Correct Triumph drivers for USB Phone FSupport


Last Updated: 2011-12-03 21:47:34
  1. richfei

    richfei Member

    Whenever I connect my Triumph via USB to my Windows XP laptop, I get a 'Welcome to the Phone F USB driver setup wizard' with options to Repair or Remove the Phone F USB driver.

    Regardless of which option I choose, this wizard continues to appear after I disconnect and reconnect my phone. It's pretty annoying

    Can someone point me to the right set of drivers to fix this problem

    I went to Motorola's website for the Triumph and downloaded something called motohelp and just installed that, but I don't think this is the right application/set of drivers

    I do see Drive E installed File manager and an autorun file alongside Phone_F_USB_Driver_v1.1.7.msi and Setup.exe
    I tried to delete these files but couldn't. Not even sure if thiis Phone F driver is really even needed since Windows can see my phone and I've been able to download from my laptop to my phone to install applications

    Advertisement
  2. bludd

    bludd Well-Known Member

    I had some drivers issues with this phone and I think I messed it up even more trying the motorola drivers and some other ones.

    I ended up using usbdeview and searching "android" and "motorola" and uninstalled all the selected devices that came up under those search terms.

    Here is a link to usbdeview for 32 and 64bit.

    usbdeview downloads - Free software downloads and software reviews - CNET

    I also manually uninstalled all the motorola drivers and whatever I installed and then ran ccleaner to clean the registry and rebooted. Afterward I plugged the phone in and used the drivers it prompted me with and installed those and all was fine.
  3. cskalski

    cskalski Member

    I just plugged my Motorola Triumph into my Windows XP workstation (Dell 2400).

    I installed the F USB driver, restarted and got the same repair/uninstall message.

    I uninstalled it, restarted the machine, checked the phone settings to make sure USB mass-storage setting was turned on and the screen-lock was off.

    Then I re-installed it.

    Same issue persists. I really only wanted to charge the phone while at work w/o having to unplug my charger at home. So, that is working just fine. All this other nonsense is superfluous, but my curiosity is peaked as to what this driver actually does to benefit me. Motorola may have to release a patch since the Triumph is brand-new on the market.

    BTW, I love the phone; especially the WI-FI at home. Also, it has a good GPS app (has a blue arrow icon) that allows me to leave my Garmin in my wife's car.

    Please let me know if anyone finds the fix (for the phone). Any sense-of -direction tips for my wife will also be welcome!

    -Chris
  4. cskalski

    cskalski Member

    While the phone is connected, opening My Computer (Win XP) will show you a new CD-ROM drive icon. If we try to open this we get the F-USB nonsense.

    However, I just noticed that there is a new removable disk drive. (mine is G, but it depends on how many drives you have as to what letter is assigned; of course).

    So, I am able to open that and move files around as I please.

    For beginners: Just open the DCIM folder to load, hear, or watch new music/photos/movies.

    Have a good week gents.

    -Chris
  5. Kamron K.

    Kamron K. New Member

    Hey,

    I just got this issue resolved for myself and thought that if ur having any of the same issues with the triumph as i was, i.e. not f***ing working for android dev lol, then i thought you would like to see the steps i took to solve this

    The steps are here.

    Thanks

    Kamron K.
  6. cskalski

    cskalski Member

    Hey Kamron K, Thanks for posting the steps to resolve the F-USB issue. I am sure someone from Motorola will see it and claim that they came up w/ it on their own and make millions off of our research! It's the American way!

    (Kidding..sort of)
    Chris
  7. poler166

    poler166 Well-Known Member

    1. Download anycut from the market (free)

    2.select "new shortcut"

    3.Select Activity

    4.Choose "Select COM Port Mode" (should be in the "s" section)

    5.Then Hit "ok" dont rename

    6.Go to homescreen and click on your shortcut "select com port mode"

    7.Next make sure that "diag" is checked and not "Mass Storage

    This also fixed pdanet for me :)
    cerem and djboi2011 like this.
  8. Chairshot215

    Chairshot215 Well-Known Member Developer


    I use a xp laptop at work and it does the same thing. dont have the problem with my computers at home running Vista and 7 so I think its an XP thing.
  9. cerem

    cerem New Member

    THANK YOU poler166. This worked perfectly. Nothing else I searched for did. Excellent explanation. Thanks man. :)


  10. Virginmobileguy

    Virginmobileguy Well-Known Member

    I was just about to give you the same steps poler 16 gave you I read the steps on Android Central from VirginMobileGuy they work great

Share This Page