Corrupted backup

Last Updated:

  1. goofyprince

    goofyprince Member


    I have a desire s which is HTCDev unlocked. For the past month or so I have been happily flashing roms between miui, cm7, cm9, etc with success. However I wanted to revert to my original rom which I took a backup of when I unlocked. I have managed to restore this rom before. Now when I try recovery reports that the backup has been restored, I flash the boot.img as normal but the phone keeps booting back into recovery instead of launching the rom. I can restore back to the IceColdSandwich rom I was using directly before so at least me phone still works. It looks like my original backup has been corrupted - is there another way to get back to the original HTC set up? perhaps using an RUU?

    Thanks in advance

  2. FoX777

    FoX777 Well-Known Member

    hmmm maybe its a lib partition problem.. Run the fastboot command "fastboot getvar all". RUU will be an easy fix, also you may as well downgraded then soff with revolutionary if you go the revolutionary route.
    goofyprince likes this.
  3. goofyprince

    goofyprince Member

    Hi, thanks for the reply.

    (bootloader) version: 0.5
    (bootloader) version-bootloader: 2.00.0002
    (bootloader) version-baseband: 3822.10.08.04_M
    (bootloader) version-cpld: None
    (bootloader) version-microp: None
    (bootloader) version-main:
    (bootloader) serialno: HT153TJ05044
    (bootloader) imei: ###
    (bootloader) product: saga
    (bootloader) platform: HBOOT-7230
    (bootloader) modelid: PG8810000
    (bootloader) cidnum: ORANG001
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 3779mV
    (bootloader) partition-layout: Generic
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: ebd3df7d
    (bootloader) hbootpreupdate: 12
    (bootloader) gencheckpt: 0
  4. goofyprince

    goofyprince Member

    I found a safe backup and tried again with the same results :(

    RE downgrading - the reason I unlocked with HTCdev is that it was not possible to downgrade using zergRush as my hboot is too new (I was getting the 'hellions with blue flames' message). How do I go about downgrading now that I have HTCdev unlocked?

    I have found an RUU - 'RUU_Saga_Orange_UK_1.31.61.1_Radio_20.28b.30.0805U_38.03.02.11_M_release_178918_signed'. On the basis that this is Orange am I ok to run this to get back to stock with an older hboot (ie already downgraded) then use revolutionary to s-off? I would like to s-off anyway as it is a pain to have to flash boot.img everytime I want to change rom.

    Thanks again
  5. InfernalByte

    InfernalByte Well-Known Member

    Try pushing a new recovery via adb and try the rom again, if that doesn't work I'd RUU.
  6. FoX777

    FoX777 Well-Known Member

    To use The RUU:
    flash any ROM that boots, change your misc version to then you can flash the RUU. still to be safe I'd create the goldcard and keep it aside to be safe.
  7. goofyprince

    goofyprince Member

    how do i change my misc version? I tried doing that when I HTCdev unlocked but got the hellions with blue flames message when trying to get temp root. On further reading it seems my hboot was too new and it was not possible to zergrush and misc version.
  8. FoX777

    FoX777 Well-Known Member

    If you flash any ROM as I said..... it will already have root thus you can ignore the temp root steps. then you can flash the RUU.
    goofyprince likes this.
  9. goofyprince

    goofyprince Member

    ok next installment...

    misc_version is coming back with an error message;

    c:\android>adb push misc_version /data/local/tmp
    adb server is out of date. killing...
    * daemon started successfully *
    1627 KB/s (589849 bytes in 0.354s)

    c:\android>adb shell chmod 777 /data/local/tmp/misc_version
    adb server is out of date. killing...
    * daemon started successfully *

    c:\android>adb shell /data/local/tmp/misc_version -s
    adb server is out of date. killing...
    * daemon started successfully *
    Error: VERSION must be a 10 character string. Length of specified string: 9
  10. InfernalByte

    InfernalByte Well-Known Member

    What does your Hboot read?

    We need everything except the radio version.
    goofyprince likes this.
  11. goofyprince

    goofyprince Member

    Hboot reads;


    Thanks again
  12. InfernalByte

    InfernalByte Well-Known Member

    Download this, put it in the root of your SD card and boot into Hboot, when asked if you want to upgrade say yes. After its done you should then be able to RUU.

    Its a PG88IMG and needs to be named exactly this (case sensitive)!
    goofyprince likes this.
  13. goofyprince

    goofyprince Member

    Thanks - Can I just check;

    The download is called ''
    I need to rename it '' and copy to sdcard root

    Is that right?
  14. InfernalByte

    InfernalByte Well-Known Member

    Lucky you did check! On thoughts of the second variety download this instead, this is HTC own engineering bootloader. Do not run the other one.

    Rename it PB88IMG and put it in the root directory of your sd card and boot into Hboot, then select yes.
    goofyprince likes this.

Share This Page