1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Corrupted EFS folder


  1. Bazooka Tooth

    Bazooka Tooth Member

    Hi there, I'm having a little trouble with my Galaxy S2, I'm a newbie to rooting and installing custom ROM's on my phone but have a rooted phone and wanted to try some different ROM's out, I knew it would be a good idea to make a backup of my EFS folder on my PC so that it wouldn't become corrupted with excess flashing, I used a program called EFS pro to do this and managed to save my EFS on PC fine, however now my phone has a number of problems, the home button no longer works, certain apps won't even open and my phone doesn't seem to be recognising my SIM. I tried to format the EFS folder and reinstall the one I had saved on my PC but it made no difference, does anyone know any ways to get around this problem, will I have to format my whole phone or is there a simple solution? Thanks for any help in advance

    Advertisement
    :
  2. Shotgun84

    Shotgun84 Well-Known Member

    Can I ask which Rom you flashed to your phone

    I'll move this over to all things root:)
    Bazooka Tooth likes this.
  3. Bazooka Tooth

    Bazooka Tooth Member

    Thanks, I'm quite new to this forum as well :p

    I think the rom I used was SGS2_XX_OXA_LPH-v5.2-CWM5

    I've looked into it a bit further and this thread seems to pretty accurately describe the symptoms of my phone, unfortunately I don't have the technical know-how to properly follow the instructions :eek:

    http://forum.xda-developers.com/showthread.php?t=1611796
  4. ironass

    ironass Well-Known Member

    That's not a ROM, it looks like a kernel.


    THose instructions are for a completely different model of phone, the Skyrocket and T989, and are not compatible with the GT-i9100.

    1. Restore your nandroid backup, assuming you have one.

    or

    2. Reflash your ROM again.

    Not a good idea to tinker with the efs file as a rule. ;)
  5. Bazooka Tooth

    Bazooka Tooth Member

    Sorry I think I posted an old kernel I used, I believe I'm using a Chainfire ROM, unfortunately I haven't got a Nandroid backup, I've heard of it but unsure how to make one, I tried reflashing the ROM again but it made no difference, I'm guessing my only option now is to save all my apps to titanium backup and format my phone
  6. ironass

    ironass Well-Known Member

    Bazooka Tooth likes this.
  7. Bazooka Tooth

    Bazooka Tooth Member

    I may well have just flashed a kernel, is it possible to root a phone with a kernel alone though? My phone is definitely rooted, thanks for the link I'll bookmark the Nandroid page, Ive already backed up all my apps to my SD card on titanium backup but thanks anyway.

    I have a GT i9100P and originally the CSC code was LPR, when I first tried rooting the phone I soft bricked it and has to flash new firmware, I've now got LPH and then I rooted it again and it worked, the problems started when I started messing with the EFS folder
  8. ironass

    ironass Well-Known Member

Loading...

Share This Page