1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

"Couldn't install on USB storage or SD card" issues with installing appsSupport


  1. mchype14

    mchype14 Active Member

    Hey all,

    So, I'm running Velocity 1.2 and it works great. However, There seems to be an issue with installing some apps. I have the default App install location set to auto, but there are some apps that won't install with an error of:

    "Couldn't install on USB storage or SD card"

    when it tries to install.

    Does anyone else have this issue? Or is there a way to fix it?

    It only started happening when I tried flashing a new theme (Thunderbolt) which screwed everything up, so I wiped everything, reflashed Velocity1.2 and it was working fine. Then I started getting these errors. Is it because it was still having issues with the .android_secure folder or something?


    Any help would be much appreciated. Thanks!

    Advertisement
  2. chevyrado14

    chevyrado14 Well-Known Member

    i started getting the same error after i flashed the ics theme
  3. SnakeDoctor

    SnakeDoctor New Member

    I just started getting the same message when trying to update apps on my SD card.
  4. SnakeDoctor

    SnakeDoctor New Member

  5. mchype14

    mchype14 Active Member

    What's so crazy, is that apparently this file described in the link you provided... does not exist on my phone. ... This is odd. I even did a search for it, and got nothing. I even made sure that all hidden files are shown...

    So I am still stuck with these BS errors. :( thanks for the try though.
  6. mchype14

    mchype14 Active Member

    So I found a temporary fix for this... and it is pretty much contradictory to what we want...

    It seems that the apps that are getting these errors are not meant to be put on an SD card. So... if you go and move them back to the phone's internal storage and then try to update them, it should work.

    It's what worked for me, but there is a reason we have a2sd and we were able to move them to SD in the first place...

    Oh well..
  7. papporght

    papporght New Member

    i almost gave up on this problem. but there is hope! haha. if you cannot see the file using file managers like astro in your phone, try mounting it in the pc.. works fine with me.. ^^
    saurav25 likes this.
  8. saurav25

    saurav25 New Member

    Ya! right "papporght" this also worked for me... I've connected the phone to the PC & searched there, there i got it & its about 8.21MB of size... Thanx!!! Dude...
  9. GrimlockDinobot

    GrimlockDinobot New Member

    Just unmount the SD card and reinstall the application.

Share This Page