Couldn't Install to USB Storage or SD Card errorSupport


Last Updated: 2013-07-14 18:29:02
  1. obsidianwings

    obsidianwings Well-Known Member

    I have a rooted LG P500h, running cm7, with a partioned sd card. I have recently started getting this error when trying to update my apps.
    There is space left on my SD Card, my internal memory, and my SD-EXT.
    All I can find on google is that a file called "smdl2tmp1.asec" is often the problem and deleting it via your computer fixes the problem, however this file appears to be nowhere on my SD card. Anyone have any other ideas? Its very frustrating. Thanks

    Advertisement
  2. obsidianwings

    obsidianwings Well-Known Member

    Never mind, ended up clearing data from the play store app which I suppose I should've tryed in the first place :/ just had an app update fine, so hopefully problem fixed. Maybe this thread will help someone in the future lol
  3. obsidianwings

    obsidianwings Well-Known Member

    I am having this problem again, the file is still not there, and clearing data is not working this time. Does anyone have any other ideas?
  4. anj_anj2008

    anj_anj2008 New Member

    Your problem will be solved by SD card unmount flow blow instruction:
    1: setting
    2: storage
    3: in sd card storage part unmount sd card
    4: install your desire applications
    5: mount sd card
    maxtein90 likes this.
  5. jackndeanie

    jackndeanie New Member

    I had the same problem. Couldn't find the file smdl2tmp1.asec and the unmount / mount trick didn't work. Finally I restarted the phone. Problem gone.
  6. adn911

    adn911 New Member

    I am having problem installing apps on my android phone saying
    "Couldn't install on USB storage or SD Card"

    one solution that i found on many forums is to go to
    Settings->storage->unmount SD card

    But i don't have any SD card . I have internal storage of 32 GB.
    What is the solution ??

    ..Thanks in advance .

Share This Page