Couple of questions about my new XperiaSupport


Last Updated:

  1. rcklss

    rcklss New Member This Topic's Starter

    Joined:
    Sep 14, 2010
    Messages:
    2
    Likes Received:
    0
    Hey everyone I am new to the forum but not the Android OS... I purchased a Samsung Captivate from AT&T yesterday and I liked it but I've like and wanted an X10 since it was released... Anyway today I returned the captivate and got the Xperia... I love the phone and the Timescape UI... I have had every Android VZW carries (I have AT&T and VZW) and the X10's UI blows them all out of the water... The phone has it's glitches but I have never owned anything in my life that didnt :) My question is i noticed that while I have the phone sitting next to me charging if I dont touch it or use it very little everything is ok... Before I had it charging and was browsing through the market and getting it setup the way i want I noticed the phone would charge for a few minutes and then the led light would stay on but the lightning bolt on the battery would disappear... I checked under the phone status under settings and sure enough it was "not charging".... If I unplugged and replugged the phone in it would start charging again then stop... I noticed the battery was very warm (from charging and heavy use i know) my question however is: is there a thermal protection that shuts the charging off till the battery cools down? is this behavior normal or has anyone else had this problem? or does this sound like a hardware issue and I should call tech support or exchange it?? I have had the phone sitting next to me screen off not in use except for the occasional txt msg or quick phone call and the battery temp has gone down significantly and the phone has been continuously charging... Thanks in advance for any help or advice you guys can offer :)
     

    Advertisement
  2. gunny5821

    gunny5821 Well-Known Member

    Joined:
    Aug 4, 2010
    Messages:
    501
    Likes Received:
    29
    Welcome! What programs are you running? Also, when the lightening bolt goes off, what percent is the battery saying it is charged at? Are you charging through your computer or through the AC adapter? When you say it gets warm, is the phone on a towel, cloth, blanket, etc..?

    Also, do you have the X10a or the X10i? What Build Number is your phone? Just ab FYI, but did you know your phone has a Screen Protector already on it from the factory? If you didn't know, don't feel like the lone ranger, many of us had ours for awhile before we noticed and no, it is not mentioned on any reviews. So no need to place a screen protector on it, or you may have trouble with screen understanding your intentions....
     
  3. NaplesBill

    NaplesBill Well-Known Member

    Joined:
    Mar 8, 2010
    Messages:
    142
    Likes Received:
    19
    If it's an AT&T branded phone it's an X10a with R2CA016.

    The battery may be fully charged and unplugging and replugging is just causing it to verify the charge then stop charging. This phone stops charging when the battery is full then restarts charging once it discharges to 90%.

    I also returned a Captivate for the X10. I couldn't be happier.
     
  4. gunny5821

    gunny5821 Well-Known Member

    Joined:
    Aug 4, 2010
    Messages:
    501
    Likes Received:
    29

    I can confirm NaplesBill's post, as my phone is working the same way yours and his does. I believe it is an internal safety mechanism to protect the battery and phone from over charging, although I couldn't find any documentation to that fact. Just like the screen protector that comes with it from the factory, no documentation or note about it anywhere, but it's there. Just one more great feature of this phone. I also returned my Captivate and got the X10, as many people here have done....

    But good question!
     

Share This Page

Loading...