Credential storage passwordSupport


Last Updated:

  1. Ryd1ZZ

    Ryd1ZZ Well-Known Member

    In settings->security there is a credential storage section with an option to set the password. I don't remember ever setting a password for this. Is there a default PW? I'm trying to connect to the Wifi at work but it asks me for this password. Anyone know whats up with this?

    Advertisement
  2. eskimojoe

    eskimojoe New Member

    The credential storage password is a password to "protect" your saved wifi network passwords. When you log on to a wifi network, the phone saves the "credentials" of the network for later use, and protects them with the password. If you forget the password- or in your case it's simply unknown- enter any password until it threatens you with erasing all your credentials. Keep entering the passwords until it does erase everything (it WILL NOT affect your data). At that point it will ask you to enter a new one, do so and it will allow you to access your wifi. I did the same thing at my University.
  3. Jitty

    Jitty New Member

    Well that didn't work. Does anyone know how you actually delete credential storage passwords?
  4. pydave

    pydave Member

    eskimojoe's instructions worked for me on my eclair xt720, but I also noticed a setting to erase your storage:

    Home > location & security > clear storage.
    teeceee likes this.
  5. Antoin

    Antoin New Member

    Thanks eskimojoe! That did the trick.
    I'm using the HTC Desire HD btw!
  6. ednunez

    ednunez New Member



    Thanks... This also worked for me on an LG Esteem.
  7. CarmieJo

    CarmieJo New Member

    This worked for me on my Evo 3D.

    Then I still couldn't connect to the secure network so I forgot it, scanned for open networks, reconnected and was able to enter my user name and password to log on to the network.
  8. teeceee

    teeceee New Member

    Thanks pydave!! worked fast on my HTC Inspire! :)
    dhyde740 likes this.
  9. MikeyCooperH

    MikeyCooperH Well-Known Member

    Thanks eskimojoe, worked a treat for me on my HTC Desire. reckon from the posts that HTC set to auto enable this function from out the box. Even clearing the storage and setting a new password auto checks use secure credential. Just disable after.
  10. coffeecupnz

    coffeecupnz New Member

    i have an htc explorer android 2.3.5 . this worked for me thanks!
  11. MandM64

    MandM64 New Member

    I have an htc sense and this worked for me as well. But the directions to clear the storage are a bit different.

    Settings > Security > Clear all credentials

    Thanks pydave
  12. terrateck

    terrateck New Member

    Hello,

    I have the same problem, but I can not remove the password.
    If I type many times, each time I get the message saying that the credentials have been eliminated, but still asking me again.

    The credentials delete option in security settings appears unchecked because really there is no certificate.

    I use Nexus 4 with Android 4.3
  13. kingdave

    kingdave Well-Known Member

    And I'm having exactly the same problem with my Nexus 5 on 4.4.2. Doesn't matter what I enter, nothing works, and there's no way for me to clear the credentials.

    It was all working fine before the Christmas break and since coming back it has been unable to connect to my work's WiFi network.
  14. sdrawkcab25

    sdrawkcab25 Guides Guide

    are you positive that your work did not change the wifi password? are you able to connect to other wifi networks? or did your work add the need for network credentials?

    if you can connect to other wifi networks fine, you will probably need to talk to your IT department.
  15. deive

    deive New Member

    Try setting your screen lock. I have a Nexus 4 ans was getting this problem. Setting my screen lock to pin allowed me to install the cert without a password prompt.
  16. Tonahtiuh

    Tonahtiuh New Member

    I used password and not a pin or pattern. coming form a Samsung Galaxy note 3 user running 4.3 thanks for the help.
  17. Tonahtiuh

    Tonahtiuh New Member


    I used password and not a pin or pattern. coming form a Samsung Galaxy note 3 running 4.3 thanks.
  18. brommers

    brommers New Member

    I tried importing a certificate into my Nexus5 recently and got this request for the device's secure storage area. Having never set this up I got a bit confused and went and tried the same thing on my ageing GalaxyS2 (good old work-horse). The S2 went through the same procedure but instead of asking for the device's secure storage area password it told me that I needed to protect access to the device through the use of either a PIN or Password for the lock screen. Given this advice, I added a PIN to the Nexus5 lock screen and tried the certificate install again - it worked perfectly this time around.
  19. apkeene

    apkeene Member

    I'm going mad with my S4 running 4.4.2. I setup a VPN (two of them) without problems. Now when I try and enter the VPN screen I get asked for my credential storage password (which of course I don't have and have never set). None of the above work arounds work. I've tried a screen lock pin, password, pattern, none. I've cleared the credential storage from the security options - which is now greyed out. I've tried getting the password wrong until it clears it, yet then it just keeps asking for a password which I still don't know and can't get right. It's not asking me to set a new one either. My carrier (3 Ireland) have recently upgraded me to 4.4.2 - I never had this problem on 4.2. So I appear to have an S4 that is incapable of accessing the VPN feature! Any clues/advice before I throw it out the window?
  20. LetsReason

    LetsReason New Member

    Everything they said below, exactly. Galaxy Note 3.

  21. DrTJ2066

    DrTJ2066 New Member

    It worked for me too... I have GLX Snowy, and i just set a PIN for my phone and it didn't ask me any password... :smokingsomb:
  22. mariarpx

    mariarpx New Member

    Had the same problem on my Nexus 5, university internet was working fine until today i got here and it wasn't i noticed the certificate was gone so i went and tried to install it again, asked me for the password but i didn't know the password so my phone automatically deleted the certificate, the first time i installed the certificate i setted a pattern code to unlock the phone and i still had it by the time my internet wasn't working so i didn't understand what was going on so i tried something: removed my pattern unlock password and tried to install the certificate again it said to me to set the pattern unlock password so i did and i was able to install the certificate and my internet is working again :D yay
  23. cida

    cida New Member

    I entered wrong PW so many times and it cleared credentials but now when I enter password it just says cred. storage cleared on and on and on.... Can someone relate to my problem by chance?!!!
    I use Android 4.4.2 with S3 samsung.
  24. DeepSukhwani

    DeepSukhwani New Member

    My PIN that I had previously set to lock my phone turned out to be my credentials storage password..

    I am using Moto E XT1022 with Android 4.4.4
  25. Brad Harr

    Brad Harr New Member

    Same issue and tried everything mentioned. This is ludicrous, there must be a solution. The VPN is unusable!

Share This Page