Custom App Groups Corrupt - Need HelpSupport


  1. powder21

    powder21 New Member

    Any time my phone starts up from a powered off state, any app groups that I have created become corrupt. Basically, in any particular custom app group, the majority (and in some cases all) of the apps I added no longer show up plus some apps that I never added to the group will be listed. I can find no rhyme or reason as to which apps get listed and I have tried creating several custom app groups just to test the problem. The system default app groups always remain unaffected. I have already tried a factory data reset and a hard reset (they seem to do the same thing). Problem persists.

    Phone has never been rooted / modified. I reboot my phone so infrequently that I can't say when the problem started. I am also worried that if this was caused by something else and the problem survives the reset, then what else might have been affected? I'd really like to know that I can fix this or that it's a bug and has to do with firmware or something.

    Please help me. Thank you.

    Model: MB855
    System: 45.4.13.MB855.Sprint.en.US
    Android: 2.3.5
    Kernel: 2.6.32.9 dnt648@fl36bld22 #2
    Build: 4.5.1A-1_SUN-254_13

    EDIT: Additionally, I first noticed the issue after having recently performed a factory reset because I suspected a malware infection. If my phone was indeed compromised at the time, could whatever caused it likely survive the factory/hard reset?

    Advertisement
    :
  2. Citizen Coyote

    Citizen Coyote Well-Known Member

    Are the apps you have installed in the custom groups stored in the phone's memory or in the on-board "SD" card app storage? I had a serious problem for a long time with apps disappearing and/or uninstalling if they were saved to the SD card, so I stopped moving them over. Wondering if something similar is happening to you.

    I don't think phone malware would survive a factory reset if you're not rooted/unlocked. Even then, it would need to get past Superuser to do anything. Do you have a physical SD card installed in your phone? Could it possibly be corrupt?

    Just throwing out ideas.
    powder21 likes this.
  3. powder21

    powder21 New Member

    Thanks for the reply!

    My phone has two storage areas: the internal storage (sd) and my sd card that is inserted into a slot by the battery when case is opened (sd-ext). All apps are stored internally. My sd card used to store music, but I don't even use it anymore for anything.

    My apps are not actually "disappearing and/or uninstalling." They are all still there and I can see them in the app manager or in the "All apps" group. There are also the "Recent", "Downloaded", and "Sprint" app groups...Each of these four groups appear by default and the apps listed in them remain unaffected by this issue. I can even add apps to those groups and they will remain listed after a reboot. The problem lies only with app groups that I have created and added apps to.

    I'm thinking the launcher might be somehow corrupted, so I've been reading up on xda to see if I can re-flash the stock ROM. I'm confused though. Apparently there is no sbf for the latest (2.3.5) OTA update. From what I've read it seems you cannot flash an older sbf if you have already installed the OTA update. However, it seems this may only be true for phones that were previously unlocked/rooted. I can't make heads or tails of that particular situation because it seems to me that your phone doesn't need to be rooted or bootloader unlocked if flashing a stock, signed sbf. However, if that's the case, I wouldn't put it pass Moto to include something in the update to ensure you could only re-flash the latest sbf and above.

    I'd really love to hear anyone's thoughts regarding the above info. Thanks again.

    EDIT: Just to be safe, I removed the sd-card and tried another hard reset without it. No affect. Same issue occurs.
  4. Citizen Coyote

    Citizen Coyote Well-Known Member

    Strange, I've never bothered with custom app groups myself so I've never encountered your problem. I assume you're running Moto's stock launcher and not a third party like Go Launcher? I don't think you can flash back to an older SBF (2.3.4) but I've never tried. Your best bet may be to take it in to a Sprint corporate store and have them take a look.
  5. powder21

    powder21 New Member

    Yes, I am (or was now) using the stock launcher. I've now fixed the issue though. I rooted my phone, made a nandroid backup, then installed the universal deblur script from Lokifish. Everything works great now.

    Thanks to Lokifish for the script!!!
    Citizen Coyote and KOLIO like this.
  6. SeaMonster

    SeaMonster New Member

    I just factory reset my phone and had the same thing happen. Most everything is fine, but app groups have lost their mind. I used them heavily prior to the FR with no issues. I even FR-ed twice but that didn't help.

    The only other thing I noticed is that when I updated the Google+ app, the icon didn't update even though the app did. But a few hours later, the new icon appeared. And if I try to open the Google+ app from the Play Store app, it says the app can't be found. This happened identically for both FRs and it doesn't happen for any other apps.

    Weird...
  7. FreeFlyFreak

    FreeFlyFreak Member

    Same exact problem as the OP and seamonster.

    I wish Moto would just dump the blur and give us plain android.
  8. KOLIO

    KOLIO NOTEoriously XPOSED Guide

    If you are indeed wanting a more stock-like ANDROID experience,I'd stop using the stock U/I & d/l the app HOLO LAUNCHER.It has an ICS look & feel + you can set up app groups just as easily,if not easier,than the stock MOTOBLUR U/I.
    damewolf13 likes this.
Loading...

Share This Page