Custom Recovery MS690 Optimus M


  1. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Attached Files:


    Advertisement
    :
  2. richiedaze

    richiedaze Well-Known Member

    Had to post... Will edit soon..
  3. danyvw

    danyvw Well-Known Member

    Installed the Recovery. Everything works fine, Nandroid Backup and restore OK, Wipe Dalvik cache OK, Installed new Kernell OK, Installed Stagefright, OC to 748 MHz Cell works stable no loops, no reboots. The only thing to mention and is that in Recovery/Flash Zip only show files/folders untill display is full (no more scroll) To be explicit: If you have 20 folders/files in your SD card, it will only show the first 15 and its imposible to scroll to the last 5.
    Thanx getitnowmarketing. Anytime (when get my paycheck) will donate for this wonderfull work.
  4. andyo70

    andyo70 Well-Known Member


    Damn I didn't even pick up on that. I guess it's a good thing I don't have too much stuff cluttering my sdcard. This is indeed a problem and could use fixing then.
    dajonsworld likes this.
  5. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    That was a limitation of adding directory browsing vs having zips only in root of sdcard. Solution since its in alphabetical order make a folder such as custom_rom and place items in that folder.
    dajonsworld likes this.
  6. danyvw

    danyvw Well-Known Member

    That's exactly what I did. Made a folder named Addons and placed zips inside. You know, like more "custom_rom" I'm going to rename it. Thanx
    crabby1594 likes this.
  7. Aplus

    Aplus Well-Known Member

    Is there a way to access this recovery through the phone itself, or can you only get to it via adb?
    dajonsworld likes this.
  8. krnla

    krnla New Member

    download terminal from the market and do the following commands:
    # Su
    # reboot recovery
    Skizr420, wilberfan1 and Aplus like this.
  9. edgchacon

    edgchacon Well-Known Member

    I have also been trying to find the key combo as well.. But I think.. you can use AneReboot...Which prompts for a normal reboot or recovery reboot. Don't know if that might also solve the issue. Gonna try it shortly.

    EDIT: Confirmed! I used AneReboot(must be rooted, of course you are..) and chose Reboot Recovery and it worked.
    jabbawest, jennson611 and wilberfan1 like this.
  10. wilberfan1

    wilberfan1 Well-Known Member

    I followed this tutorial this morning--and it actually worked! :D (It's HELL typing CLI commands on that soft keyboard though! Maybe I'll get better at it...) Once I can get the phone configured so that I can use QtADB with it, I'll be able to use my desktop keyboard? (I can't make the phone's file system mountable as rw from OUTSIDE the phone.)

    I now have a nice Nandroid Backup tucked away safely...

    And I appreciate the AneReboot tip!

    EDIT: (I don't see anything anywhere called "AneReboot". What am I missing?)
  11. edgchacon

    edgchacon Well-Known Member

    Sorry AnReboot search in the market.
  12. danyvw

    danyvw Well-Known Member

    Why its so difficult? Just Vol down+ Home +Power till LG screen appear.
    mjlove209 likes this.
  13. jawknee530

    jawknee530 Member

    Does this install custom software or is it just a step that allows you to install custom roms? I'm pretty new to android phones and want to have a solid understanding of what I'm doing before I try anything to difficult.
  14. Robzees

    Robzees New Member

    I have turned my optimus into a brick as far as Im concerned. I was deleting the Bloatware out of it and I accidentally took the browser out too, So I cant download anything. I tried this and it worked great now I just need a custom Rom so I can be back in business. Thanks so much Getitnowmarkrting. My first droid, have had it less than two weeks and I am learning so much here! someone please let me know if theres a ROM out?:)
  15. andyo70

    andyo70 Well-Known Member

    Use the rom at the top of this thread: http://androidforums.com/lg-optimus-m/256095-rom-zero-1-0-a.html

    Assuming you already have getitmowmarketing's custom recovery installed, download and put the zip file on the root of your sdcard then boot into recovery and choose "Wipe" and wipe all userdata. Then select "Flash zip menu" and from there "Flash zip from sdcard" then select "11311zerorom.zip" to flash the rom to your phone.
  16. Robzees

    Robzees New Member

    Okay, so I wrote on this thread early this morning after filing a lost phone incident with my insurance carrier yesterday. I received the new phone this morning via ups. All I can say is you guys are incredible!!!!!!!!!!!! I got home late this evening and saw your reply andyo70:D. Worked like a charm, very easy and simple. Restored my phone to new "thanks Getitnowmarketing:D as well as the rest of the guys working on this! I now have two Optimus MS690's, I can't believe I've been stuck in my laptop so deep I didn't realize that their was so much going on in the phone world until two weeks ago. The second phone will come in handy to practice with as I am so consumed with this technology and I'm sure I will do something much worse the next time around. Cheers Mates!;)
  17. rosehipzero

    rosehipzero Active Member

    Code (Text):
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system
     
    # cat /sdcard/flash_image > /system/bin/flash_image
     
    # chmod 755 /system/bin/flash_image
     
    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
     
    # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system
     
    # flash_image recovery /sdcard/recovery-thunderc-m-v1.2.0-GNM.img
    Ok, Is this within a Linux terminal in the phone or within a linux distro (I'm using Ubuntu for instance)?

    Just trying to clarify
  18. edgchacon

    edgchacon Well-Known Member

    After you install the sdk, open a CMD(windows) or terminal(linux).
    Remember you must have the SDK in your path or be in the actual directory.

    Type adb shell

    Type su

    it will get you the # prompt
  19. Silvist

    Silvist Well-Known Member

    Whoa just tried all that code in terminal, not successful. As in I could get it to give me superuser permission, but typed :

    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system

    it said access denied, any ideas what i'm lacking?

    i'm guessin the "#" is probably an enter key return, and i just literally typed out "mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system" on one line.
  20. Aplus

    Aplus Well-Known Member

    DO NOT usb mount your phone to the computer first. Just plug it in.
  21. Silvist

    Silvist Well-Known Member

    WOOOO nvm, got it~ No idea what i did, except a fresh wipe, and i restarted. I got the custom system recovery woo~ Thanks a ton, def redbull coming your way lol.
  22. Silvist

    Silvist Well-Known Member

    Not good lol, used the Kernel Thunderc-Sprint Optimus S OC, and the touch isn't working. The only actual button working is the lock button.
  23. revogozoom

    revogozoom Well-Known Member

    Just a quick question. Do I need to worry about backing up apps and such when installing only the recovery?
  24. revogozoom

    revogozoom Well-Known Member

    Ya, once I get all this figured out and get my OC going on theres definately a few redbulls coming your way.
  25. revogozoom

    revogozoom Well-Known Member

    Eh, forget it, its just a phone and it works fine the way it is. Ill drop back by in a month or so and see how you guys are coming along.
Loading...

Share This Page