Custom Recovery MS690 Optimus M


  1. revogozoom

    revogozoom Well-Known Member

    My phone is rooted and Im typing su shell and getting permissions but when I finish the first line i get "operation not permitted" this sucks, what does that mean?
  2. revogozoom

    revogozoom Well-Known Member

    Got everything going and OC'd, Ill be buying you a few redbulls this friday. Thanks!
  3. ChazzMatt

    ChazzMatt Well-Known Member


    su worked, not Su

    but now I've totally messed up my phone. what did I do wrong?

    I used this method and I just got a factory reset. No special menu came up or anything.

    now the phone is half-borked. It won't finish downloading any apps like Root Manager to access my sd card -- where all the recover files are located. it doesn't even show that I have terminal anymore.

    the market stuff is malfuntioning because of the earlier Android browser replacement attempt (a week or so ago) which is why I wanted to flash another rom.

    ===
    and su worked, not Su
  4. revogozoom

    revogozoom Well-Known Member

    those commands wont do anything more than reboot your phone
  5. revogozoom

    revogozoom Well-Known Member

    Did you enter that before installing the custom recovery?
  6. ChazzMatt

    ChazzMatt Well-Known Member

    I found that out the hard way. :( I thought that was a method to access the custom recovery rom on the sd card. I'm very new at this, although I have built computers and installed tons of software -- I am new with linux and smartphones.

    I tried using adb -- I couldn't even get it started. I downloaded the SDK files, then it made me download and install java development kit files. I did all that and still couldn't find adb. :mad: I know it's me, but there's just so much to learn about all this stuff.

    So, then I thought those commands I saw posted were a way to access that via the phone. Forget stupid adb! :p So, I downloaded terminal program for the phone from market -- and all the commands did was do a factory re-set, which did not help at all.

    The factory re-set took away my browser ability completely, since a few days ago in an experiment gone awry the stock Metro browser had been replaced by gereric Android 2.2 browser. With factory re-set it disappeared completely along with all the other browsers (Opera, Dolphin, Skyfire) I had installed. (Factory re-set does not replace stock files that have been deleted.) I knew enough not to delete the stock browser as others had mistakenly done -- but I was told that REPLACING MetroWeb browser with stock 2.2 Android browser was possible. But it's not, which is why my phone was acting wonky in the first place.

    After the factory re-set, I didn't even have a browser button on the launcher. Market would not let me re-download all my apps, just kept endlessly "downloading" without doing anything.

    =========

    Anyway, I re-installed factory 2.2 through a controversial method (thanks AndYo70) and I'm back in business. That Metro "Hello, Hello, Hello!" never sounded so good! (at that time, of course I got rid of it again. :p)

    I had apps + data on sd card through Titanium backup, but until I got stock 2.2 re-installed and rooted I couldn't use the backup. Now, I'm re-rooted and have all apps + data restored. I also have full browser functionality.

    The only problem I have now is my widgets are not loading while in Launcher Pro mode, yet they work in LG Home mode.:confused: Probably something to do with the backup restore process? I'll mess with them some more tomorrow.

    Right now I am glad I have a functional phone back! :D

    =======

    Yes, I would eventually like custom ROM but right now I'm going to breathe a sigh of relief for a day or so before doing anything else. :cool:
  7. revogozoom

    revogozoom Well-Known Member

    Just thought I'd share.

    Edit: After posting this, I discovered Linpack and get 9.6 Mflops.

    [​IMG]
  8. rodnie74

    rodnie74 Member

    nevermind i got it thanksss now i need to know how to oveclock

    i saw guys use stcpu wich version

    i use 2.1.0 and cant edit the mhz need help on setcpu
  9. unnamedny

    unnamedny Well-Known Member

    Works like a charm, thank you!
  10. rosehipzero

    rosehipzero Active Member

    Worked with ease! thanks bro =)
  11. Bleargest

    Bleargest New Member

    Trying to do this on win7 64bit. Does it matter if I use the 64bit SDK/JDK?
  12. anDROIDy3000

    anDROIDy3000 Active Member

    Sorry for the silly question but I'm a little confused as the:

    To flash: via adb shell or terminal type this from root # su shell (Do not type the # its for reference)

    What terminal are they talking about? I found one in the marketplace.....could it be that they r refering to? The custom ROMS, I've put on other devices (my PSP) are done by rebooting it and then work from there....Do I need to reboot my phone to access the flash menu?
  13. anDROIDy3000

    anDROIDy3000 Active Member

    nvm about the terminal, ya I got it from the marketplace but could someone plz simply the whole process....I typed the first command and it says "operation not permitted" I didn't USB mount, just connected it to my laptop....HELP ANYONE?
  14. joneidy

    joneidy Well-Known Member

    Just flashed it into my 2.2.1 ROOTED phone and when I reboot to recovery the screen just stays black. It will be awesome if this was compatible with 2.2.1 stock phones.
  15. sirius1y

    sirius1y Member

    First, thanks! This worked perfectly for me. Though my own fault, I lost all my apps and Titanium.. Oh well. I began my search for updating the radio. I've heard that can help get better signal. You give warning not to update radio.img at the same time, but I don't see a radio.img. Can you or anyone give me a nudge in the right direction for updating my radio? I never had any problem with signal on my Verizon phones, but who can afford them anymore...

    Thanks in advance
  16. bucketbass

    bucketbass Well-Known Member

    As I try to use TERMINAL EMULATOR and enter the code after applying su shell to the app I keep getting msgs that it cannot do that due to read only state. What am I doing wrong? Need diff app? cannot seem to get sdk to work on my windows 7 ult 64 due to some java issue which I have been trying to fix. Can anyone help me understand what I am not doing???? I feel like im stupid but I am new to android and Linux I hate to say it but it is true. I have been using some form of windows crap for years. And building my own computers and using computers since punch cards, 10" floppies, and bulk discs. So I
  17. chafin

    chafin New Member

    I can terminal to my Android with adb - even see the serial number listed, but am unable to run the code that is listed. I am assuming that you must have root priviliges before you can even run this code since it will not allow me to su. I am a bit lost here and bummed since I upgraded to 2.2.1 and lost my root capability. Any thoughts?

    C:\android-sdk-windows\platform-tools>adb shell
    $ su
    su
    su: permission denied
    $
  18. joneidy

    joneidy Well-Known Member

    If your phone came with 2.2.1 from stock you will be able to down grade it using this method http://androidforums.com/lg-optimus-m/273406-new-lgnpst-lab-1-2-thread-now-hd-video.html
    If your phone came with 2.2.1 you will not be able to root for the moment because there`s a current issue while connecting to the network on the rooted 2.2.1.

    Hope this help
    ps (I just tried it in my phone with 2.2.1 root but the recovery is not working, because of the new kernel. If this was fix it will be awesome for 2.2.1 users)
  19. mikekelso421

    mikekelso421 Well-Known Member

  20. mikekelso421

    mikekelso421 Well-Known Member

    NVM I GOT IT!!!THANK YOU ALL FOR YOUR HARD WORK!!!!WHEN I GET SOME EXTRA CASH I WILL BE GIVING A FEW DONATIONS to a few different people!!!you guys rock!
  21. bucketbass

    bucketbass Well-Known Member

    how did you get it? I still get same msg....
  22. mikekelso421

    mikekelso421 Well-Known Member

    are you rooted?? also did you download BOTH files recovery-thunderc-m-v1.2.0-GNM.img.zip and http://androidforums.com/attachment...stom-recovery-ms690-optimus-m-flash_image.zip if you did, copy BOTH files to the root of your SD card..after that,open up your cmd and type:

    adb shell
    then after that,type:
    su
    once you hit that,a # should display instead of $.once you get the #,type in the listed commands.if you already pused the downloaded files to your phone and you succeed in this last step,once its done doing its thing,power it off and reboot.then you should have service.hopefully this helps you out...ALSO YOU MUST ALREADY BE ROOTED AND HAVE SUPERUSER PERMISSIONS!AND WHEN YOU TYPE SU IN THE CMD BOX,YOUR PHONE SHOULD ASK FOR PERMISSION.ALLOW IT PERMISSION.THAT IS HOW YOU GET # INSTEAD OF $:cool:
    bucketbass likes this.
  23. joneidy

    joneidy Well-Known Member

    Hey can anyone make this work on 2.2.1 rooted phones??

    It will complete our phones.

    Thanks in advance
  24. viperman240

    viperman240 Member

    "To flash: via adb shell or terminal type this from root # su shell (Do not type the # its for reference)"
    Where am I suppose to put the code below this quote? I am stuck right now with no service and have no idea what to do now :/

    I was doing the guide for the 2.2.1.
  25. roacherz

    roacherz New Member

    I am very close to rooting my phone thanks to andy/joneidy and everyone here helping my nooby self.

    I am getting this error code when I am trying to update the SU in the superuser thing:

    an error occurred and su was not updated. A zip file (su-2.3.1-bin-signed.zip) has been placed on your sdcard, please reboot into recovery mode and flash it to update your su binary

    I did Andy's guide to flash back to 2.2 from 2.2.1 and I did that successfully.

    I finally got the ADB to work and here are the images:
    I also got that access denied in the command prompt.

    What should I do exactly , I am sorry -.- I can paypal you a few dollars I feel bad.


    [​IMG]
    [​IMG]

Share This Page