Custom Recovery MS690 Optimus M


  1. AgrussO

    AgrussO Member

    Success! Thanks for the walk-thru. I do have 1 small issue after the recovery I lost internet access for about 3 hours and it has since came back , but I constantly have weak/poor signal where it's in the past been fairly decent not sure if its related or something I may have done myself anyway to combat this?
  2. cuttingedge110

    cuttingedge110 Well-Known Member

    I have one small problem. Whenever I try to boot to recovery the screen is on but black. I have successfully rooted from 2.2.1, removed all of the bloatware and can get everything working except for this menu. I want to make a nandroid backup. I left my phone on for at least 5 mins. and nothing. Should it take this long?
  3. puyow18

    puyow18 Well-Known Member

    I'm having the same problem as cuttingedge110. Does anyone know if this is a result of something we may have done wrong, or maybe a problem on our specific phone(s)? What are the chances of having everything work as it should if one were to factory reset and start all the way back from the beginning?
  4. hav0kk

    hav0kk Well-Known Member

    2.2.1 phone rooted and followed instructions on this site to do the customer recovery. When I hold down vol up, home, power key and let go on the logo I get a black screen nothing more. Does that have to do with a stock 2.2.1 phone or is that because I've missed something?
  5. El_Colombiano

    El_Colombiano Member

    I'm having the same problem as a few others here. I have rooted my 2.2.1 and have su access but whenever I try to boot the recovery menu it hangs at a black screen. No matter what manner I try booting into it, being that of the button combo or anReboot. MUST we downgrade to 2.2 for the recovery to work? If so, a simple yes would be all that is needed. I'm trying to get my phone to OC, but I need this recovery to work properly first.

    And I *will* donate a few dollars for sure once I get this working. That is a definite. The work you have done for us is greatly appreciated.
  6. andyo70

    andyo70 Well-Known Member

    Downgrade you must. This custom recovery was based off of 2.2, therefore it is only compatible with 2.2.
  7. andyo70

    andyo70 Well-Known Member

    If you did that successfully then what is the other stuff you're trying to do? If you're truely back to 2.2 just use z4root or superoneclick to root the phone.
  8. FallOutNerd

    FallOutNerd Well-Known Member

    Any possible way this could be made into a video?????

    PLEASE PLEASE PLEASE PLEASE PLEASE
  9. ericnoid

    ericnoid New Member

    Alright great write up but im having an issue. when i type su i still get a $ and not a #. am i doing something wrong
  10. TechSys

    TechSys Well-Known Member

    Wow, lots of info here. Well, let's see if you all can help. I've gone through things quite a few times, but just can't get it. I really think I bricked the phone.

    1. Can't get # in adb shell
    2. Can't download anything from the market
    3. phone shows no phone number (guess that's why I can't dl from market)

    When I first started this quest I was able to root. I got to the point of being rooted (had terminal at that time and was able to su) and had no service. As the other topic mentioned, I came here and started on this part. Now, I have no service and all 3 of the above mentioned.

    The other topic that walked me through the rooting process was VERY easy, but now I am stuck. I feel I am overlooking something, somewhere. Everything was looking very promising until I got to this post, then things went south.

    What do I need to do now?

    I have tried doing a factory reset on phone. No go. This is actually when I lost being able to dl from the market (computer to phone). I tried going through the rooting process again. No go. I've tried and tried to get # to work. No go. What am I doing wrong?

    Any help will be appreciated.
  11. TechSys

    TechSys Well-Known Member

    Never mind. I redid everything from the start all the way to getting service again. I now have a rooted 2.2.1 Optimus M.

    I had to download a terminal.apk and use adb thing to install it. Then went through all the command line crap (typing is a pain on this phone). Rebooted using the vol down+home+power. It went straight to the locked screen. Call my home phone to see if I had service. Yup. Then went into terminal again and did an su. Got the # I was wanting.

    Now to really start destroying the phone.

    Thanks for all the info here
  12. reilus

    reilus Well-Known Member

    I think I understand it now..
  13. alexxseven

    alexxseven Well-Known Member

    dear OP lol
    ok ok, so basically this didn't work for us on 2.2.1 because the kernel it was using was for the 2.2 people. NOW someone has tooken their time to port this for us 2.2.1 people, his name is joneidy,
    (his post here)
    http://androidforums.com/optimus-m-...nally-custom-recovery-2-2-1-stock-phones.html

    ok so NOW, im wondering can we see what can be done with the kernel, is there a possibility of an overclock kernel being made as there was with the 2.2 people? im mainly interested in the OC in hopes of seeing just how great the honeycomb music player could respond, it has its latency in response to commands even at full 600mhz.

    can you get us any information on this plz? any attempts? so on so forth?
    vigos likes this.
  14. reilus

    reilus Well-Known Member

    I am formatting this message for clarity.

    Custom Recovery Instillation Problems

    mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

    Gives me the following response on 2.2:

    failed on '/system/etc/install-recovery.sh' - No such file or directory

    What does this mean? I'm proceeding anyway. Wish me luck.

    After Installation

    I got a E: bad boot message "

    I did nandroid backup, np.

    I am going to flash Rom Zero Now...
  15. reilus

    reilus Well-Known Member

    This doesn't work anymore. I can't reboot. What happened?

  16. puyow18

    puyow18 Well-Known Member

    reilus - make sure when you are inputting the commands via adb that your phone is no longer in MASS STORAGE mode. you put it in mass storage mode to place the two image files on the sd card, then unmount the sd card. so now your phone is still connected via usb and still in usb debugging mode. then run the commands from adb shell and you shouldn't have the "no such file" error anymore.
    that's what worked for me anyway. hope it helps you too.
  17. jennson611

    jennson611 New Member

    Ok for your guys that get a black screen on the recovery this happend to me i just followed the steps again and tada it worked plus in adb use the adb reboot recovery cmd its a bit easyer
  18. jennson611

    jennson611 New Member

    [/QUOTE]

    After Installation

    I got a E: bad boot message "

    I did nandroid backup, np.

    I am going to flash Rom Zero Now...[/QUOTE]

    the setup info says you will always get the E; bad boot message
    so dont worry or feal bad lol
  19. sookieball

    sookieball Well-Known Member

    OMG THANK YOU SO MUCH! IM A NOOB WITH ADB AND TO THE OPTIMUS (NOT TO ROOTING AND SUCH)

    AND THIS WAS ALOT EASIER THAN I THOUGHT!

    thank you!
  20. This has got to be the most confusing thing ever...su shell...su...can some one give some concrete solutions......it's a lot of info here that does not work......it's says you can do from phone...yet no one says anything about ...read privileges...can you do this from the terminal on phone or not.....if so can someone please put up the right information...thanx...keeps saying read only file....cannot create system directory...can someone point me in the right direction....
  21. Kalwren

    Kalwren Member

    After installing the custom ROM and rebooting the phone, the main screen shows at the top "Problem loading widget".

    What widget is that?

    Also, the Android Market is missing.

    Did I do something wrong? Everything went smoothly during the install.

    I figured it out. I'd failed to install gapps.
  22. DemizE

    DemizE Well-Known Member

    did everything down to a T. Now when I get to the recovery menu the only button that works is the UP volume button and it scrolls me through the menu but no other button works. I can scroll down but not back up. Cannot select anything on the menu. Any reason this is happening?

    Will donate once this actually works properly for my phone. Thanks.
  23. pmb116

    pmb116 Well-Known Member

    Any news on a custom kernel for 2.2.1? Getitnowmarketing? I know that you had started to work on it.
  24. jabbawest

    jabbawest Well-Known Member

    n00b in training, with a question.
    Rooted my phone following http://androidforums.com/optimus-m-all-things-root/291343-hd-video-root-optimus-m-2-2-1-a.html
    I also installed AnReboot but when I chose Recovery Reboot, I saw the open box with the droid splash screen but never got the Recovery Menu.
    Once the phone finished booting up I was greeted with a stock phone, although it was still rooted.
    Luckily, I was able to use Titanium Backup to restore my apps and data.

    What did I do wrong?
  25. puyow18

    puyow18 Well-Known Member

    jabbawest - if your phone came stock with 2.2.1 (not 2.2 then upgraded to 2.2.1) you need to use a different custom recovery found Finally Custom Recovery for 2.2.1 stock phones !!!!!! by joneidy.

    Notice the difference in the custom recovery screens (from little android guy to some crazy graffiti/tattoo design).

    Also, when inputting the commands in adb, be sure that you take your phone out of USB mass storage mode (you only enable this to put the image files on your sd card). Hope this helps.

    btw - if you need more instruction not in video form, go to joneidy's thread Root 2.2.1 and get Data WORKING!!!

    good luck!
    dajonsworld and jabbawest like this.
Loading...

Share This Page