Custom recovery Optimus One P500/Thunderg


Last Updated:

  1. angel_garcia

    angel_garcia New Member

    Joined:
    Dec 26, 2010
    Messages:
    3
    Likes Received:
    0
    then if don't show # as root in the "Terminal Emulator", how could she change $ to #?
    Thanks in advance.
     

    Advertisement
  2. getitnowmarketing

    getitnowmarketing Well-Known Member Developer This Topic's Starter

    Joined:
    Apr 27, 2010
    Messages:
    477
    Likes Received:
    788
    su
     
    angel_garcia likes this.
  3. badeaioan

    badeaioan Member

    Joined:
    Aug 31, 2010
    Messages:
    13
    Likes Received:
    3
    I managed to do a nandroid backup, but I cannot restore.

    I get an error message, something with ADB. Sorry I haven't kept in my mind the entire sequence.

    Any help would be apreciated.
     
  4. sahilisburman

    sahilisburman Member

    Joined:
    Dec 27, 2010
    Messages:
    6
    Likes Received:
    0
    I am new to android and i have optimus one i have rooted my phone using z4root. I am a complete noob pleae tell me how to use the code in adb shell

    i cannnot understand how to do this step
     
  5. badeaioan

    badeaioan Member

    Joined:
    Aug 31, 2010
    Messages:
    13
    Likes Received:
    3
    Go to market and download Terminal Emulator.

    After that launch it and type SU. Click Allow. After that type all the commands listed above.

    Good luck !
     
    sahilisburman and Djinn Moto like this.
  6. 4wd vege

    4wd vege Member

    Joined:
    Dec 19, 2010
    Messages:
    20
    Likes Received:
    9
    My Lg Optimus Ones will not boot. Might this be able to fix the problem?

    I have no back ups as phone died whiling trying to do first back up.

    I am guessing the emulator lets you type commands on the phone??

    If so it is probably not what I need.
     
  7. thesmoth

    thesmoth New Member

    Joined:
    Dec 28, 2010
    Messages:
    1
    Likes Received:
    0
    This tutorial is easily the most frustrating thing i've ever had to follow. I'm typing these comands into the terminal emulator with no errors, yet it just doesn't work.

    I have the two image files on my SD card, I rooted with z4root before that, and it doesn't work.

    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system

    # cat /sdcard/flash_image > /system/bin/flash_image

    # chmod 755 /system/bin/flash_image

    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

    Here it says now, failed on this, no such file or directory. But the first time I did it, this worked.

    # mount -o remount,ro -t yaffs2 /dev/block/mtdblock1 /system

    # flash_image recovery /sdcard/recovery-RA-GNM-thunderg-1.1.0.img

    I did this, then it said it failed part way through because something was missing or corrupt, then I went back to start again and it doesn't work now. what the hell.

    # reboot recovery
     
  8. claudiutou

    claudiutou New Member

    Joined:
    Dec 26, 2010
    Messages:
    1
    Likes Received:
    0
    someone please help ms as i am desperate here trying to flash custom recovery on my p500 optimus one.I did everithing correctly as mentioned but it get stuck on flash_image recovery /sdcard/recovery-RA-GNM-thunderg-1.1.0.img does nothing from this point i have tried at least 30 times and nothing if i restrat pushing down home+pwr+vol key it will delete all my apps and everything.I will make a big donation if can help me get thru with this i spent a lot of nights trying to do this.
     
  9. badeaioan

    badeaioan Member

    Joined:
    Aug 31, 2010
    Messages:
    13
    Likes Received:
    3
    Bump ! I experience this too. Any ideas ?
     
  10. manekbhavin

    manekbhavin New Member

    Joined:
    Nov 26, 2010
    Messages:
    2
    Likes Received:
    0
    followed all the steps mentioned. when i hit

    # reboot recovery

    my phone re boots normally and all the data is wiped off and i get the LG P500 basic 1st time set up screen! can anyone tell what went wrong?

    EDIT: While using the ADB commands i had mounted my SD card which i guess caused the problem.
     
  11. manekbhavin

    manekbhavin New Member

    Joined:
    Nov 26, 2010
    Messages:
    2
    Likes Received:
    0
    Can you elaborate how your problem got solved?
     
  12. 404 Not Found

    404 Not Found New Member

    Joined:
    Dec 29, 2010
    Messages:
    2
    Likes Received:
    0
    When i boot into recovery mode, i don't get a menu or anything just the splash screen in the background of the OP's picture and it reboots.
     
  13. sahilisburman

    sahilisburman Member

    Joined:
    Dec 27, 2010
    Messages:
    6
    Likes Received:
    0
    SUCCESS! ATLAST I OPENED MY O1 IN RECOVERY MODE BUT THERE IS A PROBLEM.
    1) when recovery mode opens background has a pic with exclamation mark on it ind in the last line a message is written "E: bad boot message.

    Please tell me how to resolve it
    Thanks in advance
     
  14. 404 Not Found

    404 Not Found New Member

    Joined:
    Dec 29, 2010
    Messages:
    2
    Likes Received:
    0
    Update: Now it either won't let me because of a lack of a signature, or no update script
     
  15. sahilisburman

    sahilisburman Member

    Joined:
    Dec 27, 2010
    Messages:
    6
    Likes Received:
    0
    i know you will find this question stupid but still help me out :p

    I partitioned the sd card with 512 mb ext partition. but now what to do further? i mean to say how to move all apps to the ext??
     
  16. getitnowmarketing

    getitnowmarketing Well-Known Member Developer This Topic's Starter

    Joined:
    Apr 27, 2010
    Messages:
    477
    Likes Received:
    788
    Quoted from 1st post

    "Note this recovery and the one for the LG Vortex have a service that instantly reboots out of recovery once you load it & I disabled it and thats why you get a E: "Bad Boot Message" on inital startup. Its completely fine."
     
  17. getitnowmarketing

    getitnowmarketing Well-Known Member Developer This Topic's Starter

    Joined:
    Apr 27, 2010
    Messages:
    477
    Likes Received:
    788
    Requires custom scripts and or rom. Look for custom roms available for device.
     
  18. getitnowmarketing

    getitnowmarketing Well-Known Member Developer This Topic's Starter

    Joined:
    Apr 27, 2010
    Messages:
    477
    Likes Received:
    788
    Thats stock recovery. You didn't flash custom recovery properly or didnt remove the install-recovery.sh.
     
  19. S3nd41

    S3nd41 Member

    Joined:
    Dec 5, 2010
    Messages:
    11
    Likes Received:
    0
    Hello,

    I want to make a backup of my current default rom before messing around with custom ones and deleting default system apps. That flash_image and the recovery .img you provided will simply enable me to get into debugging mode from where I can make a backup of my current default rom, right? It will not flash my rom with any custom roms or will it? Also, afterwards how can I restore my default debugging mode if I need to reclaim my cell phone warranty or something?

    If you could explain step-by-step what all of those commands do it would be nice also. I'd like to understand the whole procedure before trying this out.

    Thanks!
     
  20. HellGate

    HellGate New Member

    Joined:
    Jan 1, 2011
    Messages:
    1
    Likes Received:
    0
    how to add languages to this rom ??

    i already have my arabic fonts , there is any way to put it in the system ??

    This rom is fantastic !!
     
  21. ccdreadcc

    ccdreadcc New Member

    Joined:
    Dec 4, 2010
    Messages:
    2
    Likes Received:
    0
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system
    # cat /sdcard/flash_image > /system/bin/flash_image
    /sdcard/flash_image: invalid length
    #
     
  22. Omnichron

    Omnichron New Member

    Joined:
    Dec 1, 2010
    Messages:
    4
    Likes Received:
    0
    It worked beautifully. I am now the proud owner of an Optimus T P509 rooted and custom ROM'd. I installed Amber Home V 1.1 on it. Thanks guys!:D
     
  23. angel_garcia

    angel_garcia New Member

    Joined:
    Dec 26, 2010
    Messages:
    3
    Likes Received:
    0
    I too work well in my LGP500, I only had a small problem with some commands enter spaces, but now is ok. I too installed Amber Home V1.1 and work ok. Thanks.:)

    some question more,
    when I download an application, where default is saved, in phone memory or partition ext3 Memory Card (512 mb)?
    Can I know how much memory as ext3 microsd card I am using. :eek:
     
  24. Sigma47

    Sigma47 New Member

    Joined:
    Jan 6, 2011
    Messages:
    1
    Likes Received:
    0
    Fabulous method! I would suggest adding that one needs to unzip the necessary files that you provide: the recovery image and the flash_zip. I would also clarify that if the install-recovery.sh script is not found its still a go for those that aren't down with linuz and his CLI speak. Thanks!
     
  25. johno168

    johno168 New Member

    Joined:
    Dec 27, 2010
    Messages:
    1
    Likes Received:
    0
    Can someone please help me. I'm basically a newbie and don't know how to install this, I just don't get every thing after "To use copy flash_image and recovery-RA-GNM-thunderg-1.1.0.img to the root of your sdcard." and then im stuck on flashing with adb and terminal and shit like that, and people at school call me a nerd hahhaa
     

Share This Page

Loading...