Custom recovery Optimus One P500/Thunderg


Last Updated:

  1. indypan

    indypan New Member

    Please help, while I tried to do custom recovery, I got the following error message::confused:

    permission of flash_image:

    Please help, thanks!!

    Advertisement
  2. xowhd5428

    xowhd5428 New Member

    i run
    cat /sdcard/flash_image > /system/bin/flash_image
    on terminal emu and keeps saying error of
    /sdcard/flash_image: No such file or directory

    same error for the chmod 755 command as it cant find



    FORGET THE RECOVERY FLASH

    I ACCIDENTALLY BRICKED MY PHONE AND MANAGED TO UNBRICK!!!!!
  3. xowhd5428

    xowhd5428 New Member

    If I want to change back to stock recovery mode, can i just
    mv /system/etc/install-recovery.sh.bak /system/etc/install-recovery.sh

    since u mentioned that this evil script overwrites ur whatever recovery mode to the stock one
  4. anotherloony

    anotherloony New Member

    Hi, I have a litttle problem with gui mounts.
    I cannot mount sd-ext. Give me "/dev/block/mmcblk0p2 no such device" error. Partion is created fom recovery "partion sdcard" menu
    ext partition is ok I checked via adb and parted, also mount works in adb.

    Thank you for your great work.
  5. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    No, you will need to flash_image back the stock_recovery.img


    On android 2.2 the vold has changed and breaks that addition on many 2.2 devices. It can still be busybox mounted or mounted in recovery via shell.
  6. heaven666

    heaven666 New Member

    Hello

    I have one problem with the custom recovery and I need your knowledge because I don't saw any post about that...
    I have partitioned my SDcard with one ext4 partition. So I use app2sd. The Dalvik-cache and applications are on my SDcard.
    So far nothing unusual, so good !... Except that I can't wipe the SD/ext-partition through the custom recovery.....
    I tried several times to wipe Dalvik-cache and SD:ext separately and the cache to be sure, but in each time when I put after my SD-card on my PC, I can see that the partition is not empty ! All the repertories still be there including Dalvik-cache which isn't empty !
    So I tried to mount the ext-partition through the custom recovery and I have this code error who appears :

    Code (Text):
    1. E:Can't mount /dev/block/mmcblk0p2
    2. (No such device)
    Is anybody knows what the problem ?
    I followed the tutos correctly to root my phone and for install the custom recovery. I also tried to completely repartition the SDcard and keep the format in ext2, but nothing works !
    It drives me crazy ! I don't understand where I forgot something !

    Regards,
  7. dryhte

    dryhte Well-Known Member

    Got my PayPal account in order and donated :)
  8. FairCold

    FairCold New Member

    where is the nans backup + android_secure is located anyway?
  9. Pamela

    Pamela Active Member

    Not sure if i missed a post about this, but when i boot into recovery i get this message "E:Bad boot message" under all the custom recovery options, what does this mean and how do i fix it :)

    also thanks for putting this custom recovery together for all of us!!!!
  10. albert88rules

    albert88rules New Member

    Hi folks,
    Its ma first post here. :)
    I have an optimus 0ne p500.. I have rooted the phone.. When I try running the commands as given in this post everything seems to be working ok. No errors. However, once i enter "reboot recovery" in adb shell.. it reboots the phone but into the stock OS factory reset.. I have checked the commands & they look ok.. Tried this thrice, Same issue.. Any help & suggestions would be great.. :confused:
  11. dongimin2

    dongimin2 New Member

    When i try to flash the Custom Recovery by Thunderg, i get a whole lot of errors. i posted this somewhere else, but it was too undetailed i guess. Repost

    # flash_image recovery /sdcard/recovery-RA-GNM-thunderg-1.1.0.img
    When I type the above command, (with all the nessessary stuff done before)
    I get like so many errors, at least 50 lines. Read some of them

    (P.S. There was no extra line breaks on the emulator, i just made them to look good)

    # flash_image recovery /sdcard/recovery-RA-GNM-thunderg-1.1.0.img

    mtd: read error at 0x00000000 (Out of memory)
    mtd: read error at 0x00020000 (Out of memory)
    mtd: read error at 0x00040000 (Out of memory)
    mtd: read error at 0x00060000 (Out of memory)

    *repeats this pattern untill it reaches 0x004e0000 in hex*

    mtd: write error at 0x0000000 (Out of memory)
    mtd: re-read error at 0x00000000 (Out of memory)
    mtd: write error at 0x0000000 (Out of memory)
    mtd: re-read error at 0x00000000 (Out of memory)
    mtd: skipping write block at 0x00000000

    *repeats above 4 lines untill 0x004e0000 is reached*

    error writing recovery: No space left on device
    I guess it means i have to delete some apps? but i have more than 100MB free...

    P.S. I used a branded rom.. i have a UNbranded 2.2.1 (guess i cant use that..) and a BRANDED (sobs) 2.2 rom. Does it matter?
  12. aclarridge

    aclarridge New Member

    I have this exact same problem, fewer errors but same end result. I just bought this phone. Help!
  13. aclarridge

    aclarridge New Member

    Well, it isn't the exact same, it says:

    mtd: not writing bad block at 0x001a0000
    mtd: not writing bad block at 0x00320000
    mtd: not writing bad block at 0x00340000
    error writing recovery: No space left on device

    Any and all help is greatly appreciated!
  14. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    \

    You are out of virtual memory. Reboot and flash recovery after fresh reboot.
  15. aclarridge

    aclarridge New Member

    I'll try again when I get home, but that was after a fresh reboot...is there anything else it could be?

    EDIT: Thanks for the help though, where are my manners :)
  16. albert88rules

    albert88rules New Member

    Folks, I have an optimus 0ne p500.. I have rooted the phone.. When I try running the commands as given in this post everything seems to be working ok. No errors. However, once i enter "reboot recovery" in adb shell.. it reboots the phone but into the stock OS factory reset.. I have checked the commands & they look ok.. Tried this thrice, Same issue.. Any help & suggestions would be great.. :confused: Help.. Help.. Help..
  17. oticam1

    oticam1 New Member

    please help me when ever i try to put in "su" i just tells me permistion denied ever time someone please help.



  18. oticam1

    oticam1 New Member

    please help me when ever i try to put in "su" i just tells me permistion denied ever time someone please help.

  19. Omnichron

    Omnichron New Member

    beautiful work man. I am having so much fun trying out different ROMs and overclocking my android with this. Thank you so much man! you rox!:D
  20. Omnichron

    Omnichron New Member

    have you rooted your phone phone first? If so, make sure usb debugging is turned on and and you click yes in the allow window that will come up on you phone when you type su.:)
  21. randms

    randms New Member

    hi, i'm new here :)
    please help me, I've followed all the step by step correctly and I'm sure there's nothing I missed cause I've re-checked it hundred times.... but when I entered this command

    i got an error message like this:

    at the first time i thought it was a normal process so i continued to the next command #reboot recovery and i got my device reverted back to the stock ROM but with the superuser still in it, means that is already rooted.

    Then I tried repeating all the steps but it still stuck at the same error at the same command.

    Can anybody help me with this? :-(
  22. xciton

    xciton New Member

    I preformed a nandroid back as soon as I install this customer recovery. I keep the nandroid folder that was created. I then installed Megatron. All went well.

    I'd like to flash back my factory firmware that I had that I backed up with nandroid.

    What steps can I expect to do and how foolproof will this be? Is it all menu driven from the recovery tool or will i need to use adb for some of it?

    Thanks, I'd hate to brick my phone..
  23. BobbyTheNinja

    BobbyTheNinja New Member

    When I use the "adb devices" command, it lists my Optimus S as "?". I have tried installing the recovery with no errors, but when I reboot into recovery, it just stays on the LG logo screen forever, so I have to remove the battery and turn on the phone again. When I turn it back it, it boots normally, and runs normally. When I try turning on the phone to recovery (vol down+home+power), it gives me a black screen, and I have to remove the battery again. I haven't been able to find a solution to this anywhere. Anyone have an idea?
  24. satishenl

    satishenl New Member

    I used the mentioned mechanism to install custom ROM. Then I saw a nice theme for clockwork mod. I just copied the recovery_image file and accidentally restarted the mobile. The mobile got bricked. I used the KDZ tool to flash my original firmware. Now I cannot root. Please help, cause ,my phone has become from slow to dead. :(

Share This Page