Custom Recovery Optimus S/ Thunderc-sprint

Last Updated:

  1. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Attached Files:

    jmzsctt, loudang and zefie like this.
  2. zefie

    zefie Well-Known Member

    we have to look at the certs since the RC1 and beta refuse to take a LG-issued update.
  3. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Custom recovery uses test keys. You will never have lg's private key.
  4. boytek

    boytek New Member

    works like a charm thanks
  5. RaSpewTin

    RaSpewTin New Member

    Do we have a way to revert back to stock recovery?
  6. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

  7. bloodbought

    bloodbought Member

    After flash_image recovery /sdcard/recovery-RA-GNM-thunderc-s-1.1.0.img I got several of these errors:

    mtd: re-read error at 0x00660000 (Out of memory)
    mtd: skipping write block at 0x00660000

    Tried mv /system/etc/ /system/etc/ to get recovery back but got a read-only file system error.
  8. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    If you get the oom error reboot phone and do it with phone freshly rebooted.

    The other error is from you not mounting /system as rw.

    Bad block errors if any indicate that you have some bad nand flash blocks on device (google it for info) and thats a build defect in your particular phone but depending on the location/serverity may prevent a custom recovery flash.
  9. bloodbought

    bloodbought Member

    Thanks. Worked great.
  10. zefie

    zefie Well-Known Member

  11. jackpearce

    jackpearce New Member

    everytime i type
    cat /sdcard/flash_image > /system/bin/flash_image
    i get : no such file or directory.

    what am i doing wrong? i have both zip files on the root of my sd card

    got it working. i didn't extract the files. my noob is
  12. viper134

    viper134 Member

    I rooted using the application from the market. Then installed terminal emulator bc it isn't recognizing my root when i do it through the computer. typed in su got super user permissions, everything works fine until I get to the point where i do mv / system/etc/ /system/etc/, it says it failed and no such file or directory
  13. jackpearce

    jackpearce New Member

    I had the same problem. What worked for me was adding .bak after the first .sh
  14. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    It doesnt exist on all roms. If its there in yours those commands disable it. If its not there move to next step.
  15. 2kmy477

    2kmy477 Member

    I'm a noob,how do i get to the #,when i typed adb shell,it became a $ prompt.
  16. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    assuming you are rooted type su at the $ and allow superuser permissons on the pop up on phone and it will change to a root #.
    2kmy477 likes this.
  17. 2kmy477

    2kmy477 Member

    Thanks for your help.Where do I get the flash_image file,I only downloaded the .img file from your first post.

    Edit,I got the file.But when I enter mv /system/etc/ /system/etc/, I received "Cross-Device Link" error,how do i get around this?thanks.
  18. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Need a tester for this new recovery version before I roll it out for all the optimus line as the recovery binary is shared across all of them. Please post feedback.

    changelog: v1.2.0
    Allow flashing of zips from directories like clockwork does.
    Updated wipe menu and is no longer using script to wipe.
    updated kernel to allow ext3 & ext4 formatting in recovery.
    changed some sd-ext stuff for better apps2sd ability.

    Link pulled

    md5 1a455af64abed8bf9d3e49d932f3fd38

    As always please verify md5sum before flashing.

    follow 1st post instructions to flash but change this line as the recovery name is different
    Code (Text):
    2. flash_image [B][COLOR=black]recovery[/COLOR][/B] /sdcard/recovery-thunderc-s-RA-1.2-GNM.img
    zefie likes this.
  19. zefie

    zefie Well-Known Member

    Posted on AC thread. Getting mixed up now. lol.

    - v1.1.0 had a weird issue where wiping .android_secure doubled up the confirm and success messages, did not test with this one

    - Request wipe system option since there is no other way to recover a corrupted mtd partition than recovery's wipe

    - v1.2 beta says "press VOL-DOWN to return" instead of "press BACK to return" on all submenus. The buttons, however, are mapped correctly, so it is just a cosmetic issue.

    - Thanks again for the hard work :)
  20. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Thanks for the feedback. I ported this over from my new incredible one and forgot the vol-down. The 2x comfirm message on 1.1 was due to a script that Im not using anymre so should be fixed. About the wipe /system I'm not going to add that as many users could totally mess up thier phone from wiping /system. If you need to manually remove it boot into recovery and via adb shell do /mount system then rm -rf /system twice. Users do not do this command unless you know what you are doing as /system will be lost and not recoverable except with nandroid restore. Zefie you could also do a zip with Format:SYSTEM in update script.
  21. zefie

    zefie Well-Known Member

    Well as i explained in the other thread, clockwork has it and it was useful because when the mtd partition gets corrupted, you can';t fix it any other way

    flash_image system system.img will return ECC errors, nandroid will fail because for some reason it wants to mount before flashing the image, and I had no recourse except to flash smccloud's clockwork recovery, use it's wipe system, then come back to your recovery. I'm talking when it gets so corrupted that you can't mount it.

    Like I said on AC, perhaps stick the option under "Other" or somewhere not frequently traveled. I wish there was a command line option, I tried everything that day i messed up my MTD.

    Though I suppose I could try to make an update-script that just wiped everything, it would just be easier to have it as an "Advanced" option
  22. zefie

    zefie Well-Known Member

    Also the new SD browser does not scroll so I can't even get down to

    If the number of directories exceeds screen space you are SOL.

    Liked the old one better.
  23. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    I'm going to continue with the new directory browsing. Place those zips in say a custom_rom folder as its neater than having all them in root of sd.

    I added the code you wanted to my github but commented it out as I think it will cause more damage to the masses than the benefit it will give. If you want to make one for your own use personal use uncomment that code and compile the recovery binary.

    Download fixed

    md5 154f1b8f73c02d0d1ccad4b6e5ec3562

    Try that one should have the vol-down fixed.
  24. zefie

    zefie Well-Known Member

    Request for this to be placed in /sbin in recovery image:

    Usage: if your partition is corrupted, this util can restore them.

    For example:

    Code (Text):
    1. /sdcard/nandroid/mem=477M/BCDAS-20101130-1927 # mount /system
    2. mount /system
    3. mount: mounting /dev/block/mtdblock5 on /system failed: Invalid argument
    Uh oh! My /system is corrupted. Better do a restore..

    You try a nandroid restore, it tells you to run

    But that doesnt work either.

    Code (Text):
    1. Restore path: /sdcard/nandroid/mem=477M/BCDAS-20101130-1927
    2. error: unable to mount /system, aborting
    Oh no, my phone is screwed.. or is it? :)

    You need to wipe your partition.

    flash_eraseall /dev/mtd/mtd5

    Now your nandroid restore works! :)

    Code (Text):
    1. Unpacking system image...
    2. end of image
    3. Restore done
  25. chinochino360

    chinochino360 Member

    on the second comand i get this

    cat /sdcard/flash_image > /system/bin/flash_image after this i get this

    invalid lenght////////////////////////////////// got it oops it wasn't extracting the zips correctly
    yeah i know it sounds weird but i had to do it through estrongs file explorer

Share This Page