1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Custom Recovery Vortex/Thunderc-vzw

Last Updated:

  1. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Attached Files:

  2. Trident

    Trident VIP Member VIP Member

    Thanks drellisdee! :D
  3. Finalchrono

    Finalchrono Member

    I tried to flash mine using your commands, but I was getting a ton of errors from the commands. The mount command said I wasn't using it properly for one thing.
  4. This is amazing...thanks. first android phone so I don't know if i'm missing something here but, this command would not work for me. i can't remember what error it gave me, so after i get home I'll try it again and post the error. Of course, i tried reboot recovery anyway and it wiped my phone. good thing i had Tb installed, but that thing is a pain to restore with! i wish there was something that automated the restore process instead of having to click "ok, install" for _every_ app.
  5. Finalchrono

    Finalchrono Member

    Yea I put in the mount command and it said that I used the mount command wrong, then I tried the command you're talking about and it gives me a read-only error.
  6. Trident

    Trident VIP Member VIP Member

    Then you're not mounting the file system as read/write as it says to do in the original post.
  7. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    the mount command is needed to give read/write access to /system to copy flash_image to it and make it executable and also to rename install-recovery.sh (if it exists).

    The only part thats may be optional is the "mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak" if you get an error that this file is not found as it may not exist on every phone.

    Make sure you aren't typing the # and have a rooted phone and have issued the command 'su' from adb shell to change the $ to a # indicating you have a root shell. Also, you must accept the superuser pop-up the 1st time you do a 'su' from adb shell too.
  8. Finalchrono

    Finalchrono Member

    I am following the instructions word for word, and it's not working. I even copy-pasted the exact code, and it won't work right. Yes, I went into shell and issued su, showing the "#" then entering the commands. I'll try again real quick, maybe it just didn't like me at that time.

    Edit: Ok it's working now. Not sure why it wasn't earlier. However, now when I issue the command #6 to flash the recovery, it says my image file doesn't exist, even though it's on the root of sdcard with flash_image. It was successful finding flash_image, but can't find amon ra's? I believe this is the same problem steele was having.
  9. Kevin82485

    Kevin82485 Member

    I'm new to the scene here. What does this posted guide do to your phone?
  10. probably the same problem.

    initially I had a different error, this is the one that occurred after I copied the flash_image file to the appropriate location. yes, the files were unzipped, etc.
    i think when i rebooted the first time after running this code it modified the flash_image file, it turned into a 34kb file. in the interest of science, i overwrote it with the [un]zipped 10kb file again, and executing the command gave the same error. :confused:

    another question I have is, what effects would renaming the install-recovery.sh file have, especially if left that way for a while? Is it used actively, or only when a recovery is initiated? is it replaced when we execute your recovery rom?
  11. this replaces the stock recovery image, allows you to make backups (as listed in the op) and gets you on the way to loading a new custom rom.

    speaking of, are there any made that we think will work with the vortex yet, or will clockworkmod or cyanogen have a version that should work?
  12. Finalchrono

    Finalchrono Member

    I don't recommend using clockworkmod. It still isn't compatible with it. I tried fooling around with it and it bricked my phone. Anyway, not sure about this but I don't think this phone has a recovery.sh file on the phone. I would think this would be consistent with all vortex, seeing as there's only the one model. I could be wrong, if so please correct me.
  13. This one did....it let me execute the mv command without error. Maybe it created the .bak file....i didn't check to see if the .sh existed before though.

    •I checked you're right and I don't think it exists on this phone. I have a 400b file named "install-recover.sh.bak". I didn't even spell it right!
  14. Finalchrono

    Finalchrono Member

    No, it did exist on your phone. The command was to overwrite the file by placing a new extension on it. So, you did have it, and honestly I don't think the spelling matters as long as you know how you spelled it in case you need the file later.

    I flashed mine fine now. However, I was wondering if it is possible to overclock this phone further? I read it was already overclocked to 600mhz but the phone lags a good bit on some applications. That is replace the kernel for the 1ghz kernel I found? Angry Birds for one is laggy as ever.
  15. Oh. I figured a file that small wouldn't have any content, especially nothing relevant to an install or recovery function. I'm only somewhat familiar with unix commands but my concurrent adventure in linux has been helpful.

    so how did you get the recovery to successfully flash? I hope it wasn't giving the same command until it worked....
  16. Finalchrono

    Finalchrono Member

    It depends on the error. Though, if you wait 1 minute in between each line of code you put in, it helps the process move along better. I don't know the specifics on the hardware design, but i'm thinking the system cache must be very small because my first successful issue of the command gave me an out of memory error.

    Oh and there's no point in issuing the last command to reboot the recovery if you didn't actually flash it.
  17. That doesn't sound very successful...doesn't really make sense either. How many times did you run through the commands? It doesn't seem beneficial to do them more than once, from what I understand cat will append the file on the sd card to the system file, and than chmod 755 changes permissions to owner r/w. Then the last command of course flashes recovery. Flash_image is the binary command, recovery is the object to flash, and the thunder c image is what to flash with. So what could be going wrong here?i hope the dev will chime in with some thoughts soon.

    Have you rebooted into recovery yet?
  18. Finalchrono

    Finalchrono Member

    Yea, like I said it flashed mine fine. I've already run a successful nand backup. I don't see why you're getting an issue with html. Have you rooted your phone? Also, did you run a checksum on the download?
  19. Rooted, wouldn't have gotten this far without doing so. Checksum ok on the recovery image, didn't see one for flash image. I imagine the difference in success might have something to do with the reason I had install-recovery.sh and you didn't. I hope not though...but it would be my luck cause dumb crap like that happens to me all the time
  20. brianmaedche

    brianmaedche Well-Known Member

    Hi i cant get to the Android System Recovery menu. When my phone reboots after i type everything in it resets itself back to when i first got it and removes all my apps and contacts. Any help would be great.

    WOOT WOOT just got this to work after two days of trying :)
  21. Finalchrono

    Finalchrono Member

    I don't know. How did you root your phone? I used z4root. I do wonder if it makes a difference if you use the terminal app on the phone to do everything. Maybe you might want to give that a try.

    Oh and every time I entered adb shell, I would retry every command, only skipping mv seeing as I don't have the file. Just in case.
  22. Used z4 root did temp root until right before I tried the flashing -at that point I did permanent., tried multiple times both adb and term, most recently in term even though it's more of a pain. Maybe I'll try rerooting and adb a few more times :p
  23. bejer

    bejer New Member

    Got this running on my phone great, Thank you!
    I have a question about if I ever need to go back to stock..
    I am a noob to Android, but have limited experience in linux (Ubuntu)
    How would I restore the backup that was made of the stock file?

    This is what i think it would be, but I don't want to try it and brick my phone just to find out.. Hoping some of you with some experience at this could tell me if I'm on the right track.

    Code (Text):
    1. # mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    3. # rm /system/etc/install-recovery.sh
    5. # mv /system/etc/install-recovery.sh.bak /system/etc/install-recovery.sh
    7. # mount -o remount,ro -t yaffs2 /dev/block/mtdblock4 /system
    9. # reboot recovery
    VillageIdiot6710 likes this.
  24. bolski

    bolski Well-Known Member

    Does anyone have an image of the vortex with the default factory settings? I "modified" mine by removing default programs, so I'm worried when a system upgrade comes, it won't work.

    Also, when I install the new ROM, I know I lose all the app settings I had (although I can get them back if I do the nand restore), so is there any way to get those back? For example, games that I have been playing I've gotten really far in so I don't want to have to start over. Most, if not all of them are on my SD card. I've been reluctant to reinstall them under the new ROM image for fear that I might lose my game status, settings, etc.

    Or, do I have to pretty much start over?

  25. bolski

    bolski Well-Known Member

    Thanks to bhast2, I was able to get back to version 2.2. Just go here and follow his directions. Remember, this is for LG Vortex phones that are running 2.2.1:

    steele ferwick likes this.

Share This Page