Custom Recovery Vortex/Thunderc-vzw


Last Updated:

  1. Jessemn

    Jessemn New Member

    someone please help my phone is rooted downloaded emulator from market when
    I type in the second line I keep getting "invalid length" error I have no idea whats
    Wrong I unzipped on sd root folder "flash image" is there file too. Inoticed if I type in
    "su shell" no # sign just $ so ive been just typing su then line 1, but line 2 keeps
    Givimg me that error shoulld I put 1.1.0 after flash_image. Im a noob obviously and about
    To chuck phone lol

    Advertisement
  2. bgoode2006

    bgoode2006 New Member

    i literally just flashed mine and installed the rom. so far im not having any problems. its running smoother and nothing is acting wrong.

    Thanks for the tut...
  3. Do you have a copy of that downgrade file? the link appears to be broken on his site now.

    available here:
    Downgrade LG Vortex from 2.2.1 | Technoheads
  4. bhast2

    bhast2 Active Member

    sorry about that I had a server problem and I am still trying to get everything worked out

    files for the downgrade are being uploaded again
  5. jgramkow

    jgramkow Member

    I keep getting a " failed on '/system/etc/install-recover.sh' - No such file or directory"

    Edit: I see it "may be optional"? should I be concerned and can I continue?
  6. Kevin82485

    Kevin82485 Member

    When I boot into the Android system recovery, I notice at the bottom that this message appears:

    Build : RA-thunderc-vzw_v1.1.0_GNM
    E:Bad boot message
    ''

    When I try to flash recovery-RA-GNM-thunderc-vzw-1.1.0.zip it spits this back at me:

    E:No signature (1 files)
    E:Verification failed

    What does this mean?

    ##UPDATE##
    I figured out that I needed to go to Other>Toggle Signature Verify to resolve the verification issue. However, after repeating the flash zip from sdcard again, I get this message:

    E:Can't find update script

    Once again, what does this mean?
  7. Fward1208

    Fward1208 New Member

    This command does not appear to work. it states that flash_image doesn't exist. I downgraded my phone, and rooted it with z4root.
    cat /sdcard/flash_image > /system/bin/flash_image

    Edit: I did a search with Astro file manager and it shows flash_image file in /system/bin/
    Therefore, I'm guessing that the command is no longer necessary? So, then why would it not boot into the custom recovery when I use the key strokes?
  8. robbadobba82

    robbadobba82 New Member

    Hello,

    I am following the steps properly..I think. Using andexplorer. I've unzipped the file to my root but when I try to run the program, it says it cannot open file. Is this a problem with an explorer? I have no idea on any other way to access the recovery.

    Thanks!
  9. stinkybudz

    stinkybudz Member

    Hello, I am having trouble at the second command. I get into adb shell and after I type the command it says invalid length. Should I downgrade to 2.2 to make things easier? Any help would be great, Thanks.
  10. for those of you having problems, the fix appears to be to just keep trying, eventually something will click and it will work. i attempted the same set of commands at least 10 times before it finally flashed (just make sure you are entering everything exactly as it says there, copy and paste is the easiest method of doing so). kind of frustrating, even more so with lack of support from the dev. appreciate the work dev, but kinda pointless if people can't get it to work easily.
  11. i believe you have to downgrade in order to perform this flash.
  12. ksimp88

    ksimp88 Member

    OK, those instructions aren't easy to understand at all. What the heck is ADB, and how do I load the shell? I'm new at this, bear with me. But I'm a fast learner.
  13. mussio

    mussio Well-Known Member

    worked perfect on my vortex thanks for the hard work.
  14. bolski

    bolski Well-Known Member

    Okay. how to I remove the custom recovery? I want to upgrade my device to the latest 2.2.1 and then try to root it again as per instructions I found that allow it to root 2.2.1.

    However, I did what I thought was correct, but every time the update reboots my phone, I go into the custom recovery menu, which prevents the update.

    How do I get rid of the custom recovery menu?

    Thanks!
  15. stinkybudz

    stinkybudz Member

    I was able to root 2.2.1 but it was a pain. I had all sorts of problems with trying to install this recovery so Im not sure if it will work on 2.2.1. I just downgraded to 2.2 and am trying to grant superuser access to the shell but after I allow it I get the $ instead of the #. When I try and run the first command it says; mount: not permitted. I ran super one click at first but that didn't take, so I ran z4root. Any ideas???
  16. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    $ means you have a user not # root shell

    you need to issue su from shell 1st to invoke a root shell.
  17. stinkybudz

    stinkybudz Member


    I did allow adb shell su permissions. After I enter adb shell, I have # but after I enter su shell, I get the $. Any ideas? Should I root this stupid thing again? I have rooted and installed custom roms on over 10 different androids, and the Vortex has given me the most hell. I just want to get this thing dialed in so I dont have to mess with it anymore. I used superoneclick and z4root. I have installed a different boot animation so I know I have root. Thanks.
  18. stinkybudz

    stinkybudz Member

    I think I got it working. I entered su instead of su shell and got #. Now yet another problem lol. After I enter the second command line to flash_image it says- no such file or directory. I know I have the flash_image on the root of the sd. Any ideas?
  19. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    did you unzip the flash_image.zip ?
  20. stinkybudz

    stinkybudz Member

    Yea, I sure did. I unzipped it and it put it into a folder named Flash_Image so I tried it with the file in that folder and when that didn't work, I moved the flash_image file onto the root with no luck. Heck, I even renamed the file and tried that and adb shell still didn't find it. Im at a loss...
  21. jcnogo

    jcnogo New Member

    I don't get it...

    I followed all the steps. My phone is rooted. Running 2.2.1 (I used Super One Click)

    I get to the recovery screen after following all the steps where and can make backups and get the, E: "Bad Boot Message"
    which is supposed to be fine.

    I've gone through these steps 2 times now with out any problems other than the no backup file exists.

    But as soon as I restart my phone and attempt to enter custom recovery either through the key combo or through terminal emulator on my phone it just loads the factory reset and wipes my phone.

    Edit: I got it working!
    With help from this post:
    http://androidforums.com/droid-all-...y-coming-back-custom-recovery-wont-stick.html

    I used the easier method mentioned.
    using root explorer:


    All credit goes to patch.
  22. ksimp88

    ksimp88 Member

    I figured it out. Found a Shell app
  23. Yourdaddy420

    Yourdaddy420 Member

    I have a LG vortex its stuck on the verizon screen and its say downloading do not unplug its does nothing more than that. is there anyway i can send my phone to you so you can fix it? plz
  24. meskes

    meskes New Member

    Hey guys. I have a somewhat related question regarding the Vortex ROM project. It seems that the project has seemed to have died off. I tried the channel on freenode and I was literally the only one in there and from the looks of it, all the links have been pulled or are null'ing. Has the project moved or am I correct in assuming that it is now defunct?
  25. Happydevil

    Happydevil New Member

    Took some assistance from a tech savvy friend of mine to get it up an runnin but tje rom runs fantastic, overclocked to 806 stable, 3 day battery life, thing runs like my brothers droid global, wish I coild buy ya a beer bud but too broke, so ill give a nice cheap compliment :) great work man :)

Share This Page