Custom RingtonesTips


Last Updated:

  1. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
    Where do I have to put my custom ringtones in order for them to show up in the ringtone menu?

    I've put them in sdcard/Ringtones and sdcard/media/ringtones. I tried with .mp3 files, then renamed them to .ogg. Rebooted multiple times. No dice.

    Any ideas?
     

    Advertisement
  2. Me_Droid_Freak

    Me_Droid_Freak Daryl Bowman

    Joined:
    Apr 4, 2013
    Messages:
    172
    Likes Received:
    40
    Are you rooted? If you are try /system/media/ringtones/
     
  3. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    I just copied the .mp3 to /storage/emulated/0/tlaNET/Ringtones

    tlaNET is a folder I added of stuff I was introducing.


    They immediately showed up in the list in Settings | Sound | Phone ringtone

    I also have a /tlaNET/Notifications

    In both cases they are .mp3 files and root-ing is not required (good thing since its a Maxx).

    ... Thom
     
  4. Old Member

    Old Member Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    2,586
    Likes Received:
    1,905
    The Maxx is not rooted yet.
     
  5. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,590
    Likes Received:
    1,881
    They can be in any folder anywhere on storage called "ringtones" ( for ringtones) or "notifications" (for notifications.) I know that they can be in MP3 or ogg vorbis formats, and I think AAC works as well. I'm not sure about other formats.

    (I just checked and I do have a few .m4a ringtones. .m4a is the extension for AAC files.)
     
  6. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
    Odd... I'll have to play around with this and figure out what the problem is. The tones play fine on the Galaxy Nexus. No idea what would be different.
     
  7. rjack22

    rjack22 Member

    Joined:
    Feb 4, 2012
    Messages:
    22
    Likes Received:
    1
    Odd. I put my MP3 ringtone under SDcard/Ringtones and it works fine.
     
  8. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    It has been the same on Droid stuff through at least 4 models.

    In the past each time you powered on it would scan looking for Ringtones and Notifications folders everywhere. It would look for files in the folders (I only used mp3) and add them to the lists.

    If you had multiple folders with copies of the same sound files it would add them multiple times. If you did not reload they would not show up.

    On the Maxx they show up as soon as the folder is created.

    ... Thom
     
  9. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
    Well, I'm stuck. I created 4 new ringtones just now (all 30 seconds, about 500kb each), put them in the Ringtones folder, restarted, and they still aren't showing.

    Screenshot_2013-08-29-21-38-16.png

    Would anyone mind sharing the mp3s that have worked for them? Also, would anyone mind using the mp3s I made to see if they work for you? Hopefully this link works:

    Ringtones.zip
     
  10. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    This is the ONLY thing from iPhone that I ever found I liked. I use it for notifications.

    ... Thom
     

    Attached Files:

  11. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
    No go. Downloaded, moved to sdcard/Notifications, restarted, doesn't show.

    I'm stumped.
     
  12. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    I don't know where that is ... screenshot?

    ... Thom
     
  13. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
  14. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,590
    Likes Received:
    1,881
    Even though /sdcard seems to be the same place, my phone's default storage location seems to be /storage/emulated/0

    In there I have a folder called media

    In media, I have a folder called notifications and ringtones. These files are seen by my phone. I also noticed that there are folders /storage/emulated/0/notifications (empty on my phone) and ringtones (there are two ogg vorbis files for Google Hangouts intones, based on the file names.)
     
  15. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    I admit to being lost. I don't know where that folder is located. I was expecting something like these. Here you just copy the .mp3 file into the Notifications or Ringtones folder.

    ... Thom
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      126.2 KB
      Views:
      18
    • 2.jpg
      2.jpg
      File size:
      45.9 KB
      Views:
      14
  16. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
    As doogald said, I believe /sdcard/ and /storage/emulated/0/ are mirror images of each other. Anything moved to one location is automatically copied to the other. Therefore, my mp3s do exist in /storage/emulated/0/Ringtones as well as storage/emulated/0/media/ringtones and storage/emulated/0/media/audio/ringtones. Still not showing up.

    I honestly don't know what else to try.
     
  17. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,590
    Likes Received:
    1,881
    I'll download yours and pop the into folders on my phone later today. I'll let you know if I see them.
     
  18. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
    Thanks. If they work for you, I may just have to factory reset and hope that fixes something on the internal storage. I'm out of ideas.
     
  19. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    I played with it a little for you and it seems to be a little quirky.

    I went to /storage/emulated/0/Notifications and pasted in the file I provided ... I went to Settings | Sound | Default notification sound it is in the list.

    I deleted it and did a power off/power on and went to /sdcard/Notifications and pasted in the file I provided ... I went to Settings | Sound | Default notification sound it is NOT in the list. I powered off and powered on and went to Settings | Sound | Default notification sound it IS listed.

    When you said "restarted" did that mean power off/power on?

    The only "off the wall" suggestion I can make it try pasting it into /storage/emulated/0/Notifications and see if it is immediately provided in the list.

    ... Thom
     
    mcadam likes this.
  20. mcadam

    mcadam Well-Known Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    119
    Likes Received:
    33
    Well I think you solved the mystery. I just did the same and pasted the ringtones directly into /storage/emulated/0/Ringtones. They all showed up immediately. So even though /storage/emulated/0 and /sdcard/ are supposedly identical, they obviously aren't from a functional standpoint.

    I think my issue stemmed from using ES File Explorer as my file manager, as it's default location is /sdcard/. I noticed "File Manager" defaults to /storage/emulated/0/. Looks like I'll be sticking with File Manager going forward.

    Thanks for your help everyone.

    **EDIT**

    Scratch that last part. You can change the default location in ES File Explorer to /storage/emulated/0 in the settings. I'll stick with ES File Explorer for the style.
     
  21. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    It is ODD. It is sort of like it is reflected in one direction.

    It still should have worked the way you were doing it if you were doing a full power off/power on.

    Weird.

    Glad it is finally working.

    (I wonder what other counter-intuitive oddities we will run into.)

    ... Thom
     
  22. elaine98

    elaine98 Member

    Joined:
    Mar 15, 2013
    Messages:
    10
    Likes Received:
    0
    I've been following your conversation with interest. I have had this problem for quite a while. I have a folder listed as Ringtones. SOMETIMES when I have my phone hooked up to my computer, then afterward my ringtones and notifications have disappeared from the list where I can choose which I want. When I hook it back up to the computer it shows the folders are still there. In the past just deleting and repasting (while hooked on my computer) has solved my problem. But this time it hasn't. Everything I've tried hasn't fixed the problem. Any suggestions? I am flummoxed with all the referencing to "internal" "external" and yet another "internal" locations. I've read and read and can't make heads or tails of where to put my ringtones and notifications. Here is a screen shot:
     

    Attached Files:

  23. elaine98

    elaine98 Member

    Joined:
    Mar 15, 2013
    Messages:
    10
    Likes Received:
    0
    To clarify, when you are "pasting" are you doing this thru windows explorer while hooked to your computer or thru a file manager on your phone? Thanks!!!!!!!
     
  24. elaine98

    elaine98 Member

    Joined:
    Mar 15, 2013
    Messages:
    10
    Likes Received:
    0
    Sorry for the multiple replies.....I have done exactly like you said above, and it still doesn't appear in the list when choosing a ringtone or sms notification. I've lost my custom tones before but never had trouble reinstating them. I'm out of ideas. Any suggestions would be GREATLY appreciated!!!!!!
     

    Attached Files:

  25. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,690
    Likes Received:
    4,225
    The folder can be anywhere on your phone.

    The last level in the name must be Notifications.

    If you are connected to a computer then you might not access them.

    Try restarting (power off/power on) and see if they are then reported as present.

    ... Thom
     

Share This Page

Loading...