Custom Rom for Pendo Pad


  1. ag011090ag

    ag011090ag Active Member

    Hi everyone, I am in need of a romdump for the pendopad as i wish to recompile with cyanogen cm5 or cm7 2.2+ i use public computers and cannot install android sdk or adb shell required for dumping.

    -----------------------------------------------------------------------
    My goal is to implement a 2.2+ or even 2.3.7 cyanogen modifications onto the pendo pad,
    The reason it is very hard to root and mod this device is due to the fs it uses on internal storage, most android devices use yaffs fs this is easy to root and gain r/w ability, the pendo pad uses cramfs much harder to root permanantly so one must dump there firmware into a update.img decompile add what they want recompile and use RKBatchUpgrade.exe to flash to device,
    -----------------------------------------------------------------------
    So I will start with removing the CPU govern on the rk2818 i wish to extend it to the full 1.2ghz capability.
    I will minimise partition use to free up RAM and NAND storage.
    Re calibrate Touchscreeen and keys (long press circle button for mute)
    Add support for more 3g usb devices
    implement ADW and Cyanogen Settings (dev and spare parts+)
    remove bloatware
    add newest market and optional gapps
    add more languages when required.
    change boot animation and logo (green android fullscreen and cyanogen bootanimation)
    remove unneeded notifications and ringtones that are just taking up space.
    add APP2SD native
    -----------------------------------------------------------------------For this to be possible I need a romdump from somebody, The completed rom will be available for everyone to use but i cannot step foward without the dump. Thanks
    -----------------------------------------------------------------------

    Advertisement
  2. ag011090ag

    ag011090ag Active Member

    This is only for windows users.
    Also only for rockchip 2818 not for other ones!!!

    What do you need
    Z4Root
    SU
    Winrar < Not included in package!
    ADB
    Android drivers
    Rockchip drivers
    Rockchip flash program
    SD card or internal memory on the device self (150mb atleast)
    USB Cable

    Programs can be downloaded in this package.
    So al the progams you need are in the rar file.

    1. Preparing the device
    First install Z4Root and SU on you're device.

    Then start Z4Root and click on ''Temporary Root" he will root the device for you and after reboot you will loose the root access so don't reboot!

    After that connect you're device to an windows machine he will ask you to install drivers.

    Install the drivers and then start CMD
    (Windows XP: Start > run > CMD > Enter)
    (Windows vista and 7 Start > Type CMD > Enter)

    now locate to the ADB.exe folder i recommended to place it in the C: root.
    so type this in CMD
    cd C:

    when you are there type this command.
    adb push rkdump /data/

    After that type adb shell
    this command bring you to a terminal like command line for you device.

    Ok now watch you're device and type su in cmd.
    A popup will show up to get SU access for terminal press "allow"
    Now we can backup the FS.

    type this in cmd
    cat /proc/mtd
    a list will popup like this one

    mtd0: 00002000 00000010 "misc"
    mtd1: 00004000 00000010 "kernel"
    mtd2: 00002000 00000010 "boot"
    mtd3: 00004000 00000010 "recovery"
    mtd4: 00030000 00000010 "system"
    mtd5: 0003a000 00000010 "backup"
    mtd6: 0003a000 00000010 "cache"
    mtd7: 00100000 00000010 "userdata"
    mtd8: 00cbc000 00000010 "user"
    mtd9: 00020000 00000010 "pagecache"
    mtd10: 00020000 00000010 "swap"

    i made one red because that the line we need.

    NOTE: we need backup partition so look always to mtd number not every device have backup as mtd5 it might also be 6 or 1 or some other random number!

    Now it is time to backup!
    type this
    /data/rkdump /dev/block/mtdblock? /!!!/update.img

    place the number of the mtd on the ''?''
    if example your number is 6 use it like this
    mtdblock6

    place the destination backup folder on the !!!
    flash for the tablet internal memory
    sdcard for to backup on the sdcard

    if you did this good it will say this
    update.img found (116115456 bytes) < File size may be difference depends on device.

    after it is done it will say this
    crc found (4 bytes, 0x0709e735) < Also this could be difference
    done

    Gongrats you backup you're FS now you can destroy you're device with custom roms!


    2. Restore you're FS

    Sometime you will see you destroy you're device what now!
    Good thing you made a backup of you're FS!
    First Hold back/ecs button on you're device just hold it and put the usb cable in it.
    (From pc to the tablet ofcourse)
    you're pc will give you a driver notice install them (included from the package)
    After that start RKAndroidBatchUpgrade.exe
    Then choose in settings you're backup and press ''Upgrade''
    Wait a few seconds or minutes and you are done.
    congrats you can use youre device again!
  3. ag011090ag

    ag011090ag Active Member

    Come on People Help me out here.. i need that dump file so i can create custom rom for everyone to use
  4. kingosoul

    kingosoul New Member

    Hey mate are you still after a dump of the firmware because if so I will dump my devices tomorrow if you are in need.

    Regards,

    James
  5. ag011090ag

    ag011090ag Active Member

    Still need it thanks
  6. ag011090ag

    ag011090ag Active Member

    Hey hows that dump coming??
  7. ag011090ag

    ag011090ag Active Member

    why no dump?
  8. betabrain

    betabrain New Member

    i will give it a go but have no idea how
  9. ag011090ag

    ag011090ag Active Member

    hey mate the instructions for rom dumping are above your post. would be greatly appreciated if you could do it for me
  10. betabrain

    betabrain New Member

    the link isn't working (multiupload not responding)
    please reupload
  11. drbogg

    drbogg New Member

    ag011090ag
    you had any luck with this yet ??

    Dr.
  12. WacKEDmaN

    WacKEDmaN Member

    after fighting with adb on win7 for 2 days...i installed the SDK and google drivers...the driver provided above says it did not contain information for my hardware..on both win7 and xp..the google driver installed fine on xp but im just getting "device offline" from adb (unlike device not found) on win7...

    so xp..adb connecting fine...i try the steps above..i cant get rkdump to the data folder even tho im rooted with z4mod..so i pushed it straight to /flash/ (2gb free on the 4gb pad!)..next i run cat..get whats show above..and move on to actually dumping..so running rkdump from flash..oops no execute perms!..so hunt around with a esfile explorer in root mod and found a folder that had wr-x perms..i copied rkdump to this folder /data/app-private/ and then set execute permissions on rkdump in that folder..i can now run rkdump from adb...and make a dump finally!

    so what i want to know now is...do i need to dump all the partitions? (ive got boot, kernel, recovery,system and backup)..
    what do i now do with my update.img? (backup) ..
    and how can i get into it to add and change things?..
  13. GTOJOE

    GTOJOE New Member

    I have a Pendo 7" rk2818 I would like to root also. Subscribing for updates.
  14. RaNGA93

    RaNGA93 Member

    I tried this as well and got this error:

    failed to copy 'rkdump' to '/data//rkdump': Permission denied

    from this command ''adb push rkdump /data/"

    any suggestions?
  15. SubnormalNeb

    SubnormalNeb New Member

    RaNGA93 I had the same problem, install terminal emulator from the android market onto the pendo pad and type in the following commands without quotes, "su" then press allow on the popup, "chmod 777 data", then you can go back to adb and use the command, when the file is copied, use "chmod 777 data/rkdump"
  16. SubnormalNeb

    SubnormalNeb New Member

    ag011090ag, do you have the update.img? i would love to have a custom rom for my pendo pad, cant wait
  17. RaNGA93

    RaNGA93 Member


    I installed terminal emulator, when i type su the response is ''not found''
  18. WacKEDmaN

    WacKEDmaN Member

    ..the instructions given above by ag011090ag dont work 100% correctly..
    and from researching...cyanogen is not possable on rk2818 (its been discontinued on their site)...
    but it is possable to make a rooted/custom rom

    first..download RKcooking.zip from RK2818 Kitchen for windows - SlateDroid.com
    unzip the folder to the root of C drive (else the bat file will cause errors)
    it contains ALL the files needed (you dont need the android sdk)

    next..install Z4root to your pad and then temp root
    [APP] z4root - xda-developers

    you will also need a root file explorer (i use latest version of ES File Explorer in root mode)

    once you have root on the pendo..connect usb to the PC AND turn off USB storage on the pendo once it has connected to the pc (pull down notification drop down and select Turn off USB Storage)
    next, open command prompt, change folder to c:\rkcooking\
    type the following to upload 'rkdump' to the pendo...

    adb push rkdump /data/app-private/

    now on the pendo, start the root file explorer, navigate to /data/app-private/ edit the properties/permissions on rkdump so that its executable

    now we want to find which mtdblocks to backup..so back to command prompt, type the following...

    cat /proc/mtd

    you will get the list of mtdblock..take note of which blocks are "backup" AND "system"...on both my pendos they are mtd5 and mtd4.. (system needs to be dumped if you want to make any changes to apps, the one included inside the 'backup' image is locked..so we just dump a unlocked copy straight from the pendo)
    now we dump these images to the SD card...
    still in command prompt, type...

    adb shell

    once you are connected to adb, at the $ prompt type..

    su

    then watch the pendo, it should popup asking to allow and unknown app to have superuser rights, click yes..then go back to the adb prompt and type the following to dump 'backup' image to SDcard..

    /data/app-private/rkdump /dev/block/mtdblock5 /sdcard/update.img

    wait for it to finish..then type to dump 'system' image to sdcard

    /data/app-private/rkdump /dev/block/mtdblock4 /sdcard/system.img

    remember to change the mtdblock number to match your pendo!
    congrats! youve now backed up your pendo roms!

    from there u can copy the img files to the pc..run the rkcooking.bat to unpack/edit/re-sign...

    ill go into more detail of that once ive done it! but heres a hint..newtuxflashtools allows you to edit the dumped system.img to remove/add apps

    edit:also noticed flashing does NOT require the pc connected, android will find the "update.img" on the SDcard and ask if you would like to use it to flash the firmware..so remember to remove it from the SDcard or you will get popups everytime it scans for new media..

    edit2: my 2 pendos are very different..the old one (2Gb) has an update.img size of 65mb..my new pendo (4Gb) has an update.img size of 103mb.. but theres no extra apps..ill have to look into it a bit more to see whats different

    edit3: the difference seems to be...4gb pendo has some extra fonts, ALOT more usb_modeswitch files..and a file /etc/wireless/rt2870sta/rt2870sta.dat (wireless folder doesnt exist on 2gb pendo)..also config for dhcpcd_eth (2gb only has dhcpcd, 4gb has both)..
    and some files related to adobe which arent on the 2gb (its not flash player tho!)
  19. RaNGA93

    RaNGA93 Member

  20. WacKEDmaN

    WacKEDmaN Member


    i think its discontinued...and the issues with stuff not working out weighs the benifits of flashing it to a pendo

    http://androtab.info/cyanogenmod/rockchip/ as you can see..rk2818 is closed..and work is only continuing for rk2918 tablets
  21. WacKEDmaN

    WacKEDmaN Member

    ive been successful in flashing a modified rom (just updated es file explorer, taskmanager and maps, removed quickoffice, that handwriting app, and a few of the live wallpapers i never use) ...

    i originally tryed flashing my 4gb image to a friends 2gb pad (after dumping his original backup.img and system.img)..but it just crashed on boot just after the little android icon appears..so i flashed his original rom back and all was fine...

    next i used newtuxflash to edit his dumped system.img (not the one thats in update.img..its locked!).. i removed the apps and then flashed it back.. (both methods work, from file on sdcard called update.img or from USB & RKAndroidBatchUpgrade.exe pointing to the .img on your system).. some of the apps didnt show up...i checked the system.img i editied with newtuxflash and found the apks had spaces in the names, once i removed the spaces, signed the system.img and reflashed, they all showed up perfectly, even entirly new ones (battery meter on the notification bar)

    next i will workout how to add su/root

    for anyone looking for a rom...the best way is to make your own i think..RKCooking.. linked a few posts above.. has everything you need to dump, modify, sign, and flash YOUR own ROM (everything except a temp root tool and root file explorer to workaround a few issues mentioned above) theres too many different versions of the pad out there (yet they all have the same model number!)
  22. RaNGA93

    RaNGA93 Member

    WacKEDmaN, did you flash android 2.2 or newer or are you still running android 2.1 ?
  23. WacKEDmaN

    WacKEDmaN Member

    2.1...
    i dont think its possable to get 2.2 AND all the features running correctly..everything ive read has said that rk2818 does not support 2.2..hence the broken/unfinished features and stopped dev of cyanogenmod..

    i may try flashing the 2Gb pad with cyanogen..not really sure tho..i dont really like the idea of changing the bootloader and kernel..

    btw...i changed the build.props in my latest ROM hack version to change the LCD screen density..i changed it to 120 and it had the effect of making the resolution larger, and making everything smaller, allowing more menu items etc to show on the screen..ive read that the market as problems it is not set to 160 or 240..but its working fine (actually shows more apps than my 4GB pad!)

    also added a few tweaks to build.props that ive found on the web...seems to be the fastest pendo ive used! (faster than my 4GB!)

Share This Page