CWM not launching on CF-Root kernel ...


Last Updated:

  1. bbbc

    bbbc Member

    Hey guys,

    I'm currently running CF-Root 4.1 kernel on my SGS2, but no matter what I try, I cannot boot into CWM recovery.

    I've tried both ways, using Volume Up + Home + Power and also using the shortcut in the CWM app that ChainFire has provided.

    Problem is, it only ever boots into Android System Recovery (3e).

    Any ideas?

    Thanks

    Advertisement
  2. heshanj

    heshanj Well-Known Member

    hmm strange.. which CF root kernel are u using, KG5? maybe u could try flashing it again?
    did u flash a stock kernel to remove the yellow triangle? u need to flash the zImage file from the CF root zip file afterwards.. i cant think of anything else, really. coz if u just flashed a CF root kernel, u should defnitely have CWM
    bbbc likes this.
  3. steslatt

    steslatt Well-Known Member

    As heshanj said really, sounds like you flashed stock kernal to remove yellow triangle then didnt flash the zImage after. Try the zImage again and if that doesnt work try flashing the cf root again in odin.
    bbbc likes this.
  4. bbbc

    bbbc Member

    Hi guys,

    Yes, I flashed KG2 zImage back using CWM afterwards.


    Hmm, maybe when CF releases 4.2 it'll be fixed. But any other ideas?
  5. Slug

    Slug Check six! Moderator

    Just to be clear, the steps are:

    1. Flash CF-Root (yellow triangle appears on reboot)
    2. Copy stock kernel TAR package and CF-Root zimage to /sdcard
    2. Restart in download mode and flash stock kernel using Odin to remove triangle
    3. After restart flash CF-Root zimage from within CWM app to regain full root functionality (triangle will not reappear)
    bbbc likes this.
  6. heshanj

    heshanj Well-Known Member

    if u did the process exactly as slug has mentioned, then it should work fine.. u shouldnt need to wait for a CWM update to get it working.. i hope u get it sorted out soon :)
    bbbc likes this.
  7. bbbc

    bbbc Member

    Gonna reflash CF-Root from odin then do the triangle removal process again.

    Will update!

    Update: same thing guys. I'm still getting the regular recovery and not CWM after doing what Slug had suggested.

    I'll run it again but not remove the triangle for now. See if that helps ...

    Update 2: So CWM will now launch if I don't do triangle removal. I'll stick with this until I figure out another solution I guess.

    Thanks for all the help anyway! Appreciate it.
  8. heshanj

    heshanj Well-Known Member

    hmm i really find it odd, its the stock kernel being flashed thats doing it, i see..

    so ur using a KG2 firmware, with KG2 CF root kernel.. right? u downloaded the stock kernel from intratech's thread on xda and flashed the .tar file via Odin..
    then u unzipped the CF root zip file, copied the zImage file into sd card .. and flashed the zImage file via CWM Manager, selecting Flash Kernel?

    i dont see how this could go wrong. i guess u could stick with the yellow triangle but i found that annoying! :D
  9. bbbc

    bbbc Member

    Yup, everything is KG2, stock kernel from intratech's thread as well.

    I'll have to live with the yellow triangle for now, until I figure out what it is that's making it not work
  10. Slug

    Slug Check six! Moderator

    Just to confirm, you did reflash the zimage from the CF-Root file?
  11. bbbc

    bbbc Member

    Yup, I still had root after yellow triangle removal
  12. Slug

    Slug Check six! Moderator

    This is a strange one.... what version of CWM is installed? It says at the top of the app window.

    Can you also confirm what is displayed for Kernel and Build number in Settings/About phone?
  13. bbbc

    bbbc Member


    I've got CF's v2.0

    Kernel 2.6.35.7-I9100JPKG2-CL342890root@DELL104 #2

    Build number GINGERBREAD.UGKG2


    PDA: I9100MUGKG2
    Phone: I9100MUGKG2
    CSC: I9100MBMCKG2

    Build Info: Tue Jul 12 10:19:43 KST 2011


    I've got a Bell Galaxy S2 from Canada if that makes any difference. I read that I can use any stock kernel, as long as the KG2 part is the same. The one I used was the XSG JPKG2 from intratech's thread.
  14. Slug

    Slug Check six! Moderator

    So that's the stock kernel.

    Just to double-confirm, if you then use CWM to flash the zImage from Chainfire's KG2 CF-Root package CWM stops working?

    Something's not right.... booting to recovery with a stock kernel should land at the stock recovery afaik. A modified kernel is required to support CWM's features. :confused:
  15. bbbc

    bbbc Member

    That's the stock kernel? I'm still on yellow triangle though
  16. heshanj

    heshanj Well-Known Member

    yeah, the CWM app in ur app drawer, the one u see, is the CWM Manager app that chainfire includes with CF root. it does nothing if CWM recovery itself isnt installed, so thats the problem with urs. i dont get it though.. flashing the stock kernel via odin and the zImage from CF root via CWM manager, u should definitely have CWM.. but we've been thru this many times. maybe u want to try flashing a newer firmware and trying?
  17. bbbc

    bbbc Member

    Hey, not really feeling that the newer KG's will benefit me over KG2 right now, so I'll wait for something else.

    I can try another kernel I suppose.
  18. vantiveman

    vantiveman Well-Known Member

    I have seen some youtube videos (and saw also on Amazon) that there is a dongle for the Galaxy S2 that will reset the firmware count and get rid of the yellow triangle. Also, there is a different dongle that launcher download mode with the idea that if you have a bricked device you can use this and then once in download mode use ODIN to re-flash a good kernel.
    However, I have both of these dongles and both take me into download mode - neither one will reset the flash counter.
    I'm not sure if the problem is the dongle (I tried 2) or if my Galaxy S2 (Rooted KI4 Kernel with stock KI4 Firmware) has some problem that prevents the flash counter from being reset.
    Does anyone here have any experience of these dongles?
    Thanks,
    Alan.
  19. Slug

    Slug Check six! Moderator

    The firmware probably includes the newer bootloader which disables the USB jig reset.
  20. vantiveman

    vantiveman Well-Known Member

    Hi Slug,
    Thanks for that. It rather shocks me though, as these reset dongles are meant specifically for rooted phones. But, you say it is probably due to the kernel firmware I flashed having a newer bootloader. Do you know if there is a KI4 rooted Kernel that does support the use of this jig?
    Also, is it right for me to assume that ALL new rooted kernels will contain a bootloader that does not support these reset jigs? I should probably notify the seller of this as they should change their product description on Amazon. It says that it is suitable for ALL of the phones shown in their supported list.
    Thanks again for your feedback.
    All the best,
    Alan.
  21. Slug

    Slug Check six! Moderator

    The problem isn't with the kernel. The newer bootloader was already installed alongside the stock firmware.

    You can replace the bootloader with the old one from intratech's thread here; scroll down until you see a big block of red text, and the first link in that is to the old bootloader.

    It was.... until Samsung moved the goalposts for the GS2 quite recently.
    vantiveman likes this.
  22. vantiveman

    vantiveman Well-Known Member

    I guess I don't need the jig if I follow the process described earlier in this thread for removing the yellow triangle, though that also confuses me (just call me 'mr easily confused' lol).
    Basically the process describes reloading the original stock kernel (which I assumed would remove root) and then install it again, but then got messed up by the mention of ZImage. What is that?
  23. Sydney99

    Sydney99 Well-Known Member

    zImage file is just one part of the file package.

    my non-technical "take" on this is that the phone knows you've played around with root access, so puts up the yellow triangle. the insecure kernel file/package adds the goodies/programs you need to get root, flashing the stock kernel back removes root so the triangle disappears (but the root programmes stay on your phone). the zImage file of the insecure kernel gets you your root access back again without being recognised by your phone (but it does not contain the programmes, which is why you need to flash the whole file first) - make sense???

    a lot of people like the look of the yellow triangle and leave it there - it does no harm and saves hassle!
  24. ironass

    ironass Well-Known Member

    Wear the yellow triangle with pride! It shows that you have the knowledge to root your phone and sets you apart from un-rooted handsets. It shows that you can do more with your phone! It says that you belong to the Galaxy SII elite!






    (It also saves a lot of b*ggering around later when you are flashing other kernels and ROM's :p )
  25. Slug

    Slug Check six! Moderator

    It's a compressed copy of the boot partition.

    I'd prefer it in blue, to coordinate with my theme. Yellow is sooooooo unfashionable. :(

Share This Page