Root [CWM][ROOT][GB ONLY] Clockworkmod Recovery for the LG Spectrum 4G

Discussion in 'Android Devices' started by PlayfulGod, Aug 1, 2012.

  1. PlayfulGod

    PlayfulGod Well-Known Member
    333

    Jan 28, 2011
    8,109
    4,938
    333
    Male
    Web Design and Hosting/PC Repair
    NW Georgia
    [​IMG]
    DISCLAIMER: This is a Custom Recovery! Use at YOUR OWN RISK!!! By using this, you understand that that I am not liable for any or all consequences of using this. If you don't know what you're doing, DON'T TRY IT. Use at your own risk!

    THIS IS FOR GINGERBREAD ONLY!!!
    or after the using the unlocker ONLY!!

    Well I have finally got it all worked out!!! ;)

    CWM bootloop fixed!!
    Built from source specifically for the Spectrum. ;)

    Instructions

    1. Download & unzip the zip on your PC.
    2. Connect phone to PC via USB.
    3. Make sure to have debugging enabled.
    4. Make sure to have USB mode set to Internet Connection.
    5. Run the Installer script for your OS.
    6. Enjoy!! ;)

    NOTE
    : For those who prefer the non-touch CWM, I have included it in the zip, just rename the img's according. ;)



    People to Thank
    koush - for his kickass recovery.
    djrbliss - for the root.
    Spectrum community - for donating me a Spectrum. ;)
    Folks in #koush on irc.freenode for their their assistance.
    Folks from #spectrum - for testing. ;)

    The goods
    Unofficial CWM Touch & Root Official CWM & Touch available via ROM Manager! ;)
    AllinOnePackageSpectrum.zip - mtmichealson's og AIO updated.
     

    Advertisement
  2. admn81

    admn81 Well-Known Member
    93

    Nov 20, 2010
    641
    150
    93
    MN
    Hey good job PG! I will try this out tonite possibly while talking to you lol
     
  3. scott240

    scott240 Active Member
    16

    May 31, 2012
    34
    2
    16
    OK I have maybe a dumb question. So I understand why you want different roms but is there anything different about having a different recovery. I was just wondering if it looks different or does anything special that my current recovery doesnt do. Its not like I am not gonna download and install it because I have to install and try everything :D just curious though
     
  4. MrB206

    MrB206 Well-Known Member
    163

    Pg can correct me if I'm wrong but this means we don't have a ported version, so timestamps should work and we won't bootloop.
     
  5. PlayfulGod

    PlayfulGod Well-Known Member
    333

    Jan 28, 2011
    8,109
    4,938
    333
    Male
    Web Design and Hosting/PC Repair
    NW Georgia
    Well for starters, if for some reason you fudge everything up and it wont boot to the os normally and you have to use the button combo to boot to recovery to fix it all, well now it will boot out of recovery w/o having to flash the cwm-bootloop-fix.zip. ;)

    This one is built specifically for the spectrum, not the Nitro and then hacked to work on the Spectrum. No offense to Neph, he did what he knew how to and it worked. ;)

    And yes it looks different thanks to koush n his crew.

    Does one have to or need to change recoveries, no, its not a must, just recommended. ;)

    And finally, CWM is what got me in here to start with and I promised I would get it built and working right for you all!!! Just took a lil longer than I liked lol ;)
     
  6. PlayfulGod

    PlayfulGod Well-Known Member
    333

    Jan 28, 2011
    8,109
    4,938
    333
    Male
    Web Design and Hosting/PC Repair
    NW Georgia
    Not sure on the timestamps, think thats more a LG issue a few devices have. And you're correct on the bootloop!!! ;)
     
  7. MrB206

    MrB206 Well-Known Member
    163

    Ahh, see I thought it was because of the porting. I guess I assumed since I never came across that issue with the Motos. I'll flash it here shortly and report back. :D
     
    cac2us likes this.
  8. IMUcarmen

    IMUcarmen Well-Known Member
    163

    Mar 29, 2012
    1,720
    350
    163
    Custom Furniture Building
    Williamsburg, VA
    Good job play!
     
  9. admn81

    admn81 Well-Known Member
    93

    Nov 20, 2010
    641
    150
    93
    MN
    Pm sent to guide to have this link put in all things root guide
     
  10. cac2us

    cac2us Well-Known Member
    38

    Jul 28, 2011
    126
    20
    38
    Please do, for some reason my Spectrum reverts back to Jan-01-1970 every time I reboot.

    My wife's dose not.
    We got them at the same time, rooted at the time, but hers won't re boot directly into recovery without having to pull the battery.
    Her phone will do a simple reboot and maintain the proper time and date after start.
    Her timestamp in recovery is corrupted as is everyone else.
     
  11. admn81

    admn81 Well-Known Member
    93

    Nov 20, 2010
    641
    150
    93
    MN
    Has anyone else tried installing this via Windows?
     
  12. phillip_viado

    phillip_viado Well-Known Member
    53

    Aug 26, 2010
    244
    63
    53
    Las Vegas
    it works fine on windows
     
    admn81 likes this.
  13. admn81

    admn81 Well-Known Member
    93

    Nov 20, 2010
    641
    150
    93
    MN
    Nevermind....To quote myself "operator error" Good job on this PG
     
  14. cac2us

    cac2us Well-Known Member
    38

    Jul 28, 2011
    126
    20
    38
    I used Ethernet and got:

    Clockwork Mod Recovery
    Press any key to continue . . .
    * daemon not running. starting it now *
    * daemon started successfully *
    Device found.
    Pushing CWM to Phone
    2606 KB/s (5384192 bytes in 2.017s)
    Rebooting device
    Waiting for device to reboot
    Pushing Exploit
    Rebooting device again
    Waiting for device to reboot
    Installing Root Files
    remount succeeded
    rm failed for /system/etc/install-recovery.sh, No such file or directory
    rm failed for /system/recovery-from-boot.p, No such file or directory
    682 KB/s (22364 bytes in 0.032s)
    link failed File exists
    3726 KB/s (828156 bytes in 0.217s)
    2566 KB/s (843503 bytes in 0.321s)
    Installing CWM Recovery
    remount succeeded
    rm failed for /system/etc/install-recovery.sh, No such file or directory
    rm failed for /system/recovery-from-boot.p, No such file or directory
    1314+1 records in
    1314+1 records out
    5384192 bytes transferred in 1.610 secs (3344218 bytes/sec)
    Removing Trash
    Finished Recovery!!!
    Press any key to continue . . .

    ClockworkMod Recovery v6.0.1.0

    Running a backup now. What does "freeing space, Done freeing space" mean?
     
    admn81 likes this.
  15. steamer86

    steamer86 Well-Known Member
    38

    May 29, 2012
    216
    23
    38
    Mine still reads 5.80.20 or of the sort at start.. This is suppose to read 6+?

    First install hung me on reboot wait. Figured it was done. Fixed permissions and sound and vibe was removed. Reinstalled from windows installer and sound and vibe worked again but still hung after initial reboots and still reading 5. Will try again tomo, figure out what's going on. Also, if it matters, running BB 1.20.01.
     
  16. Neph81

    Neph81 Well-Known Member
    213

    Mar 3, 2012
    1,401
    823
    213
    Male
    Wisconsin
    So when is Koush going to push this to CWM manager? Also, how exactly did you get the boot loop fixed. I'm dyeing to know now.
     
  17. admn81

    admn81 Well-Known Member
    93

    Nov 20, 2010
    641
    150
    93
    MN
    Yes, it should be 6. something
     
  18. PlayfulGod

    PlayfulGod Well-Known Member
    333

    Jan 28, 2011
    8,109
    4,938
    333
    Male
    Web Design and Hosting/PC Repair
    NW Georgia
    that I can't answer lol, but I will keep bugging him to get it and the others I still have waiting to be added lol.

    And this is what fixed it: https://github.com/playfulgod/andro...lob/clockworkmod/recovery/postrecoveryboot.sh

    Its what I have been saying would do it and it finally pi55ed me off enough to stay at it until I got it right lol.

    Basically, that file gets built into CWM and runs when booting into CWM. And when booting to CWM with the button combo it zeros (clears) out the boot-recovery and wipe-data flags that get set. ;)
     
  19. Neph81

    Neph81 Well-Known Member
    213

    Mar 3, 2012
    1,401
    823
    213
    Male
    Wisconsin
    Very cool. I can't wait to play around with this a bit more tomorrow. I've learned not to flash things to my phone while half asleep.
     
  20. Lightswarm

    Lightswarm Well-Known Member
    48

    Jul 19, 2012
    164
    21
    48
    Oh how I've bricked my phone way too many times on the Fascinate while half asleep. Not fun, had to go through a long process just to re-flash that same ROM. I feel your pain Neph, feel it real good.

    As for PG, this is sweet. But I'll be using All In One, until it kills my Spectrum. Just because I'm too lazy to download yours. Thanks and Sorry! :p
     
  21. brianmaedche

    brianmaedche Well-Known Member
    68

    Jan 7, 2011
    230
    119
    68
    Building Maintenanc
    Missoula, MT
    Recovery works and looks great playfulgod, can't wait to see what else you can bring to the table for the spec
     
  22. PlayfulGod

    PlayfulGod Well-Known Member
    333

    Jan 28, 2011
    8,109
    4,938
    333
    Male
    Web Design and Hosting/PC Repair
    NW Georgia
    Think thats why I kept overlooking what was right in front of my face for how long??? lol
     
  23. steamer86

    steamer86 Well-Known Member
    38

    May 29, 2012
    216
    23
    38
    Pushed again, working fine. Nice work.
     
  24. ups2525

    ups2525 Well-Known Member
    23

    Jun 26, 2011
    89
    26
    23
    UPS driver
    Converse (10 miles from DT San Antonio)
    I get...

    * daemon not running. starting it now *
    * daemon started successfully *

    and it stalls there?? :thinking:
     
  25. PlayfulGod

    PlayfulGod Well-Known Member
    333

    Jan 28, 2011
    8,109
    4,938
    333
    Male
    Web Design and Hosting/PC Repair
    NW Georgia
    PC not seeing the phone.

    I've put a update.zip together to install it too, just need test it b4 I release it ;)
     
    neckchop and ups2525 like this.
Tags:

Share This Page

Loading...