[CWM][ROOT][GB ONLY] Clockworkmod Recovery for the LG Spectrum 4G


  1. MrB206

    MrB206 Well-Known Member

    You're not alone... I've never understood why anyone would pay for the pro version of RM. Other than rom updating and some 'premium' roms, I don't see the benefit... and those features are worthless on a phone like the Spectrum, because all our roms are in the forums. On phones like the DX, GNEX and other highly-dev'd devices, it *might* make some sense... but even when I had a D2 and OG Droid, I could just as easily update manually... for free. ;)
  2. hollywoods14

    hollywoods14 Well-Known Member

    i can understand why some people would buy it, just for ease of it being a one click option. But your right doesnt make any sense for a device like ours where its all on the forums and easy as pie to do manually.
  3. IMUcarmen

    IMUcarmen Well-Known Member

    one reason to buy may be to support the dev...

    I know I've bought more than one app just for that reason. The free version gave me everything I needed in those instances and didn't have ads but I felt it my duty to throw a few dollars the devs way just to show my support for their work. Most, if not all of us blow 5-10 dollars on crap we don't need all the time, and a alot of those times we aren't even satisfied with what we got for it.

    At least with these great apps provided to us by many many hours of hard work on account of the developers of apps, and roms, and themes we have the option to pay for it after we try it :]
  4. atomilluminati

    atomilluminati Well-Known Member

    Average Joe yes... Understood but I am fluent in this shit and I think it's unfair.... I don't develop but I do know my way around... I helped write the first all in one with Mt... Just to say I could lol I see both sides but I disagree with Koushik
  5. MrB206

    MrB206 Well-Known Member

    That's exactly why I bought rtb pro over titanium pro.
  6. IMUcarmen

    IMUcarmen Well-Known Member

    I bought both :p And ultimate backup pro not knowing RTB pro came with it :p I was a noob then though.
  7. tdm

    tdm Well-Known Member

    @PlayfulGod: Thank you, this is awesome! CWMT and adb. Love it! :thumb:
  8. tdm

    tdm Well-Known Member

    Just did my first backup to play with CM9 and I'm a bit nervous:

    /sdcard/clockworkmod/backup/1970-01-02.02.19.02 # ls -l
    -rwxrwxrwx 1 root root 10485760 Jan 2 02:19 boot.img
    -rwxrwxrwx 1 root root 514 Jan 2 02:27 cache.ext4.dup
    -rwxrwxrwx 1 root root 246729 Jan 2 02:27 data.ext4.dup
    -rwxrwxrwx 1 root root 296 Jan 2 02:27 nandroid.md5
    -rwxrwxrwx 1 root root 16777216 Jan 2 02:19 recovery.img
    -rwxrwxrwx 1 root root 219368 Jan 2 02:25 system.ext4.dup

    I know dedupe is cool, but come on... 219k cannot possibly hold all of /system. What gives? Do the dedupe files in /sdcard/clockworkmod/blobs hold most of the data? "du" shows that there's about 1gb of space used under blobs.
  9. ortrigger

    ortrigger Well-Known Member Contributor

    I'm trying to root my device with this. I'm not new to flashing or anything and I use Ubuntu. But every time I try to root and install the recovery, I get this error:
    Clockwork Mod Recovery
    [*] Press enter to install CWM to your phone...
    Pushing CWM to Phone
    error: insufficient permissions for device
    error: insufficient permissions for device
    error: insufficient permissions for device
    Rebooting device
    error: insufficient permissions for device
    Waiting for device to reboot

    I've tried switching the script around to where it roots first but nothing is working. Any ideas?
  10. tdm

    tdm Well-Known Member

    That backup is fscked. I tried to restore and got "Error while restoring /system!".

    /tmp/recovery.log says:

    Good thing there's adb and I took a tarball of /system and /data for safe keeping. Gonna restore from those now.

    Since this new dedupe thing obviously cannot be trusted (well, I can't trust it), is there a way to rebuild CWMT without dedupe and just use the good old tarball method?
  11. tdm

    tdm Well-Known Member

    BTW, after the failed restore, "df" says this:

    BTW2, the timestamp on the backup is 1/1/1970 -- the clock isn't reading correctly or something.
  12. MrB206

    MrB206 Well-Known Member

    The timestamp issue is a known one that can't be resolved (afaik).
  13. ortrigger

    ortrigger Well-Known Member Contributor

    Any help? I even tried combining two different scripts and am still coming up with nothing. For some reason, I can't get my terminal to recognize adb commands though either... Maybe I should update my sdk. I'll try that and post back with results. In the meantime, y'all have any other ideas what could cause this?
  14. Neph81

    Neph81 Well-Known Member

    Try manually using ADB. If you can get in that way, then it's a script issue. Last time I saw this happen thou, it was because the user didn't have ADB set up correctly on their linux box. Once they fixed that, the install script worked fine.
    ortrigger likes this.
  15. tdm

    tdm Well-Known Member

    +1

    Also, I never mess with the USB permissions. Instead, I start adb as root:

    sudo adb start-server

    Then anyone can use adb.

    That's just me though.
  16. ortrigger

    ortrigger Well-Known Member Contributor

    turns out my adb wasn't configured right. I'm rooted now. :) Thanks for the help everyone.
  17. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Dd is what u used to install cwm in the first place ;)
  18. tdm

    tdm Well-Known Member

    Not sure I understand that. Are you suggesting that I use dd to do my own backups instead of using nandroid?

    I just want a working, reliable backup and restore...
  19. Neph81

    Neph81 Well-Known Member

    Grab the 6.0.1.1 version of our recovery from here:
    ClockworkMod ROM Manager - Recoveries

    Install using DD commands.
    When in recovery go to "backup and restore" -> "choose backup format" -> and pick "tar" .

    Consider everything good to go unless you swap out your SD card as it keeps your choice stored in the clockworkmod directory.
    tdm likes this.
  20. finndo77

    finndo77 Well-Known Member

    Oh sweet, been avoiding the new CWM because of the de dupe. Now I guess I don't have to.
  21. MicroMod777

    MicroMod777 Well-Known Member

    Is AllnOne pkg, on 1st post up to date n failsafe to install cwm recovery?
  22. finndo77

    finndo77 Well-Known Member

    so I finally pushed this CWM to my Spectrum... then started a backup... then noticed the link to DL 6.0.11 to get the option of .tar for backups.
    It took about 5-10 minutes before it told me it was backing up data, now it has been sitting on that for 45 minutes.

    at one point a REALLY long file name ending in .so was there on the screen, but it disappeared in about 25 seconds and was overwritten with the "Backing up Data..." line. about 20 minutes maybe earlier) in the 45 minute timeframe that it has been "backing up data..." a new line showed up with a single period.

    is my phone actually doing something? or should I just yank the battery and push 6.0.11 to it and try again?

    none of the physical buttons have any affect, and the key backlights are and have been off. I'll give it another 20 minutes, if no progress, I'm a gonna yank the sucka!


    -----------------
    so, it is almost an hour and 40 minutes later (I received 9 pages for work right after I put in that last post) there has been no change on my spectrum.


    ---------------------
    10 hours later...
    I pushed 6.0.11 to my spectrum and set it to a tar backup and it is running fine now, already finished backing up the system partition and working on the data.

    just a note though, after pushing it over with adb I did an adb reboot recovery and was met with a blank screen and unresponsive phone. the backlight for the display was on, but that was it. a battery pull and the phone booted fine, adb reboot recovery again and all is well.

    ----------------------
    10 minutes later...
    all done...
    now IK@#JR( QN#U$"TG(U#$%QTUQ#$!!!!!
    it looks like CWM reset it's date time...
    my new backup is no longer incrementing in time, it has started back over at 1970-01-01 very annoying, as now my backups will be out of order... and of course the file creation date (for all my backups) is jan 1st 1980 on every single CWM backup over the last 6.5 months...
  23. bzr

    bzr Member

    Kind of a noob with the Spectrum, have rooted my Eris and Incredible without problems before. One question about including the 6.0.1.1 recovery: Do I need to modify the adb commands to look at that file instead of the default one in the AIO? Should I just drop the 6.0.1.1 into the Files folder or do I need to rename the files?

    Thanks,
    -bzr
  24. Neph81

    Neph81 Well-Known Member

    If you grab the 6.0.1.1 file from koush, just delete the other image and rename 6.0.1.1 to what that file was. Much easier then trying to edit the .bat file.
    bzr likes this.
  25. bzr

    bzr Member

    Worked like a charm, no hang ups or anything, I'm able to get up to root in File Explorer.

    Now just need to find a good ICS ROM for the Spectrum. Any suggestions on a stable daily driver??

    -bzr
Loading...

Share This Page