[CWM][WIP][DEV] Clockworkmod Recovery for the LG Viper 4G LGLS840


  1. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Ok this is a tester only as I still need a few things to verify a few things.

    I need a dump of the stock recovery, will need root, LG USB drivers installed, and know how to use adb.

    in adb shell or term on the phone:
    from from pc/cmd:
    Code (Text):
    1. adb shell
    or from term on phone:
    Code (Text):
    1. su
    Code (Text):
    1. busybox dd if=/dev/block/mmcblk0p13 of=/sdcard/stockrecovery.img
    I also need hexdump for misc:
    Code (Text):
    1. su
    Code (Text):
    1. hexdump -C /dev/block/mmcblk0p25 > /sdcard/hex-misc.txt
    And a copy of the vold.fstab located in system/etc

    You can either zip all of this together n upload n link me, or uplaod the recovery.img n pastbin the others.

    And now for the test cwm;

    cwmrecovery.img


    1. Download
    2. unzip
    3. Have LG USB driver installed
    4. connect phone up via USB
    5. have debugging enable
    6. have in internet connect mode (charge mode if internet mode isnt an option)
    7. Run the follow from adb shell:
    Code (Text):
    1. adb push cwmrecovery.img /data/local/tmp/cwmrecovery.img
    Code (Text):
    1. mount -o remount,rw -t ext4 /dev/block/mmcblk0p27 /system
    Code (Text):
    1. rm /system/etc/install-recovery.sh
    Code (Text):
    1. rm /system/recovery-from-boot.p
    Code (Text):
    1. busybox dd if=/data/local/tmp/cwmrecovery.img of=/dev/block/mmcblk0p13
    Code (Text):
    1. rm /data/local/tmp/cwmrecovery.img
    Code (Text):
    1. reboot recovery
    Last report I got back, it all works great but booting to recovery with the button combo it wont reboot to system. A battery pull is required to boot normally.

    wikidd's fake flash maybe a safer method for the non-savvy. ;)

    Advertisement
    :
  2. jdiflam

    jdiflam New Member

    Is this stable? any bugs or anything?
  3. jmendezsr25

    jmendezsr25 Member

    Here you go PlayfulGod all three you needed in 1 rar file. Here

    stockrecovery.img
    hex-misc.txt
    vold.fstab

    waiting on some mods for the phone if anything else i could do let me know.
  4. jmendezsr25

    jmendezsr25 Member

    attempted to do CWM Installer LG Viper 4G

    Device is Rooted
    USB Debugging is Enabled

    craftblack likes this.
  5. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Was just informed the viper doesnt use the same root method as its cousins do but uses ratc instead. Making the needed changes n testing in irc atm.
  6. wickidd

    wickidd Active Member

    Hi!

    I'm working on this phone as well. Out of something like 32 different partitions, how did you determine those to be the correct ones? lol Just curious, because I'm new to LG's scheme of things. I've been modding on Samsung and Moto for a while now, but this is my first LG.

    Thanks,
    ~WickiD~
  7. ryanwinston27

    ryanwinston27 Active Member

    Do you think you can give me a copy of the .img file for the Viper's current update? My phone's bricked at the bootanimation because I changed my su binary with TB.
  8. wickidd

    wickidd Active Member

    1. How did you change your su binary using TB (which I'm assuming is Titanium Backup?)? I haven't used it in over a year or so, but I only recalling it having a busybox updater, which you can use for su privileges, but I don't recall it actually changing the su binary, unless they've changed it.

    2. Sounds like a soft brick, and a normal update should do the trick.

    2. Do you know how to use adb? If you do, you can reboot your phone into recovery using that, and try doing the update from there:

    update.zip

    Just put this on your sd card as update.zip and make sure it's in the phone when you reboot to recovery via adb, and the magick will happen from there. I just did this with my girl's viper, and it took a good 15 mins to boot after the update because it was recreating the cache (which I wiped while in recovery after the update), so don't be alarmed at the slow reboot, but the update took that way on hers.

    Hope that helps :)
  9. wickidd

    wickidd Active Member

    Thanks for the updated link in the OP! :)
  10. ryanwinston27

    ryanwinston27 Active Member

    My phone works perfectly right now, but would I be able to install the update.zip with the MS840 CWM I flashed? Is there any way to access fastboot menu on the LG Viper? In case I need to flash the stock recovery.img?
  11. wickidd

    wickidd Active Member

    No and no.
  12. ryanwinston27

    ryanwinston27 Active Member

    Well I have flash_image on my phone, how do I use the stock recovery I saved?
  13. wickidd

    wickidd Active Member

    Is it working?
  14. PlayfulGod

    PlayfulGod Well-Known Member Developer

    boot and recovery are the same as the other 840's. Unpack the stock recovery.img, looking the ramdisk, etc, recovery.fstab, or may been recovery.mmc.fstab, either or it will tell you the mounts n partitions. Didnt realize I deleted or moved the zip. I will reupload it ;)
  15. PlayfulGod

    PlayfulGod Well-Known Member Developer

    boot and recovery are the same as the other 840's. Unpack the stock recovery.img, looking the ramdisk, etc, recovery.fstab, or may been recovery.mmc.fstab, either or it will tell you the mounts n partitions.

    The ratc wont run correctly from a script, I will post a link to the img and it can be flashed with dd. ;)
  16. ryanwinston27

    ryanwinston27 Active Member

    I tried to do "cd /sdcard" then "flash_image /sdcard/recovery.img" but something about partition errors pops up.
  17. ryanwinston27

    ryanwinston27 Active Member

    Wow I feel stupid looking back on the rudeness of the post I had written lol.
  18. wickidd

    wickidd Active Member

    I think, being a dev, I speak for both PlayfulGod, and I, when I say, EXCUSE US?? We didn't put a gun to your head and tell you to do that! You did that ALL ON YOUR OWN! If you got partition errors, WHY DID YOU REBOOT?? You should have put stuff back the way it was, BEFORE you rebooted! Your lack of knowledge, is NOT our responsibility! We will not be held liable for ANYthing YOU do to YOUR OWN PHONE!

    Sorry bud, YOU acted the fool, YOU deal with the consequences!

    Later,
    ~WickiD~
    tonylc74 likes this.
  19. ryanwinston27

    ryanwinston27 Active Member

    Sorry if I offended and accused but I was really upset, as my phone has no way of starting back up...please gie me some help on this? :/ I'm at a standstill right now and I would really appreciate it if you could help, maybe give the firmware flashable with Odin? Please? :'(
  20. PlayfulGod

    PlayfulGod Well-Known Member Developer

    ODIN only works with Samsungs. I have the tot file for this phone for LGNPST, but not the dll for it, so its useless atm.

    You can try to get it into download mode n see if the LG Mobile Support Tool will pick it up n update it.

    Other than that I dont know of a solution until the dll for the ls840 is available.

    And where did anyone say to use flash_image???
  21. ryanwinston27

    ryanwinston27 Active Member

    As my actions have proved, I am not an expert with Androids, although they are my favorite operating system. First off, I would like to apologize to you and wickidd for my outburst, it's just that my parents are going to kill me if I don't get my phone fixed because they need to call me... would you be willing to give me the tot file? I am horrible with these phones, and am completely screwed as I do not have a boot.img or a recovery.img right now. :/ I know my phone goes into download mode but as of now there isn't an update for the Viper.
  22. wickidd

    wickidd Active Member

    Yeah, same apology from me. As you see, I've edited my post some. I really don't care for being accused of anything.. And PG is right, I asked if it was working, as in, had you tested it. I never once said TO test it. Lol wow..

    But hey, PG, is Odin not compatible with the download mode on these?
  23. PlayfulGod

    PlayfulGod Well-Known Member Developer

    ODIN is for Samsungs ;)
  24. wickidd

    wickidd Active Member

    I was just wondering if it's ever been tried, lol.
  25. wickidd

    wickidd Active Member

    Yeah, I did all of that, and built a cwmr, after making a couple of mods, but it didn't boot into the recovery. I'm wondering if the recovery doesn't have to be built on the stock boot part. I'm thinking that part has the key combo builtin and defined to kick it over into the hard factory reset, and that the hard reset area is where we can put cwmr. Just food for thought..

    Peace,
    ~WickiD~
Loading...

Share This Page