CWR (Clockwork) Recoveries (Multiple 5.x and 6.x)


  1. kemonine96

    kemonine96 Well-Known Member

    I am not responsible for anything bad that comes to your device when using the information posted in this thread. Everything here is dangerous, may cause a brick, will void a warranty and has the potential to just plain wreak havoc. Do not complain you followed my instructions and met with a dead device. Consider yourself warned


    I've tested to the best of my ability, but I am one person with one device, I cannot catch all potential failure modes. If you find a problem and a fix, or have information that should be added let me know and I will update the necessary information.


    Recoveries

    Note the below ClockWork recovery images use the external sd card for storage due to the small size of the internal sd card
    Version 6.0.1.1 will fall back to the internal SD card if no external card is found.

    Using Stock Recovery
    Use the Volume Up/Down keys to scroll up or down, then press the key to make a selection.
    Menu descriptions / purposes

    • reboot system now: this option turns on your phone.
    • apply update from sdcard: this option allows you to apply updates from your memory card to your phone.
    • wipe data/factory reset: deletes all data from the phone except pictures and videos.
    • wipe cache partition: allows you to delete all cache data such as log files.
    • install fota: allows you to install over-the-air firmware.


    ClockWork Recovery Installation
    Courtesy of Android Forums

    1. Root device (see above for instructions)
    2. Enable debugging on device
    3. Plug into computer
    4. Copy recovery image to sdcard (download links below)
    5. Run adb shell
    6. su
    7. Optional -- Backup stock recovery: dd if=/dev/block/mmcblk0p13 of=/sdcard/stock_recovery.img
    8. dd if=/sdcard/recovery.img of=/dev/block/mmcblk0p13
    9. exit
    10. adb reboot recovery

    Images
    Stock Recovery Image: stock_gingerbread.ucla4.img
    ClockWork Recovery 6.0.1.2 (KemoNine Build; CM9 Compatible): CWMR_6.0.1.2_Apache_KemoNine.img -- Sources

    Advertisement
    :
  2. Can I download 6.0.1.2 straight to my phone without the use of a computer?
  3. Motorhead1991

    Motorhead1991 Well-Known Member

    Hello again :). Just downloading it won't do anything, but I can point you to an odin installed image.
  4. Odin..... Images..... I don't understand the terms. lol
  5. Motorhead1991

    Motorhead1991 Well-Known Member

    Odin is a flashing tool leaked from Samsung's labs, and an image refers to a filesystem packed similar to an iso file for computers.

    EDIT: Here's the Odin stuff I was referring to Odin flashable files
  6. I'm starting to get mad... I tried to dl Odin 4.43 many times but it keeps failing... The same thing when I tried to dl MH-1.2 kernel... I may just have to use my computer.
  7. jlede

    jlede Well-Known Member

    Is this in Rom manager
  8. Motorhead1991

    Motorhead1991 Well-Known Member

    Not yet. We're waiting to talk to Koush for official support.
  9. asamu694

    asamu694 Member

    I have cwr 6.0.1.2 and followed steps to install CM9 but fo some reason when i turn on wifi and enter password to connect and select connect it says "not in range". What could be the cause of this?
  10. Motorhead1991

    Motorhead1991 Well-Known Member

    You're not the first to have wifi issues on CM9... If you look at the Super Thread on xda, you may find some help.
  11. Stuntmanmike

    Stuntmanmike Member

    So, I'm rooted and trying to install this clockwork recovery but, I think that I may have missed something. The image file is on my sdcard and everything is going well except for the script below.

    C:\Program Files\ADT Bundle\adt-bundle-windows-x86_64-20130729\sdk\platform-tool
    s>adb devices
    List of devices attached
    I8473105e165 device


    C:\Program Files\ADT Bundle\adt-bundle-windows-x86_64-20130729\sdk\platform-tool
    s>adb shell
    $ su
    su
    # dd if=/dev/block/mmcblk0p13 of=/sdcard/stock_recovery.img
    dd if=/dev/block/mmcblk0p13 of=/sdcard/stock_recovery.img
    /sdcard/stock_recovery.img: cannot open for write: Read-only file system
    # dd if=/sdcard/CWMR_6.0.1.2_Apache_KemoNine.img of=/dev/block/mmcblk0p13
    dd if=/sdcard/CWMR_6.0.1.2_Apache_KemoNine.img of=/dev/block/mmcblk0p13
    /sdcard/CWMR_6.0.1.2_Apache_KemoNine.img: cannot open for read: No such file or
    directory
    # exit
    exit
    $ adb reboot recovery
    adb reboot recovery
    adb: permission denied
    $


    This is copied straight from the sdk command screen. I'm almost certain there is something I'm doing wrong. If anyone recognizes the step that I missed or went wrong, please help. Thanks in advance.
  12. kemonine96

    kemonine96 Well-Known Member

    Looks like the /sdcard mount point is causing you hassles. Try /mnt/sdcard instead of /sdcard in the commands.
    Stuntmanmike likes this.
  13. Stuntmanmike

    Stuntmanmike Member

    Thank you for your patience and your help. unfortunately, that didn't do the trick. i even tried a different script "flash_image recovery /sdcard/CWMR_6.0.1.2_Apache_KemoNine.img" both with and without the "/mnt/" addition you suggested. when that didn't work, i tried all combinations of these scripts on an android terminal emulator (minus the debug bridge part). every time i get the same response, "file not found." It's as if my phone doesn't recognize it's contents. i'm not sure what to try next.

    Thank you again
  14. Motorhead1991

    Motorhead1991 Well-Known Member

    1. Try a new/different SD card, I've seen this work.

    Forgot this was the internal card... Try putting it on the external and see if it will let you do it that way.

    2. If you don't care about the flash counter: TWRP 2.6

    Flash that with Odin Multiuploader (4.45 I think).
    Stuntmanmike and kemonine96 like this.
  15. Stuntmanmike

    Stuntmanmike Member

    Thank you both Moterhead1991 and Kemonine96. flashing with the twrp 2.6 with odin worked. unfortunately, something went wrong. i'm not sure how it happened but now i'm in a soft brick stage. also, i was stupid and didn't back up anything before flashing the rom, so recovery mode does no good either. i can get it in download mode. i was going to try to flash one of Kemonine96's recovery/system/kernel packages through odin but i don't know how to properly drop the .gz extension. i need help in a bad way. please.
  16. kemonine96

    kemonine96 Well-Known Member

    Use 7zip or gunzip to extract the gz file.
    Stuntmanmike likes this.
  17. Stuntmanmike

    Stuntmanmike Member

    thank you very much. any other insight that might help or anything that i should watch out for would be greatly appreciated before i go down this road. i'm like a kid with a gun here. i know just enough to hurt myself. thanks for looking out for me thus far. i've extracted "odin_gingerbread_ucla4_boot_stock_recovery_cwr_6012_system_no_bload.tar.md5" from your superthread and will attempt to flash it using odin tonight. i'm hoping this will flash over any mistakes that i've made so far. Thanks again.
  18. Stuntmanmike

    Stuntmanmike Member

    it worked! thank you.
  19. Motorhead1991

    Motorhead1991 Well-Known Member

    Always nice to get someone back up and running :).
Loading...

Share This Page