CyanogenMod 6.1/Android 2.2 Is here for GT540!


  1. CowboyDan

    CowboyDan Active Member

    Hi mate,

    I'm trying to follow your guide but run into a problem early.... I run the z4root app, it goes through the motions (acquiring root access etc) then reboots.... yet when I install MyBackup Root from the market then run it, it says I don't have root on my phone and exits. I'm not game to upgrade without saving my data, so I can't move on from here.

    I can't seem to get past this (seemingly) simple step. Any tips?

    Oh and before I go any further, will I be able to use my phone in Australia with the Europe Open software? It might be a silly question but 3G phones and their software are something I've never played with so yeah, just checking

    Thanks,

    Dan.
  2. dudeman1996

    dudeman1996 Well-Known Member

    Hey there,

    Have you tried rebooting the phone then trying again? Also, do you have USB debugging enabled? (Settings>Applications>Development>USB Debugging) If it's still not working, try to do a soft/temporary root. You'll know your rooted when you see a new app in the app drawer called 'Superuser'.

    Also, your only putting on the Europe Open firmware so you can get fastboot which you need to install 2.2/CyanogenMod. So once you put on Europe Open, your just replacing it again with CyanogenMod. :)
  3. CowboyDan

    CowboyDan Active Member

    Once z4root runs it reboots itself. I've tried rebooting again, still doesn't work. I've unrooted the phone, then gone through the process again, and Mybackup Root still says I don't have root access. But I have the Superuser application in the drawer. I've downloaded the trial version of MyBackup Pro so I'll just use that to backup.

    Also do you have any idea how far away a final release is? I can live with the bugs for a little while but I would like to get it all working properly at some stage.

    Thanks :)
  4. CowboyDan

    CowboyDan Active Member

    Ok so I've backed up with the MyBackup Pro trial and installed Europe Open with Fastboot - that went easily.

    Trying to install Cyanogen, however, I'm having another problem. When I hold the camera button down and power on the phone I get no LG logo, just a short vibrate and black screen. Then when I runn fastboot.exe -w I get the message < waiting for device > and nothing happens. I've let it sit there for over an hour, it just stays the same. I am running cmd as administrator.

    I have disconnected the device, pulled the battery and re-inserted it. The phone still boots as normal when I don't hold the camera button down, but no matter how much I try I can't get the first fastboot step to work :(



    EDIT: So the issue appears to be with this step : (i) connect the phone to the computer via USB cable, and wait for the necessary drivers to install

    When I connect the phone to the computer, windows tells me it's found new hardware and opens the found new hardware wizard. The drivers don't install automatically and I can't seem to find anything in the packages.
  5. dudeman1996

    dudeman1996 Well-Known Member

    Hmm, what version of Windows are you using?
  6. dudeman1996

    dudeman1996 Well-Known Member

    Not sure how far away the final release is, but they release out updates every couple of weeks or so, and it's getting closer and closer to the final release :D
  7. dudeman1996

    dudeman1996 Well-Known Member

    Update:

    A new version has been released, but it doesn't seem to be available for download. Have a look at the changelog (I put it in the 1st post) the Russian translation doesn't fare too well, it says: 'Download while it is impossible'. The original Russian text says '&#1057;&#1082;&#1072;&#1095;&#1072;&#1090;&#1100; &#1087;&#1086;&#1082;&#1072; &#1085;&#1077;&#1083;&#1100;&#1079;&#1103;'. Can anyone give us a better translation as to what it says? Hopefully I'll be able to download the new update and I'll upload it here as soon as I can. It also includes IPV6 support, which is needed for Google Goggles.

    Thanks! :D
  8. CowboyDan

    CowboyDan Active Member

    I'm on WindowsXP SP3. I might wait a little while for the final release - I've flashed my phone with the Aussie Vodafone 2.1 release so that will do for now.

    Thanks
  9. dudeman1996

    dudeman1996 Well-Known Member

    Okay cool, give me a shout if you need help when you decide to flash :) :D
  10. he6rt6gr6m

    he6rt6gr6m Well-Known Member

    Okay. Problems encountered on XP SP3 for me.

    Firstly, the driver package didn't install the following USB Driver which is VITAL to the process: http://android.modaco.com/index.php?act=attach&type=post&id=66762

    Secondly, when typing 'cd C:\Android' in CMD.exe, it came back that this was a bad action. I instead had to type the EXACT location of the file. IE the WHOLE directory as you would see it in Windows: 'cd c:\documents and settings\[my username]\desktop\android'

    Everything else was plane sailing. I'll give this mod a day or two to impress me, and if it's not worth it, back to the Baltics. :)

    EDIT: Already I've found that they've messed with the Keyboard.

    Can people not just leave the Keypad Keyboard in as an option? Especially given the screen calib. needs tweaking on this Beta.

    Thanks for a well-written and understandable guide. The rest I've seen were awful.
  11. CowboyDan

    CowboyDan Active Member

    he6rt6gr6m - was that driver you mentioned critical to the fastboot process? Cause I got up to installing cyanogen via fastboot but windows wouldn't recognise my phone....

    also:

    The guide says to copy the files to c:\android, not leave them on your desktop :)



    EDIT: You mentioned going back to baltic, can you go back to 2.1 from this cyanogen mod? That was the other thing I worried about.... if I don't like it, can I reflash with older firmware?

    cheers
  12. he6rt6gr6m

    he6rt6gr6m Well-Known Member

    That's the same point I got to, also. I'd enter fastboot on my phone, but once I'd plugged the USB in, it just wanted to connect to Windows to find a driver. I allowed it to, and it didn't find one, so a quick search at MoDaCo turned that USB driver up, which worked perfectly and allowed the PC to see the phone and run the CMD.exe with it.

    I'm not 100% sure about whether it can go back to 2.1, but I've seen stories of people going back, so I'm PRETTY sure you can.

    As a side-note, I've found that you can use the 2.1 LG_IME Keypad/Keyboard on this, but it requires using Recovery mode, which, using this tutorial, is unavailable.

    For installing Recovery mode, apparently we need to enter fastboot again and install the Recovery.img. Once that is done, instead of the phone booting into Safemode when you hold Home and Power, you now go to Recovery mode, which allows you to install the LG_IME file.
  13. Djolle

    Djolle Well-Known Member

    Here is the latest version... Enjoy! :D
  14. wirsininkas

    wirsininkas Member

    Tested.Everything works good :)
  15. dudeman1996

    dudeman1996 Well-Known Member

    Thanks! I'll update the first post! :D
  16. dudeman1996

    dudeman1996 Well-Known Member

    Thanks for this info! I guess those drivers are just for Windows 7, because those are the ones I used because I'm on Win7 :p I'll update the first post to include those drivers for WinXP users :)

    As for the keyboard, download the smart keyboard apk from here Access point and install it, in the settings, you can have the choice to put the keyboard the same as the LG stock, with T9. :D
  17. dudeman1996

    dudeman1996 Well-Known Member

    I'm not to sure about the recovery because it seemed a bit risky to be honest, I think somewhere on the 4pda.ru forum is a thread for a custom recovery for the GT540, but flash it on at your own risk. If your successful, please post your results and how you did it for the rest of us :D :)
  18. dudeman1996

    dudeman1996 Well-Known Member

    The driver in the post you mentioned isn't an executable .exe file, how would it be installed, and to where? :)
  19. CowboyDan

    CowboyDan Active Member

    Just extract the files anywhere (e.g. desktop), right click the .inf file, and select install.
    dudeman1996 likes this.
  20. dudeman1996

    dudeman1996 Well-Known Member

    Thanks! :D I'll update the first post! :D
  21. CowboyDan

    CowboyDan Active Member

    YAAAAAAY! I DID IT! :) I thought I'd share my problems and solutions in case anyone has the same problems.

    First problem - the 2.1+fastboot software I've been installing has not been working AT ALL, mostly when I start the phone I get major errors 'the process com.android.phone has stopped unexpectedly' or 'the process com.android.messaging has stopped...'. If you are getting these errors, do not despair. LOCK the screen (power button) and continue with the update procedure as normal. If you get stuck in a boot loop, you will need to turn your phone off, use KDZ_FW_UPD in CS_EMERGENCY mode to flash a KDZ you know works, then try it with a different ROM that has fastboot.

    The second problem - I lost my LG and Vodafone splash screens. When trying to start into fastboot mode, the screen stayed black instead of displaying the LG symbol then going black. This coupled with problem 3 made me think I couldn't use fastboot. This wasn't a problem though - I held the buttons for about 10 seconds (nothing happened on the phone other than a power-on vibrate) and the phone was in fastboot mode (still blank screen)

    The third problem - this one stopped me completely. Running "fastboot.exe -w" left the cmd window with <waiting for device>. NOTHING would happen. I found a post on MoDaCo (here) which describes how to install Black Quarx ROM via essentially the same process. A few pages in I found people with this problem - and here is the solution:

    * While the cmd window shows <waiting for device>, unplug the USB cable from the computer, and plug it into a port in a different location (e.g. move from the back ports to the front ports, or vice versa). Plugging it into the port next to the one it was in didn't seem to work (maybe because they are on the same channel?).
    * Windows will give you the "New hardware found: Android" message then open the new hardware wizard. It will ask if you want to search Windows Update for drivers; answer yes. It should download the drivers, install them, and BAM problem solved.

    After this, just follow the guide in this thread as normal. Basically what I did was follow the first half of the Black Quarx guide on MoDaCo exactly as written until I got to installing the Black Quarx ROM, and from there followed the steps in this thread for installing Cyanogen.

    I hope that helps someone.. I've been cracking at it for 2 days now lol :) If you have had the same problems as me and can't work it out please post here, I'll try to help as best I can!
  22. CowboyDan

    CowboyDan Active Member

    [​IMG]

    yeah baby
  23. dudeman1996

    dudeman1996 Well-Known Member

    Nice one! Good to see some perseverance! :D Thanks for posting this for everyone else who might have this problem, and enjoy CyanogenMod! :D
  24. Djolle

    Djolle Well-Known Member

    So, I installed latest CyanogenMod and installed SetCPU (320/768 on demand) and Swapper 2 from market created swap file (recomended settings) and to check if it is activated went in SetCPU under info - it is!

    Also in terminal emulator type free and you should get info... ;)

    p.s.-Dungeon Defenders need active internet connection.
  25. dudeman1996

    dudeman1996 Well-Known Member

    I used swapper 2 to create a swap file on the recommended settings too, and it did come up in SetCPU and in terminal emulator. :)

    I always have an active internet connection, either through Wi-Fi or mobile data and it just wouldn't work...

    As for SetCPU, I wanted to see how high it would go and it would continue to work when set to Max: 864MHz. But go any higher and the phone will just restart and bring the setting back down.

    :)
Loading...

Share This Page