Cyanogenmod 7 for Motorola Milestone[GUIDE]


  1. Mr User

    Mr User Well-Known Member

    NEWS: UNFORTUNATELY, the Cyanogenmod team has decided to stop supporting/developing for the Motorola Droid, the Milestone's twin, as the phone has aged too much. As you might have known, Android 4 aka Ice Cream Sandwich (ICS) has been released, and the Droid's 2 years old already. It's been a king, but now it's retired and obsolete.

    So, Cyanogenmod 7 (Android 2.3.7) is as far as the Motorola Milestone/Droid would get from the Cyanogenmod team. I don't know about other mods, but I doubt the Milestone/Droid hardware could handle that smoothly.

    Hey guys. How u doing today.
    I know u can probably google this topic like I did when i started, but the instructions sometimes aren't clear and do not work for you(did not for me, til I tried everything and figured out this way).

    THIS guide is LONG. I know it is, I'M ITS GDAMN AWESOME CREATOR. I'm not trying to waste ur time, but its a pretty detailed guide IMO, so you might wanna fast-read through it before you decide it doesn't help you. Trust me i want to help I've been through all this sh**, two effing times.

    For more information, read the first comment beforehand.

    This is a hardcore guide, for the last barriers the Motorola Milestone can put up against you. If you've done all this and it doesn't work, not many peeps know what else to do.

    EDIT: For advanced users, who knows what they're doing and just generally chilled, this isn't necessarily just Cyanogenmod.
    YOU CAN JUST DO THE UNLOCKING PART, AND IT WORKS WITH ANY ROMS OUT THERE.
    Check on the forum for a detailed list.
    I'll name 2 good ones: Cyanogenmod, of course, and MIUI. Both is Gingerbread, i.e. Android 2.3.

    CAUTION: The method of rooting in this guide is FULL root for stuffs like new ROMs, overclocking things. If u just want an easy root, WHICH DOES NOT ALLOW YOU TO PUT Cyanogenmod on ur Milestone, try applications like z4root. If z4root 1.3.0 cant be installed, try an older version, perhaps 1.1.0. Full detailed guide here: TheUnlockr | Archive | Motorola Milestone How To’s (Advanced)

    NOT APPLICABLE FOR MOTOROLA DROID. The steps shown here is intended to be used ONLY for a GSM Motorola Milestone.

    The methods in this guide IS NOT entirely worked out by me. I only came up with the way to get over that E:Signature Verification Failed. This is more like a throughout summary of other people's methods, which works for A LOT of people(not guaranteed for yours, but probably would).

    You should be reading this if:
    -You want to know how to have Cyanogenmod 7 on your Motorola Milestone
    -Stuck at E: Signature Verification Failed when trying to apply update.zip
    -Got passed Signature Verification once, but then stuck again(OpenRecovery doesn't show up)

    The last(third) reason up there, you might not even encounter, but I did have to go through, horribly, twice due to my own mistakes.

    So a few words about my Milestone. It's a gift for my aunt who's in the Netherlands(Holland). She used it a lot, until recently, she got a new HTC Sensation. Yay for her. Anyways, she gave it to my sis, who is totally new at this whole smartphone thing, although I did tell her a lot about all these ROMs and updates. So one morning, she just throw it at me saying "put that good update whatever you told me on this phone". Obviously she doesn't know the stakes and the horrors. I bricked this thing 5 times. Just kidding, its kinda hard to actually brick ur phone these days, but cautions should be take.

    The long guides in this post is not mine.
    The pictures in this post belongs to their respective owners. None is mine.

    It's an EU(not sure, but probably) GSM Motorola Milestone, with 2.1 Android.

    I AM NOT TO BE HELD RESPONSIBLE IN THE CASE IF YOU DAMAGE YOUR DEVICE IN ANYWAY BY FOLLOWING MY GUIDE. ALTHOUGH I WILL TRY TO HELP YOU.

    Just to calm you down, again, its not likely ull brick ur device, even though u did, there might some solutions, just try google or ask some devs nicely. The disclaimer up there is so tht i can get away in case ur phone exploded and wipe a city off the map or something. NO JUST KIDDING I WILL GET AWAY ANYWAYS.

    Nuff said, lets get down to business.

    STEP 1: First is to root your motorola. Some phones with a locked bootloader, in my case it is, could permanently turn off your phone(yes, BRICK) when you try to install a different ROM other than the stock ROM.

    Follow this guide here(I dont wanna type them all again so hah)
    There are others but I used this one and it seems clear enough.

    How to Root Motorola Milestone

    Motorola Milestone - the GSM version of Motorola Droid - came with Android 2.1

    Advertisement
    :
  2. Mr User

    Mr User Well-Known Member

    So, just to give you a better understanding of why I wrote such a long guide. There are others, much shorter than mine. And they work, too, perfectly, for most folks. But, this is for some Android devices with a 2.1 official update that still has their bootloader locked.

    In a few unlucky situations, the errors that you encounter after you thought you've unlocked your bootloader, is because of the way your system works. Right after you wrote new codes on it, when you reboot it, it overwrites its own codes on the new ones. This is like restarting whatever you just did, without you knowing. So, as mentioned above, you gotta act quick before it boots, else you'll have to redo it all.

    If you already know what to do, skip the words-you don't need to read them, most are boring, descriptive stuffs- and get to the vital, action parts and bust this bastard phone.

    It's quite troublesome, I know. My case was worse. The phone wasn't mine. It was my sister's, and omg it's got scratches and metals sticking outta every corner. I got electrocuted if I touched those parts when it's plugged in. And yea, it also has this problem. So I've had to endure it all, holding the phone down all the while getting shocked, then doing it again several times, always hurriedly. After all this i looked like Michael Jackson before he was white. No jk, I didn't get burnt, but I didn't feel good either.

    But anyways, if you succeed, it's permanent.

    As I said before, this applies only to a few situations, and I know there are advanced people out there, who doesn't need to read through it all, I'll just tell them what's going on, bam it's done.
  3. scorpio.pilot

    scorpio.pilot Member


    ......... nope. this Signature Verification Failed guy is pretty resilient.
  4. LifeInAnalog

    LifeInAnalog Well-Known Member

  5. Mr User

    Mr User Well-Known Member

    Sorry for late reply I'm a sophomore and pretty busy :p

    @scorpio.pilot
    which step were you stuck at? Also did u finished getting Cyanogenmod on ur phone and stuck again, or still trying to get CM into ur phone?

    @LifeInAnalog
    Yeah I know it reboots once RSD flashes thats why you gotta take the chance to put it into Recovery before it's done booting into the normal Android.
    Its weird that even if RSD flashed several times successfully, tht Signature problem is pretty hard to bypass. Only time it wont show is when RSD flashes ur phone, says "rebooting device" and you just press those buttons (D-Pad Up + On button) right into Bootloader
  6. captredbush

    captredbush New Member

    I keep getting stuck on the M screen. Can't figure out why. I used GOT sbf and their open recovery. My phone was on 2.1update and i successfully got it running on 2.2. But when I try and update to cm7, every time it just gets suck on that damn M.
    Any suggestions are greatly appreciated.

    Edit: Also, after I try and update and reboot it will automatically start in recovery mode.
  7. Mr User

    Mr User Well-Known Member

    Stuck at M screen? I need some more details to help you here....what happens after that?

    If it just stuck there and reboot normally, you're not pressing the buttons right or your buttons have problems

    If it just stuck there, NOT loading at all, showing that M ALL DAY LONG (i mean as in just doesn't do anything) than its some other problems
  8. captredbush

    captredbush New Member

    So I go though and clear everything, do the update for cm7 with no errors and then reboot the phone. When it restarts it goes strait into recovery mode and I go though the menu and tell it to reboot again. After that restart it will get stuck on the M. I have let it set for 15-20 mins and it just stays on the M. From what I have read it may take a while to boot up the first time but it shouldn't get stuck on the M for so long. I got frustrated trying to download different cm7 files so I tried getting the latest MIUI version. Ran that update and it worked like a charm. I'm thinking either I have multiple corrupt .zip files or I just didn't wait long enough for it to boot up. I still would like to try to figure out whats going on, I would like to give cm7 a try.
  9. Mr User

    Mr User Well-Known Member

    U shouldn't get stuck at the M for so long...might have been a problem with ur files and flashing....try the official cm7 files.
  10. Walhar97

    Walhar97 New Member

    Ok I'm just going in circles here...

    I keep getting stuck at this point>>> Go to Apply Update, scroll to ‘update-cm-7.0.0-RC3-0.07-11.03.12-Milestone-signed.zip’ & apply.

    I've put the files on the SD card in the folders specified but it's not an option, just don't see the files to update...

    Any support please!
  11. androjk

    androjk New Member

    hey
    i did a one click root using androot but wen i read dis i wanted 2 root it dis way so i unrooted ma milestone n now it dsnt get detected on rsd lite 4.6!plz help!
Loading...

Share This Page