Darktremor A2SD for Prevail [Updated 5-7-12]


  1. zombie droid

    zombie droid Well-Known Member


    Have you tried reformatting your ext partition? I'd run titanium or do a reinstall with a fresh partition. I had a similar problem and it helped with mine.
  2. TryingToRoot

    TryingToRoot Well-Known Member

    Cache is always mounted when I install a2sd on mine, and I have never had an issue.
  3. x432hz

    x432hz Well-Known Member

    I want to install this to take care of my low space issue, I just updated to the gingerbread via auto download from boost, and I am rooted. In the first post the requirement says: "A properly formatted SD card", but then in step 6 it has you partition it.

    Am I supposed to start out with a regular partition like I have now or partition it first with the 2nd ext partition, then continue the process?

    Also, what version of Odin am I supposed to be using for this phone/mod/process?

    thanks.
  4. scootmcdoot

    scootmcdoot Well-Known Member

    Thanks for the responses. I have tried everything. I have done all my creating and reformating of my partitions in cwm. The weird thing is Easeus doesn't recognize my partition now. It did before I started this process, but now it shows nothing. I just redid it and my sd-ext free (total) shows89 MB (93MB) and my cache free shows the exact same #. This is frustrating simply because it worked like a champ last time and this time its a no go. I'm not sure what else to do. Thanks

    Edit: Is there anyway that I have several partitions now and that is screwing up my setup? How would I get rid of the partitions and start from scratch? Last time I used Easeus, but like I mentioned earlier, its not showing any partitions. Thanks.
  5. inigomontoyasr

    inigomontoyasr Well-Known Member

    the a2sd app does not report internal space correctly on ext4 partitions. at least on this phone. titanium backup or a file explorer will.

    i updated the instructions. thanks for pointing that out.
    it's best done through cwm to format the sdcard properly. that will remove the question of which format to use. cwm will determine whether to make it ext2/4 depending on your kernel.
    there is only one odin for this phone. comes with the odin version of this mod and i believe with any of the other odin images.
  6. mvaness

    mvaness Well-Known Member

    I had a similar issue happened to me yesterday as I tried to add some apps. I had known about the misrepresentation of space, so I was not concerned until I kept getting the insufficient space message. I had ctmod with the kouma's 1.0 kernel, and a2sd installed. I had followed all directions. Could a2sd still have control of apps being installed? and if it does, would the misrepresentation of space be what is causing the conflict. Reinstalled everything, but with link2sd, and I am not getting those messages

    Edit: Started over and installed a2sd, and everything seems to be working! (I have flashed and reflashed my phone with almost everything in this forum, numerous times. I can't reiterate how important it is to read the directions, and make sure you understand them, and review the entire post. You will often find tips and suggestions that make things easier when experimenting. I made a mistake, and I wanted to make it clear that it was my mistake, and nothing to do with the developers work. Thanks Inigo!
  7. Dandnj1

    Dandnj1 Well-Known Member

    I had the same issues yesterday, but it started after i got the latest market I thought maybe that was the issue .. i restored to a backup i had from the morning and it worked fine .. I had not made any other changes all day except the market updating
  8. scootmcdoot

    scootmcdoot Well-Known Member

    Are You guys on CTMOD 2.1? Just curious.
  9. Dandnj1

    Dandnj1 Well-Known Member

  10. mvaness

    mvaness Well-Known Member

  11. inigomontoyasr

    inigomontoyasr Well-Known Member

    about how many apps are you trying to install?
    are you using the supplied sd card or an aftermarket?
    have you moved dalvik-cache to sd?
    have you looked at the help file or tried to run the commands through adb or terminal?
    how much space does the phone tell you it has under settings > storage?
    i've been on the same setup you just described for a few days. there are 23 user apps on my sdext now. when i flash a rom or advanced restore a backup they stay with me and install with little to no trouble. i will try to help everyone achieve the same result.
  12. mvaness

    mvaness Well-Known Member

    Hi Inigo

    I was trying to push apps from My Library from the online market. about 20?
    It is an after market pny 8 gb class ten card. Formatted in cwm with a 1024 partition. factory reset.
    dalvik was moved to sd through the guii.
    No, I did not read the helps or use adb, that was my next step, but i'm a little short of time, right now. When I can, i will try to reproduce the results. Thanks.
  13. prevailkills

    prevailkills Well-Known Member

    is this an update to the program? i installed your (bobrom) is that what this actually is? i just dont want to have to go through and do things all over again.
  14. TryingToRoot

    TryingToRoot Well-Known Member

    Inigo I really wanted to get a copy of your rom, but file appears to be gone. Is it still available?
  15. inigomontoyasr

    inigomontoyasr Well-Known Member

    broke it when i updated OP. fixed now.
    no updates, just added more information. the GUI doesn't seem to always work properly so i added the original help file to assist in troubleshooting your installs.
    prevailkills likes this.
  16. Rally 517

    Rally 517 Well-Known Member

    Im good with the update I now have 146 free internal space compared to only 89 before
  17. TryingToRoot

    TryingToRoot Well-Known Member

  18. Heloguy

    Heloguy Well-Known Member

    Can I just flash this update over the original or do I have to wipe and start over?
  19. inigomontoyasr

    inigomontoyasr Well-Known Member

    i updated where the files are hosted and how it installs on the stock gingerbread rom. if you have it and it works there is no need to download again.

    the updated version of the .zip installer will remove stock maps and books apps from phone to make room for necessary files. apps can be downloaded free from the market.

    the odin method has all stock apps installed, some optimization, adw launcher and a2sd installed. there is only one version of this. BObRoM

    i don't use the gui because it can be wrong. i have seen the "apps are on sd"! button lit when apps were not in fact on sd. it is possible to move only the dalvik-cache. it does not always indicate the proper internal storage.

    the terminal commands are the way the dev created the a2sd scripts to be used. the app does not necessarily support a custom modification such as this. they are written by different devs.
  20. mvaness

    mvaness Well-Known Member

    Thanks Inigo,

    I will make sure I familiarize myself with the commands before I try it again. I need to learn them anyway. But I need to practice my SQL for now. Not enough time in the day!
  21. wyelkins

    wyelkins Well-Known Member

    I do not remember seeing this posted before, if so, sorry for the repeat.


    Running GB, CTMod 2.1, KoumaKernel, A@SD and Loving it. Only one problem.

    Not sure how to rebuild Dalvik Cache.

    I used the GUI to move the Dalvik to sd-ext. No probelms.

    have tried twice to use the GUI option to rebuld the cache. The phone sticks on the KoumaKernel screen for a LOOONG time. In both cases I had done a Nandroid backup before the rebuiild so I just restored and gave up.
    How long is too long to wait?

    I know this worked with Froyo/Shabby.9 and i am pretty sure that it worked with Stock GB. Have not been able to get it to work since CTMod for GB.

    I have used TB to move a few apps to system just less to install after a factory wipe. Not sure if this is involved.

    I think that Inigo stated that not all the options on the GUI work properly. What is the process to rebuild the cache using the command line?



    Does the Titanium option to clean up the cache work properly with A2SD? It gives the stats on sd-ext.

    I know the Dalvik can be deleted with Root Exploer when in conventional memory, Not sure about now.
  22. TryingToRoot

    TryingToRoot Well-Known Member

    Not sure if its the right thing to do, but I just wipe davlik from cwm and let it rebuild on boot.
    wyelkins likes this.
  23. wyelkins

    wyelkins Well-Known Member

    Thanks, I actually forgot about that and have used it in the past, too. Darn Alzheimer's. ((apologize for the bad joke in our PC world, I meant np disrepect to our forum members who actually suffer from Alzheimer) also I do not know if everything seamlessly works properly with A2SD and GB.

    But, I am going to give that a shot and see what happens. Thanks again.


    Oh, and I changed my original post. I am running CTMOD 2.1
  24. Rally 517

    Rally 517 Well-Known Member

    I'm running the GB updated rooted CT Mod 2.1 with ap2sd running perfectly all options work
    wyelkins likes this.
  25. wyelkins

    wyelkins Well-Known Member

    Well T-Root I got some good news and I got some bad news.

    good news: CWM Dalvik wipe and rebuild on boot apparently works.

    bad news: I don't think it puts it on the sd-ext. I had 124MB free before with the old Dalvik After, I have 64MB. I had a hunch this would happen.

    The damn GUI still says that Dalvik is on sd-ext. The original option to move dalvik from system to ext worked, but I have not had any luck with moving it back or to cache. Maybe I am running the wrong GUI, scripts, or some other shit. b It did get updated from Market a few days ago.
    .
    Restored from backup. No big deal, probably have the answer before tomorrow morning. This forum is awesome.
Loading...

Share This Page