1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Darktremor A2SD for Prevail [Updated 5-7-12]


  1. is it also on system/sd?
  2. new optimus

    new optimus Well-Known Member

    on further thoughts I am not sure we want that, internal memory will run much faster then even the class 10 sd cards and if we managed to get the phone to basicly run from sd it would run slower.
  3. lmao... i had a rough time typing it so it can not sound ******ed...

    long story short. c how hoark has his ex4 rom. well that rom actually running on the sd-ext4 using the sd space.

  4. ok.. thanks.. that was gonna b my next question... how would it perform...
  5. new optimus

    new optimus Well-Known Member

    yes, I open /system/sd and without opening any folders there I get the exact same numbers, 73.53 used and 167.11 free

    also Im not seeing /system/sd/data
    I am however seeing app dalvik-cache though.
  6. yea mines either but i do have a data2, but i think titanium created that folder when i clicked move app data to sd on TB:

    system/sd
    app
    app-private
    dalvik-cache
    data2
    lost+found
  7. new optimus

    new optimus Well-Known Member

    sounds likely, as if it was moved by a2sd it would just be data
    I have all those but data2
  8. inigomontoyasr

    inigomontoyasr Well-Known Member

    that instruction is for 2.7.5.3, this is made from version 2.7.5.2-1
    the /data/data/ function is not yet available in this version

    you should not run system apps from the sd

    /data/app and /data/app-private get linked and moved to the sd-ext partition which is mounted as (named) /system/sd

    /data/data stays on internal to protect personal data.
    /data/dalvik-cache can be moved for further free space although i had stability issues with this
    i did move dalvik to /cache using
    a2sd cachepart
    and that seems ok until i add many apps guess dalvik gets too big for that partition
  9. yea the data2 gets created with titanium backup pro option... also if u delete a app from data/app it will also deleted on system/sd... so they are the same folder... just a duplicate so def we are lacking the data linking to the ext2... i noticed that before but just thought internal would go down anyway.. so i guess we got some more testing 2 do..
  10. new optimus

    new optimus Well-Known Member

    when he typed system/sd
    he was not talking about system apps,
    not sure if you thought that.
    he was talking about the actual folder

    /system/sd
    and inside is
    /system/sd/app
    /system/sd/app-private

    etc. I am running with dalvik-cache on sd and it seems ok, but I am using a class 10 card so its pretty quick all things considered.

  11. ok that makes a big difference there.. its not supported on this version... but yea runs fine on mines also & im only using a 2gb.. waiting on my 32gb in da mail...
  12. hroark13

    hroark13 Well-Known Member Developer

    no my ext4 rom runs on internal memory
    murderousone likes this.
  13. hroark13

    hroark13 Well-Known Member Developer

    I think I can make a CWM that formats the sd-ext to ext2

    But I want to hear some good reasons why we should not be using ext4

    I would like to hear from the dev, and people who tested it

    If we drop ext4 totaly, then there is no need for my kernel, and I have to compile a new CWM
  14. hroark13

    hroark13 Well-Known Member Developer

    Did ShabbyRC1 init.d require the S## ?
  15. Heloguy

    Heloguy Well-Known Member

    great work! just curious..is there any way to get the CIQ removal to work with this setup? i keep getting the random vibrations and stuck on bootanimation.
  16. inigomontoyasr

    inigomontoyasr Well-Known Member

    his init.d either requires something i'm not aware of or it's broken. i tried scripts named 'script', ##'script', S##'script' and K##'script' and none ran at boot. i had to use the install-recovery.sh to invoke the mount script. i'm trying to make a universal version so install-recovery.sh uses
    Code (Text):
    1. sh /system/etc/init.d/S00mount
    that was the simplest method i could think of.

    I now have a single version that will mount itself in cwm, install on stock, shabby, and hroark with the sdext as ext2 or ext4 and if any variable is changed, and causes a bootloop, a simple cwm reinstall or
    Code (Text):
    1. adb shell a2sd reinstall
    while bootlooping will fix the mount.
    i'll test more and release when it's ready.

    as for ext4. when using your all ext4 rom the a2sdgui doesn't report correctly (all rfs variations did in my testing). and the ext4 rom also uses more space on all partitions. even when migrating a nandroid from rfs the partitions are more full. it boots faster, and apps load faster, but there seems to be a storage trade-off. i still use teh all ext4. i keep my phone off at work and turn it on at lunch and when i leave so i like the speedy boot.


    one other thing, this a2sd allows for toggling the app storage between internal and sd. i reckon that's to safely swap sd cards. it works on stock and shabby in fact you have to toggle apps to sd when you first install on those. but everything is locked to sd on hroarkernel. can't be moved back. haven't investigated that further. i think some more testing is needed to make a decision so if anyone has input here, it would be appreciated.


    there was more on my mind than i realized. i need a nap.
  17. inigomontoyasr

    inigomontoyasr Well-Known Member

    did you try the method that involves flashing standard theme and then no-ciq theme? seems most have reported that to work although i don't think it's been tried with this mod yet.
  18. Heloguy

    Heloguy Well-Known Member

    i did not. i will try that and post the outcome. thanks again
  19. Mr.Push

    Mr.Push Member

    Help please dont know where i went wrong or how to fix ...i cant see the a2sd program i could see it before i partitioned my drive however it wasnot reading my ext i still was using the old one from links2sd..so i redid it thru cw but i could bring this up in the emulator..also the extra drive shows up in titanium with a2sd attached to it...i am running the cw V4.0.1.5. mod also if that sheds any light.. ..




    $ export PATH=/data/local/bin:$PATH $acsd check acsd: permission denied $ a2sd check rm: can't remove '/data/dta2sd.lg2': Permission denied cp: can't create '/data/dta2sd.lg2': File exists rm: can't remove '/data/dta2sd.lg1': Permission denied cp: can't create '/data/dta2sd.lg1': File exists rm: can't remove '/data/dta2sd.log': Permission denied [ ] Apps2SD is launching... grep: /init.rc: Permission denied __ _____ | | | | | |__/ | Darktremor Apps2SD 2.7.5.2-1 (2011-01-02) [ ] GetProp Command = /system/bin/toolbox getprop [ ] SetProp Command = /system/bin/toolbox setprop [ ] Mount Point = /system/sd [ ] Creating /cache/dc mkdir: can't create directory '/cache/dc': Permission denied chmod: /cache/dc: Permission denied [ ] Symlinking /cache/dalvik-cache to /data/dalvik-cache rm: can't stat '/cache/dalvik-cache': Permission denied ln: /cache/dalvik-cache: Permission denied [ ] Starting Apps2SD Check Program. grep: /init.rc: Permission denied grep: /init.rc: Permission denied [ ]
  20. inigomontoyasr

    inigomontoyasr Well-Known Member





    looks like you're boned.






    just kidding. but we do need lots of information.
    does the phone start or bootloop?
    can you connect with adb?
    did you uninstall link2sd first? i suppose in theory you could use both but let's get you fixed up first.
    step by step, what did you do? meaning from right before this happened until right now. how about now?
    Mr.Push likes this.
  21. Mr.Push

    Mr.Push Member

    first i did wipe then used oden to update to latest cvw..i was using Link2d but i think i made a mistake when i loaded the links2sd well i know i did because i didnt reformat my sd (16gb)and the ap2sd would not read it it did however show in my titanium however.. so the next thing i did was download my sd card to my laptop then i went to recovery and wiped my partition and created a new on 5132 and 32swap.. then i did a system mount and data mount..rebooted open up titanium back up and it showed the drive however the numbers look strange system rom ..168mb(32.5free) internal 169mb(119 free) sd card 15.4 (15.3 free) sd crd (a2sd) 503mb(492MB)....now when i first booted it was giving me loops but i went back into recovery did a wipe and phone went to normal.. then i redid the steps as far as mounting and unloading of zip a2sd_prevail_ext4.zip. after that i didnt see the app itself as i had seen previously so i went in my emulator app and ran the check command..and that brings me to "boned" and i dont know about adb never attempted it i dont think..
  22. new optimus

    new optimus Well-Known Member

    I am running with bloods simple blue nciq and a2sd though I am thinking my battery life has gone to shit with nciq,
  23. From Your Log:
    Looks Like Your Having Permission Problems From What Your Log Says....
    Files Are Not Even Getting Pushed Correctly... Try Re-Installing The A2SD Without Link2sd. Also Link2Sd Creates Similar Simlinks As A2SD... So It Can Cause Probs If Both Are There..
  24. Heloguy

    Heloguy Well-Known Member


    it worked. thanks for the pointer. much appreciated.
  25. Mr.Push

    Mr.Push Member

    i lost the link2d with the wipe and didnt reload it ...so its gone

Share This Page