Darktremor A2SD for Prevail [Updated 5-7-12]


Last Updated:

  1. inigomontoyasr

    inigomontoyasr Well-Known Member

    link2sd was probably taking ownership of the partition. that's why the permission denials.
    the rest working properly? did you run a2sd check again?
    you should still navigate to /system/etc and delete install-recovery.sh to avoid mounting conflicts.
    the swap partition is not used so that should be 0MB when partitioning. if you haven't installed anything yet, partition in cwm again with 0 swap. you're just wasting space there.
    then just reboot and see where you're at.

    Advertisement
    Mr.Push likes this.
  2. Mr.Push

    Mr.Push Member

    with a 16 mb card about how large should the partition be..i know 1024m is about 1 gb but will anything larger interfere with the workings of the program
  3. inigomontoyasr

    inigomontoyasr Well-Known Member

    i've read posts in other forums that claim larger than about 1GB gives some users unfavorable results but 512MB ~ 1GB should be enough room for an enormous number of apps anyway.
    smith058 likes this.
  4. Mr.Push

    Mr.Push Member

    $ export PATH=/data/local/bin:$PATH $ a2sd cp: can't create '/data/dta2sd.lg2': Permission denied rm: can't remove '/data/dta2sd.lg1': Permission denied cp: can't create '/data/dta2sd.lg1': File exists rm: can't remove '/data/dta2sd.log': Permission denied [ ] Apps2SD is launching... grep: /init.rc: Permission denied __ _____ | | | | | |__/ | Darktremor Apps2SD 2.7.5.2-1 (2011-01-02) [ ] GetProp Command = /system/bin/toolbox getprop [ ] SetProp Command = /system/bin/toolbox setprop [ ] Mount Point = /system/sd [ ] Creating /cache/dc mkdir: can't create directory '/cache/dc': Permission denied chmod: /cache/dc: Permission denied [ ] Symlinking /cache/dalvik-cache to /data/dalvik-cache rm: can't stat '/cache/dalvik-cache': Permission denied ln: /cache/dalvik-cache: Permission denied [ ] Starting Darktremor Apps2SD Version 2.7.5.2-1 [X] No command specified. You must specify a command if you are launching from the command line. Syntax: /system/bin/a2sd command All comm


    well i followed the steps but keep getting the same results..(insanity) but it is rather fun..hey its not bricked..but umm all I did was deleted the file install-recovery.sh ..wiped partition cleared cache's reformated ext 2gb's.. 0 swamp..mounted data mounted system...rebooted...added ap2sd4ext zip file ran zip ..rebooted ran emulator check and back to square one ...and the formatted drive shows up just like before listed on the titanium manager ..with the drive space increases noted...?????? helppppppppppp..! lol..dont want to have to go back to links2sd
  5. inigomontoyasr

    inigomontoyasr Well-Known Member

    now do precisely this
    1 boot into recovery
    2 mount system and data
    3 install zip from sd card
    4 choose your 'a2sd_prevail_ext4.zip'
    5 when it finishes, back out to main menu and reboot

    that should clear you right up. if not, pm me. you can try something new for me.
    Mr.Push likes this.
  6. hate

    hate Well-Known Member

    he mentions making a 32swap .....since I started using cwm to I been meaning to ask what that is. Are we suppose to make one? cause i always leave it at 0mb.
  7. new optimus

    new optimus Well-Known Member

    dont make a swap, android dont need it but it will use it if its there and because its on slower medium it will slow your system down.:eek:
  8. Heloguy

    Heloguy Well-Known Member

    Not sure why, but it takes between 2-3 minutes to load up all my apps. Is that normal?
  9. psp_noob

    psp_noob Well-Known Member

    hey guys been out of the loop for a while but has this replaced link2sd? and what is the latest and greatest rom/kernal/mod that we are all using to achieve this?

    i keep hearing posts about hroar's 1.3 but don't see it in the thread

    also could someone post a quick recap of pros and cons of a2sd vs link2sd
  10. protegemini

    protegemini Well-Known Member

    ^ditto
  11. inigomontoyasr

    inigomontoyasr Well-Known Member

    link2sd gives you the option to move individual apps to sd-ext and it leaves a link for each app on internal storage. each link takes up some small space.

    a2sd just links the app folders so you only ever have two links on internal. three if you move dalvik. and all apps are installed to sd

    i've modified this version to work on any rooted prevail. it's not rom or kernel specific :)
  12. inigomontoyasr

    inigomontoyasr Well-Known Member

    sd card speed, kernel, number of apps. many factors can determine your loading speed.
    i've noticed that my launcher takes time to build the icon list but i can still open all my apps.
  13. keyneom

    keyneom Member

    I actually prefer Link2SD I might be missing something but I prefer being able to choose which apps I put on the SD card and which ones I want to keep running internally. Additionally you get a lot of other options such as letting you decide if you want to put the apps data on the card as well, etc. Is there some other functionality DT's a2sd provides that makes it the better option? Just want to make sure I'm not missing out on something here.
  14. 666wicked666

    666wicked666 Active Member

    I was using link2sd not having any problems other then when I link all apps I got less freed up space then I did when I move any app that I could move the android way and linked the rest with link2sd ...tried a multiple times also with cache cleared and each and every time got more space free when I did the half half method (it was more like 70/30 70 link2sd).... I put every thing back on internal uninstalled link2sd (only had 3.2mb internal space at that point) flashed the DT a2sd zip and the only setting I changed in the a2sd GUI was delvik to sd and I went from 65.4 megs free with link2sd to 118 megs free with a2sd ...needless to say I'm sold ....only question I have is what should the setting for the devik heapsize be and what should I do with the zipalign on boot (on or off) Thankz to all involved ...you guys know who you are
  15. psp_noob

    psp_noob Well-Known Member

    and what are your speeds looking like with pure a2sd vs pure link2sd vs mishmash of both? and how troublesome is either choice with doing backups and restores?

    i'm still waiting for the latest alpha phase to end to see how practical it is to use one vs the other or both

    i'm using a class 4 card, so i may not get the full speed potential of a2sd and i certainly don't want to invest in a 6+ card if this turns out to be just a flavor of the week or something, plus i'm getting real tired of doing full wipes of phone and sd card everytime we test a new step in this process, so i guess i'll just wait a bit longer
  16. 666wicked666

    666wicked666 Active Member


    well to be honest it's a little early in the game as far as speeds and performance but, so far I haven't noticed much of a difference one way or the other..w/link2sd it was ok mish mashed or all link2sd was quite happy actually.. I was using that since it first hit this forum and I to was planning on waiting but when they made a2sd CWM flashable I figured it doesn't get any easier then that so why not check it out

    as far as backup and restore had no problems w/link2sd ...only have done a backup w/a2sd and w/no problems there

    I'm not sure what class card I've got cause I swapped cards w/my dad and he hasn't a clue what he bought and it doesn't say on the card (can anyone tell me how to figure that out never tried looking into it but I would think that shouldn't be to hard w/computer or some thing)..it's a 16gig card w/partition set to 2gigs 0mb swap ext4 ...I did read bout potential probs w/larger then 1gig but I don't appear to be having any (yet) I might end up redoing that cause there is no real need for it being that big (but hell I'm one of those "more power
    kinda guys")

    so all in all if you're trying to get as much possible space you can out of a way tiny amount of internal space a2sd seems to be a nice easy way of doing it

    I'll be sure and post any probs I run into after I've been using it a fair amount of time

    Edit: ok just booted into recovery and did wipe of delvik cache and cache partition and booted into sys and went from 118megs free to 68 and change ...don't get that but link2sd did the same thing just not as much of drop ...can any one explain that one to me cause that just doesn't seem right
  17. inigomontoyasr

    inigomontoyasr Well-Known Member

    Try opening a terminal and doing
    a2sd repair
    Are you on the all ext4 rom?
    666wicked666 likes this.
  18. MrPeter1985

    MrPeter1985 Well-Known Member

    How do Newly installed apps get to the SDcard? Install of your CWM went fine, everything went to the SDcard. I had 74-76mb free. Installed Tango as a test and it went down to 60mb, which is the 14-15mb for tango. Even after a reboot its still 60mb.

    I had stock EE14 from my newly replaced Prevail. Rooted it and slimmed everything down. Installed your CWM listed and no custom theme or roms installed. Just the kernel above. sd-ext is 512mb 0 swap. EXT2 format.

    TIA.
  19. new optimus

    new optimus Well-Known Member

    What did you do?

    you used the install recovery sh?

    by the way I modified shabbykernel to work with init.d scripts. though basicly I just turned it into hroarks including adding ext4 support.
    the differences are so minor they could be the same.
    I am now running that modified shabby kernel and same ext4 partition for a2sd.
    I also found, er borrowed a way to get the sd card read ahead without using sd speed boost. I hated waiting for that to come up every time I rebooted.
  20. hroark13

    hroark13 Well-Known Member Developer

    how did you implement init.d, did you do it the same way i did?
    did you try my repacker ?
  21. new optimus

    new optimus Well-Known Member

    I downloaded your repacker, but didnt get a chance to mess with it.

    I have been using the android kitchen, first testing on my optimus, got things sorta what i wanted then took a look to do on the prevail.
    the prevail is so much harder because there is so little out for it.
    Ya I implemented it your way, added the scripts you did and edited the init.rc
  22. 666wicked666

    666wicked666 Active Member

    Edit: ok just booted into recovery and did wipe of delvik cache and cache partition and booted into sys and went from 118megs free to 68 and change ...don't get that but link2sd did the same thing just not as much of drop ...can any one explain that one to me cause that just doesn't seem right[/QUOTE]


    I hit move and rebuild and according to a2sd that erases the dev cache and forces it to rebuild on reboot and well it increased my internal back up to 118 megs ...anyway still need to know proper value for heap and what is dev JIT also should zipalign be on or off the GUI does not address niether of these in the help tabs and like I said in earlier post I get carried away at times and always go big
  23. inigomontoyasr

    inigomontoyasr Well-Known Member

    yup. shabby's and stock fall back to that script to initiate mount.

    i still can't get repack to finish.
  24. inigomontoyasr

    inigomontoyasr Well-Known Member

    zipalign makes apps load faster. i've been using 32m heap and JIT ON since my first shabbymod since that's what it had. also supposed to make apps run faster and smoother. never changed it so i don't know the impact.
    666wicked666 likes this.
  25. 666wicked666

    666wicked666 Active Member

    great thankz ....

Share This Page