Data Call Failure: Error Code 67Support

Last Updated:

  1. Groovehog

    Groovehog Member

    'Registration failure. Press ok for options. Your PCS Vision username and/or password may be incorrect. Please try again.'

    Getting this error quite frequently now. Anyone know what this is or know how to fix it?

  2. andrewcgrimm

    andrewcgrimm Well-Known Member

    yes this means that either the username or password on the phone is incorrect or there is a provisioning error on sprints side.


    1. preform a reset on the device by going to menu<<settings<<about phone<<system updates<<update profile

    2. if that doesn't work the call sprint *2 from another sprint phone or 888-211-4727 and ask for advanced technical support. once you speaking with ATS,, tell them the error code,, they will more than likely have you reset the device again after changing some network elements

    but in most cases the reset will fix the issue... now if you were to get a survey based on this call today for customer satisfaction would you be able to say I resolved your issue..... crap gotta remember im not at work...
  3. JackG058

    JackG058 Well-Known Member

    Thanks. This worked for me.
  4. Vampyre

    Vampyre Member

    Thank you. I just got my hero and this fixed my error.
  5. lexnallan

    lexnallan New Member

    :( Talked to Sprint support tonight and they told me that the modem option has been disabled on the HERO.
  6. Skiguybri

    Skiguybri Member

    I'm getting the same error...tried the reset solution but that didn't work so I called Sprint and was told the same thing. The rep I spoke with suggested there may be 3rd party workarounds but wasn't specific.

    Anyone have any luck tethering their phone using another method?
  7. 82Grad

    82Grad New Member

    I found PdaNet on my Hero (Sprint) just finished setting up and it works great. The speed is only about 700kbps right now at home, but that I think depends on how good your cell signal is.

    1. Download Pdanet on your cell phone.
    2. Download the Pdanet software on your computer.
    3. Follow instructions on both and it works great. Good luck!

  8. dmchaney

    dmchaney New Member

    I came to this forum specificlly for this issue. Major pain .I just called tech support and was told the same thing, that they no longer have this service avaliable". In other words, you have to buy another mobile internet device and get a new data plan and pay them more money. Thanks for that sprint.

    I suppose im going to try the PDANet work around. Pisses me off that they limit the devices capabilities.....:mad::mad::mad::mad::mad:

    PS - Great forum!!!!:)
  9. jazFunk

    jazFunk Member

    I use EasyTether Lite. Free, easy.... it also claims the free ("Lite") version does not support https, I'm here to tell you that it does. It works brilliantly. You can get it from the market. You also have to download and install something on the pc your going to use.
  10. Biggest Fro

    Biggest Fro Well-Known Member

    I'm guessing you guys aren't rooted, Wireless Tether is working fine for me, just tried it.

    But a few weeks ago I did get Error Code 67 a few times. I rebooted and updated me phone each time and haven't gotten it since.
  11. jazFunk

    jazFunk Member

    I don't really understand what 'Rooted' means. Haven't researched it either. Since you brought it up may I ask you to tell me what it is and why people are doing it and why some say don't even consider it?

    Essentially, what will I gain by doing it?
  12. KitsapAndroid

    KitsapAndroid Well-Known Member

    +1 for EasyTether. I used both PDAnet and EasyTether, and I prefer EasyTether. To answer the question above in a simple, non technical manner, when you Root your phone you are gaining FULL access to your phone and it's programming. It will also allow you to flash a new ROM if you are not satisfied with your current one. There are many threads on the process that will give you much more detailed and technical answers.
  13. Not sure if this applies as I have a HTC Evo 4g. Tried the above fixes and it does not get around the message.

    Get the same Data Call Failure message anytime I try to turn on Hotspot OR I tether with internet sharing on and have Mobile Network on. But have not paid the $30/month extra to get Hotspot. If I turn off Mobile Network (using 3G/4G) and turn on WiFi, tethered internet works fine and no message pops up. Maybe this login / authorization message implies you are trying to use a service not available to your level of service contracted and therefore your login is not valid for the service being requested? Crappy message if so as they could just say "service available only for an extra fee".

    wonder if the reset is simply forcing the phone to get new credentials after a change in the central server? When first setting up phone and data service, had to wait more than 5 minutes after re-powering the phone before it was recognized as valid. They had blocked call out attempts until they did some central reconfiguring and verification. Guess they do not trust their field stores and have centralized the last bit of access to their networks.
  14. mslisaj

    mslisaj Well-Known Member

    On the error code 67. Happened to me too. Didn't want to call Sprint as I am rooted. But couldn't get on the internet to update my profile. The way I fixed it was turn on my wifi. Through my home wifi router I accessed the internet and then updated my profile that way. Solved the log on and internet issues............

    I never tried the "tether" that came with the phone as I have always used PDAnet and that has always and still works great for me. Hope this helps.

    Lisa ;)
  15. Well seems you should not use PDAnet, based on my tests so far, unless you really have too. Am getting just over 1 mbps down on the tether as a max. If I use HTC Sync and "Share the Internet Connection" while the EVO is on Wifi, I can get 10mbps down through the EVO. Upload is also comparable with close to 10mbps using HTC Sync tether versus .5 mbps using PDAnet tether with the same Wifi. So PDAnet seems only best to use when 3G/4G is your only network. But I need to check more on the configuration to make sure something else was not killing performance. Does this sound like others experience? Did you get PDAnet to run faster?
  16. archercc

    archercc Well-Known Member

    I have never tethered while on wifi (never saw the point) but in ATL using PDANet on the Evo I was getting 5megs down.
  17. Ann Droid

    Ann Droid New Member

    Hi there.
    I too (or three or four) am getting this message. I have the new Evo 4g, tried the fix mentioned above, turned the phone off an turned it back on and nada. :( Still keep getting the message. :( Any suggestions? Thanks!
  18. Ann Droid

    Ann Droid New Member

    Hello again.

    I unplugged my phone from my PC and turned it off again; then after letting it sit for a few moments, I restarted the phone and only after it seemed to have fully started, I plugged it into my CPU. So far (fingers crossed) the message has yet to reappear.

    I did find that message to be odd anyway, considering that I do pay for the wifi hotspot service. Thanks!
  19. zx12richard

    zx12richard Well-Known Member

    Girlfriends hero and mine did it today. Both. Called Sprint had me soft reset the when booted up dial ##3282# if i remember right. It then done some configurating rhen it was fixed.
  20. Whiskeypawz

    Whiskeypawz Well-Known Member

    I was getting this message on my Hero the other day. I could "dismiss" the message & do what I need to do but after a couple of times I couldn't even do that. I finally shut it off & turned it back on & so far (knock on wood) I haven't gotten the message again.
    Something about "Error code 67. Your PCS Vision Username & Password are invalid."
    FTR, I've never rooted, tethered or connected it to my pc, except to do the 2.1 update.
  21. stainlessray

    stainlessray Well-Known Member

    soft restart seems to work so far.... very annoying. they need to fix it if its error. if its attempt to limit tethering, its unacceptable. evo4g, not worth 30 a month to do something i can do through open dns for free. the 2 year contract is enough gauranteed money as far as i'm concerned. i chose sprint because the rates were good for service, and i THINK they won't nickel and dime me.
  22. Hardcorp

    Hardcorp Well-Known Member

    I would love to get a solution on this error as well.

    Since the first day I got me EVO i have gotten the error. I have talked to advance technical support and done all the "salutions" and nothing has changed.

    The last time I called they told me that is was because of a network issue in my area. But why would they not have told me that before?

    Anyway,does anyone have more information as to a fix?
  23. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Not as of yet, happens to me at least twice a day, all I do is turn mobile off and back on, or just update my profile, but I agree it is a PITA, I have seen many more issues with Sprint in the past couple of months now, with connection issues and call issues, I think when they put this any mobile plan out I think they bit off more than they can chew, I think other carriers may not be allowing Sprint to roam on there networks anymore, JMO Thus the reason for lack of receiving calls and internet issues.
  24. Hardcorp

    Hardcorp Well-Known Member

    Ya, Im not sure what could be causing it but I would like to get a straight answer as to why it is happening.

    andrewcgrimm made it sound like he works for Spring so maybe he can find out more.
  25. Hardcorp

    Hardcorp Well-Known Member

    ok. I have been going back and forth with Sprint on this issue and today I finally got somewhere, I believe. But I have to say I wasn't very happy with what I heard.

    I went up three levels of technical service doing everything (remove battery...update profile...ect..) finally they had me do a hard reset and the error 67 was still there. By this time I was not happy after spending an hour and a half on the phone. During this whole time none of the ATS people asked me if I was on a roaming network or not. So I finally said will that effect getting the whole error 67 ?Her reply was "Let me talk to MY superviser and I will call you back...ok.

    A half hour later I get a call from someone who says the are the "senior technical service adviser" (and no accent BTW) she tells me that only voice and text are guaranteed on a roaming tower. and the fact that I was currently on a roaming tower would explain why I am receiving the error 67.She goes on to explain that data is a separate issue when working with roaming and some roaming towers even block data from connecting....WHAT!?!

    Well it goes without saying that I am a little disappointed with that conversation and if I would have known upfront I would have stayed with *gulp* AT&T.

    live and learn.

Share This Page