Data Monitor App very, very sluggish after change to 'limit'Support


Last Updated: 2012-07-26 06:09:12
  1. CaptBones

    CaptBones New Member

    Hi all, please be gentle- first post.

    I've recently upgraded my samsung galaxy s2 (on t-mobile) to ics (via kies). It has been running sweet for the last week or so but today i was playing around with the "data monitor" app, and somehow managed to set the upper limit to 2048gb...

    Since this, the data monitor app runs extremely slowly, eg, from selecting data monitor app via settings, it can take upwards of 2mins to draw just the graph. The rest of the OS appears to be running smooth but 'settings' app is equally sluggish but once 'unresponsive app' is force-close, then settings springs back into life.

    i tried to set the upper limit to 2048mb via the set limit screen, but then i must have tapped into the 'limit' edit box and the 'keyboard input' appeared and before i knew, the value in box was 2047xxxxMb (where xxxx are other numbers i don't have to hand).

    the graph widget has the upper limit set to 2097152 which, interestingly is 0x200000, a coincidence? (yes, i'm a s/w engineer!)

    I've tried changing the upper limit via the interface buts it's painfully slow and i haven't managed to successfully do this. I'm hoping that someone out there knows if the data monitor app stores it's settings in a file somewhere on the Android's file system that i can change behind the scenes. Or does someone else have an alternative solution/cause to this issue.

    cheers!

    Advertisement
  2. CaptBones

    CaptBones New Member

    error in post above- the edit 'limit' widget has the value 2147483647 (0x7fffffff), a factor of 100 larger than i first thought (2047xxxx). The other value on the graph itself is correct.
  3. Xerses

    Xerses Well-Known Member

    Since I have not received the ICS update from Telus yet, the only suggestion/question I can make is...

    ...have you considered resetting the phone to default?
  4. CaptBones

    CaptBones New Member

    re: resetting back to default- Not yet, that would be last ditch attempt (which I'm getting quite close to).

    I may sometime in the future try a more technical forum (say an Android OS forum) but I'm still biding my time.

    As useful as this datamonitor functionality is, I can live with out it for the moment!
  5. CaptBones

    CaptBones New Member

    Hi All,

    Been a while since I've tried to resolve this issue- I have now managed to reduced the "upper limit" via the graph and keyboard (it took me 2 hours to do this!) and here's some more info that I found out along the way....

    If you switch "mobile Data" to 'off', then the "data usage" app springs back into life.
    >>>I found this out recently whilst on holiday- the phone was in "airplane mode" and I could access the data usage screen without the slow-down, although I couldn't access the logged data though. I witched off the "mobile data" and took the phone out of "airplane mode" and *could* access data monitor stats, etc. But if I turned the "mobile data" back 'on' then the app reverted to it's ridiculously sluggish operation.

    Changing the upper limit whilst in "airplane mode" had no effect
    >>> it seems that although I could change the upper limit whilst in airplane mode, when I exitted airplane mode, the upper limit was still set at the v. high value.

    "com.android.settings" is the process that takes up all CPU
    >>> according to the "debug utils| show CPU usage overlay", it is the "com.android.settings" app that is taking up the CPU.

    (I think) it is the drawing of the graph that is causing the issue
    >>> I noticed (when in airplane mode) that the graph has a vertical line marking off each 256mb of data between 0 and your upper limit. so in my case, i believe the graph widget was trying to draw a fair few thousand (millions?) of these lines on the graph between 0 and my v.high upper limit). I cannot prove this (maybe if I had a different "debug option", "flash screen widget currently being updated" or something like) but it is my gut feeling.

    I think that's it. Good luck to anyone else who (somehow) sets a v.high upper limit on the "data usage" setting app".

    Just to reiterate, I managed to sort this by using the very sluggish screen interface to 'tap' the upper limit on the graph, which brought up the "change upper limit" dialog. I then 'tapped' the large upper limit in order to bring up the keypad and some how I managed to clear the large number and enter a smaller one. put your phone into airplane and practise on the data usage app!

    cheers for you time.
    Atma likes this.
  6. alextop30

    alextop30 Well-Known Member

    I have to tell you that what you did takes very big persistence because I know if I experience latency off my phone of 3 seconds or longer it is out of there.

    Next - I am using that stupid app that T-Mobile to show me my data usage. What I have found that the only way to see the real usage is when you are on the mobile network and that updates fairly quickly the rest of the app is actually trash.

    As for the stock app that manages data - I personally think it is another pointless thingy as it is buggy - I know the bug you are talking about and it is annoying as hell. Plus that 0000x1FFF thing I believe is where the error occurs however I have very little understanding of memory errors which is what I believe it is. Next the native app is also pointless because every time you install a rom on your device it resets (that is if you are as adventurous as I am :) ). I would simply suggest a third party app that would log the amount of traffic. Get one of those and forget this struggle - get a cup of coffee and enjoy life!!!! :)

    Seems My Data Manager is pretty nice - but do read the description and make sure it suits your fancy...

Share This Page