Data network not working after factory reset


Last Updated:

  1. imek

    imek Member

    My phone been running slow lately so I decided to do a factory reset. I backed up using ClockworkMod and then did factory reset. When the phone finished factory reset, everything seem to be working fine except that it is not connected to Sprint data network at all. The box for mobile network is check but it is not connected. I then restore back to what I had before but network is not working there either now. I tried turning on and off airplane mode and Mobile network but that didn't help.

    Lastly, I boot into ClockworkMod again, but this time I wipe cache partition, as well as Wipe Dalvik Cache, and then did the factory reset. But that still didn't solve the problem. Any ideas on how to fix this issue? Thanks.

    Currently running CyanogenMod 2.6.29.6-aospCMod

    BTW, should I upgrade to the CM7?

    Advertisement
  2. LBPHeretic

    LBPHeretic Well-Known Member

    If you have your original Nandroid that backed up your stock Android 2.1 ROM, then try going back to that. You can also try toggling mobile data on and off.

    Once in a very rare occurrence, my handset will not have mobile data connectivity after doing a reboot. I just toggle the mobile data widget on and off and it comes right back.
  3. KitsapAndroid

    KitsapAndroid Well-Known Member

    I too have had this occur, and toggling the widget on and off has always made it come back. Personally, I would make the jump over to CM7. It's what I've been running and it performs fantastically.
  4. LBPHeretic

    LBPHeretic Well-Known Member

    Haha. I am on CyanogenMod 7. :D

    I guess I should change that information under my avatar. I keep meaning to do it. ;)
  5. imek

    imek Member

    I forgot to reply on what happened. So what had happened was that I needed to pay my bill lol, so I guess they decided to cut off my internet until I pay them. But it was just coincident that it stop working right after I did the factory reset, it was fine beforehand. After I paid my bill the next the day, the internet worked by itself.
  6. mnshimul

    mnshimul New Member

    Hello,
    I root my glaxy SII few days ago and after that time data network mode keep active always. If I deactive it after few minute later it active automatically. when ever I open phone lock data network mode active always. I checked my mobile network setting there use packet data option is unselected but than also data network active and keep running all time. I don't face any problem use internet but I have limited data and it drain battery life.

    can any one give me any idea how to fix this problem? plzzzzzz
  7. Lobo89

    Lobo89 Well-Known Member

    Welcome mnshimul. This is actually the Sprint Hero subforum; you will probably find better help under the specific subforum for your phone.


    The page at the link below has a listing of all the phone-specific subforums:
    http://androidforums.com/

    Check the root section for your phone and you should be able to find the help you need. Good luck!

Share This Page