Dead MT4G after usb charge via pcSupport


Last Updated:

  1. Raw11

    Raw11 New Member This Topic's Starter

    Joined:
    Dec 5, 2010
    Messages:
    3
    Likes Received:
    0
    Got a MyTouch 4G on Black Friday at Costco (upgraded for $150 before $50 mail in rebate) and it worked great for 3 days. It charged with the wall plug and the usb cable fine Friday and Saturday. Transferred files fine from pc. Charged it via the usb cable connected to my pc Sunday night and it was just went dead. I tried charging in the wall and in the car, removing the battery, everything. No luck - it was toast.

    Took it back to Costco Monday and swapped it out for a new one. Everything has been cool with the new one for almost a week now. I have connected it to the pc a time or two to transfer files and charge it. One time, it acted like it was about to freeze up after unplugging it. Yes, I unmounted it in Windows beforehand.

    Has anyone else had any issues like this?

    I'm a little scared that it will die again. It has the warranty and I even got the insurance. But it is a hassle to have to go and swap it out and re-install all my stuff.

    Was it just a defective phone or a bad usb cable or a power surge or something with the pc?? Any ideas would be appreciated!
     

    Advertisement
  2. Blacklight82

    Blacklight82 Well-Known Member

    Joined:
    May 31, 2010
    Messages:
    209
    Likes Received:
    31
    Did the LED flash orange when you tried charging after it died? This happened on my Incredible twice and I thought the battery was a goner. I replaced the battery after first time but it happened again with the new one.
    I figured that it wasn't a dead battery but just a bug with the system. All I did was plug in the wall charger and immediately press the power button a couple of times. The battery was completely drained and I just let it charge for a few hours and all has been well since.
     
  3. Raw11

    Raw11 New Member This Topic's Starter

    Joined:
    Dec 5, 2010
    Messages:
    3
    Likes Received:
    0
    No, the light was orange when I first plugged it into the pc. I went to check it's progress and nothing. No light at all, even when I plugged it into the wall and car...
     
  4. gohausmachine

    gohausmachine Well-Known Member

    Joined:
    Oct 18, 2009
    Messages:
    212
    Likes Received:
    22
    Oh wow I feel bad for ya man. I would bring this problem up to Tmo they may replace your phone or just the battery.
     

Share This Page

Loading...