Dead N7. Black screen, no backlight, no charge (no this is not the usual long press power problem)Support


Last Updated:

  1. phred259

    phred259 Member

    So my N7 died yesterday while at nearly full battery. It was running a game, made a horrible buzzing noise instead of the game's usual sound effects, then I tried to turn it off with a long press to reset it, and eventually it did turn off after a number of "app X is not responding" messages.

    The screen went black, and it hasn't been back since.

    Plugging in the charger shows no response. No backlight, no flicker, no noise. Deadsky. No combination of power+volume buttons, at any length of time (have tried for 30-45 seconds, 2 minutes, and once desperately for 5+ minutes) seems to help. Battery is well connected internally, and I have tried disconnecting and reconnecting it. Stock charger does nothing much, and plugging into PC USB again no response.

    There does seem to be some power draw, as the battery grows warm when plugged into the charger for extended periods. Have left it unattended and not charging, and then charging for hours, without result.

    I purchased it from newegg, so I'm guessing I'm stuck going to ASUS for an RMA.

    Any tips, hints, advice?

    Advertisement
  2. jhawkkw

    jhawkkw Chinchillin' Moderator

    You could try to take the battery out like a traditional battery yank. After that, replace the battery and plug it into the wall and let it charge for like a day. If that doesn't work, chances are that is the route you need to go.
  3. phred259

    phred259 Member

    Thanks jhawkkw. I did yank the battery entirely at one point. Now on the 'letting it charge for a day' step since ASUS North America isn't at work today, anyway.

    Honestly crushed that my N7 died. Feels like we lost a family member. I've been a tech geek my whole life and never been quite as sad as when my trusty companion quit on me! :(
  4. jhawkkw

    jhawkkw Chinchillin' Moderator

    It's a weird thing if the battery on this device completely dies. You plug it in, but often there is no reaction. And even after letting it charge a full day, it will get some life, but only about 5-10%. After turning it on with that life will it charge all the way up.
  5. phred259

    phred259 Member

    I'm really hoping that's all it is - but my hope isn't strong since as I said, it had a nearly full battery when it croaked.
  6. jhawkkw

    jhawkkw Chinchillin' Moderator

    Yeah, I hope this works to save you the RMA. The withdrawal of sending an addicting electronic deice away is intense.
  7. lucky013

    lucky013 Well-Known Member

    What happens if you.hook.it.up to a toolkit and choose dead. Try and reset?
  8. silvercue

    silvercue Active Member

    I had a similar problem with my first Nexus. Wasn't sure if it was taking a chrage or screen was faulty. Realised it was screen after (very occsionally) it would come on for a bit then fade.... I returned to store and they said they had been inundated with returns for various screen faults.

    Your sounds maybe a bit different as you had app error messages, I can't recall if I had that.

    I have gone through 3 Nexus 7s now......and not got one that works at the moment :(
  9. phred259

    phred259 Member

    Thanks, lucky. How do I hook it up to a toolkit?

    EDIT: Plugging the usb cable into a PC shows nothing on Windows. I'll try a Linux machine and watch dmesg when I get to work this morning (right before I call /shudder Asus).
  10. keifer123

    keifer123 New Member

    have you tried a different cable?
  11. lucky013

    lucky013 Well-Known Member

    You need to install Wugfreshes nexus root toolkit on your pc and do a factory reset. Can't hurt to try.
  12. jhawkkw

    jhawkkw Chinchillin' Moderator

    Unfortunately, the toolkit won't do much good if the computer won't see the tablet. If the charge up didn't help, looks like it's rma time.
  13. phred259

    phred259 Member

    Yup, no response from USB (so ADB or anything helpful like that) and swapping in a different battery didn't help either. Brief chat with ASUS and then RMA'd it.
  14. Netcat

    Netcat Well-Known Member

    Have you tried this? I have not but I found this on Android Central and people there says it worked to bring a N7 back to life.

    With the unit off...
    -Press and hold volume down and power.
    - Keep holding the buttons 'till it reboots to the bootloader.
    - Cycle through the menu selections and choose to power off the device.
    - Unplug then re-plug the charger.
    - You should now see the battery-charging icon. Just let it sit and charge to full capacity.

    Nexus 7 problem; Won't charge, and when it does, screen goes dead and pixels fly across the screen. - Android Forums at AndroidCentral.com

Share This Page