[Debug] SetupConnection Update ProblemSupport


  1. JiMinitaur

    JiMinitaur Member

    I had a lot of problems with this, but I did get past it, so I wanted to put my experience out there for anyone having the same issue.

    For those who don't know, some users experience a hang in the final stages of the official update tool. After hitting the "Start Download" button, the status bar goes:

    [Debug] Run
    [Debug] SetupConnection

    .. and then just hangs. The first time this happened to me, I just thought it would just take time, but after leaving it to its own all night, no progress was made.

    The consensus I found was that you simply need to keep retrying. Success stories ranged from PC reboots, to update tool uninstalls, to battery pulls and cable unplugs. I got it done with the later, and I'm pretty sure that, driver conflicts aside, it's the only thing that is really required.

    I think the reboots and tool reinstall only work because there is a random chance that the connection to the phone will be established properly, so rebooting/reinstalling is the same as retrying from the "Start Download" screen, only it takes longer because you start from the begginning.

    The problem with restarting from the "Start Download" screen, however, is that if you simply unplug/replug the USB, windows detects the phone as an unrecognized device. At first, the only way around this I could find was to reboot the whole update tool.

    The trick I found was to power cycle the phone every time I unplugged the cable. In pretty list format:

    1. Unplug the USB (Update tool displays error notification)
    2. Remove the Battery
    3. Reinsert the battery
    4. Hold Camera+Volume Down+End (to boot to the download screen)
    5. Press "Start Download" Button on PC update Tool (when it becomes enabled aka not grayed out)
    6. Wait 5 seconds after "[Debug] SetupConnection" appears
    7. If the status doesn't change, repeat from 1.

    It took me about 3 tries before it took successfully. When it finally worked, the status "[Debug] SetupConnection" changed to some random question mark jibberish almost immediately.

    This worked for me on XP SP3. I hope it helps others as well.

    Advertisement
    :
  2. JiMinitaur

    JiMinitaur Member

    For clarification. This only applies to those who don't have driver conflicts. if you have old samsung drivers installed (i.e. if you installed PC Studio) You need to uninstall them before running the Sprint tool.
  3. JiMinitaur

    JiMinitaur Member

    UPDATE:

    I re-flashed my phone using the SDX ROM from JoeyKrim, as per:

    Official Android DE03 2.1 with SDX custom recovery and BEYOND!

    Had the same issue (Stalled at SetupConfig), only this time it took 5 power cycles to fix.

    My recommendation, if your experiencing this problem is to follow repeat these steps till it works


    1. Unplug the USB (Update tool displays error notification)
    2. Remove the Battery
    3. Reinsert the battery
    4. Hold Camera+Volume Down+End (to boot to the download screen)
    5. Press "Start Download" Button on PC update Tool (when it becomes enabled aka not grayed out)
    6. Wait 5 seconds after "[Debug] SetupConnection" appears
    7. If the status doesn't change, repeat from 1.
  4. craigpicc

    craigpicc Active Member

    the most important thing i found that made the update work was removing old drivers and studio. first i removed the drivers and it got the debug error and nothing i did made it work. then i removed studio and it worked. it took several cycles of removing battery and going back into download mode, but it did eventuall work after about 4 tries. you just got to make sure you remove all the old drivers and studio.
  5. NOMster

    NOMster Well-Known Member

    When mine did that I had to download a fresh copy of the updater. Then it worked fine
  6. craigpicc

    craigpicc Active Member

    yes...i did that also...thamks for adding. i forgot that point.
  7. ColdStart

    ColdStart Well-Known Member

    I experienced a different problem on my Vista pc. When the screen came asking you to accept the EULA or whatever it's called, there was no next button to click. I finally started changing the graphics display settings. What I wound up with was 1440 x 900. And at that, I still could only see the "NEX" written on the button.
  8. venom1000

    venom1000 New Member

    did anyone else have the "e - dll cannot setup coonection with the target" durring the install process?
  9. n9ssham

    n9ssham Member

    Thanks JiM..,

    After working all day on this and literally 50plus attempts all stuck at "setupconnection" I tried your handy list and it worked the very first time through the list! I did not have to reinstall the installer. I just followed your steps... I did get the error message "e - dll cannot setup coonection with the target" (mentioned by the previous post) as soon as I unplugged the USB connection, so if some are getting this message it might just be a bad cable.

    I am embarrassed to share this point, but I spent the first 4 hours trying to get the USB driver to install until I realized that the USB cable I borrowed was for apparently for charging only! Once I found my original cable the USB driver installation went through without a hitch.

    But what is the deal with this USB driver recognition, going through it twice as part of the Moment install routine... sounds like they were having problems at Sprint with the USB connection and that is the work around they came up with. Too bad it didn't work! I kind of wonder if it might be timing related? When I followed the "list" I plugged the USB cable back in almost immediately after entering the download mode, instead of the several seconds that probably elapsed during my previous multiple failed attempts???

    Oh well, it finally worked and the new 2.1 looks pretty slick... I am going to wait a week before I install any apps, so that I will be able to fully evaluate the new OS in all its' virgin glory! If they haven't fixed some of the BASIC problems with this phone, I will be at the Sprint store demanding a belated return next week. I have put up with 1.5 and 1.6 for many many months, and I am at my limit with Sprint and their inability to address dozens, if not hundreds, of BASIC operational defects in the OS! You know, just simple things like not being able to answer a call without waking up the display which you do by pressing the "end call" key... what were they thinking!!!!!!!!

    Dave in Illinois
  10. genus

    genus New Member

    I got mine working, but i did something slightly different, instead of waiting after the status bar, i hit it as soon as it appeared and it worked the first time i tried!

    btw, i was getting the same error as mentioned above: "e - dll cannot setup connection with the target" each time i would reset.
  11. mltsy

    mltsy New Member

    I have to confirm what craigpicc wrote - uninstall New PC Studio entirely. I had already followed Sprint's instructions to uninstall the old Samsung USB drivers - but tried the above steps 10 times or so with no luck. SO, I uninstalled New PC Studio (thank you, craig), and then running the update program resulted in a program crash, so I had to uninstall/re-install that, run it, the first attempt failed, and the second attempt (following the above steps) worked. So, for clarity:


    1. Uninstall New PC Studio
    2. Uninstall SW Upgrade (run the installer again, and select "remove")
    3. Restart your computer
    4. Install SWUpgrade again
    5. Run it
    6. Follow all instructions and wait for [DEBUG] SetupConnection
      NOW ON THE PHONE:
    7. Unplug the USB cable
    8. Remove the phone battery
    9. Replace the phone battery
    10. Hold VolDown + Camera + End (until you see the download screen)
    11. Plug in the USB Cable
      NOW ON THE COMPUTER:
    12. Click the Start Software Download button
    13. Bob's your uncle... finally. (if not, repeat steps 7 - 12 to try again)
    P.S. I'm running Windows 7
Loading...

Share This Page