Decks difficulties.....


Last Updated: 2012-12-15 17:30:37
  1. jg62

    jg62 Well-Known Member

    Hey guys,

    Been running decks since it was released and originally was working fine, over time (obviously not a long time) my phone has started experiencing wake lag, and now I am having problems with phone usage, when I end a call, the screen to hit "end call", does not populate so if I am leaving a voicemail my screen does not wake and I am left listening to all the options for voicemail. Eventually it does appear but may take 90 -120 seconds to do so. (This problem never happened prior to decks, I guess it could be the proximity sensor, but I kind of doubt it. Would have to load a different rom to be sure)

    I have tried other kernels bw ver2, wheatley, etc, and adjusted the min. cpu up to 384, and also checked the option to use the volume control to wake phone, with no change in behaviour.

    One more thing I was curious about is whether or not there is any setting to adjust the incoming call volume (not the ringtone but the volume of the caller on the other end) Mine seems to be toward the low volume end and if I get minimal background noise it makes it difficult to hear the other party. It seems MikG had an adjustment for this, although I could be mistaken.

    Sorry this is so long, but thanks in advance for any help you can send my way.....:D

    Advertisement
  2. dustwun77

    dustwun77 Endeavor to Persevere :) Guide

    I had the wake lag after a while with the previous release. I couldn't find a fix for it.

    This version has been fine for me so far, knock on wood.

    have you tried the old standbys of going in to recovery and wiping cache and dalvick cache? Don't think it would hurt to try.

    Did you, by any chance, make a nand of this rom when you got it set up the way you wanted it? If so, maybe use an app like titanuim to back up your current goodies and restore the nand and see if it helps?

    A lot of roms you can dirty flash, as in flash it without wiping (other than maybe the above mentioned caches) right over itself. It would revert some settings to default and remove certain mods and themes, but otherwise usually leaves your data intact.

    There are some roms now that pre wipe for themselves now, I think the last Mik rom was such, so it would have to be modified for it not to.

    Other than that, I am wondering what apps may have been upgraded or added to the mix that could be affecting it?

    Has your battery life changed recently? could something be stuck? did it happen to occur and you find out that the playstore has updates waiting for you?

    I wish I could say a certain kernel setting of cpu or governor or clock speed would do it for you but I was never able to resolve it earlier, so I have nothing to offer there.

    Let us know what you find or if you fix it please! :)

    oh, and regarding sound level while in a call, I think you can just hit the volume up button while in the call to raise it and it will stay that way for future calls.
  3. jg62

    jg62 Well-Known Member

    My volume up/down has no effect on volume while in a call, works as it should when adjusting ringtone volume when not in a call.

    Thanks for your suggestions, I appreciate you taking the time to answer.
    ocnbrze and dustwun77 like this.
  4. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Are you using the default kernel? Have you tried the sbc-fso version of the MasonG d.15?
    I have a slight issue with the volume of the caller...cannot change it while the phone is by my ear ...I have to pull it away from my ear, wait about 2 seconds for the screen to come on to change the volume.

    Edit: Have you tried the smartass2 governer and the deadline scheduler ?
    jg62, ocnbrze, tube517 and 1 other person like this.
  5. jg62

    jg62 Well-Known Member


    Yes, I am still running the default kernel, will give the fso version a try. Tried the volume adjust but didn't have any luck, thx for the suggestion though mike.

    will keep you posted on how the kernel change works out, thx again mike

    edit: yes to the smatass 2 gov, negative on the scheduler
    Mikestony likes this.
  6. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    If you need the link to the fso version, let me know. I got it in my DB :)
    jg62 likes this.
  7. jg62

    jg62 Well-Known Member


    thought I had it, but i was mistaken, could I get that link from ya, thx mike
  8. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    jg62 likes this.
  9. jg62

    jg62 Well-Known Member

  10. jg62

    jg62 Well-Known Member

    Hey Mike,

    will update you tmr, gotta be up early so I'm hanging it up tonight, thx for all your help buddy
    Mikestony likes this.
  11. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Hope that helps your issue, but you know, kernels act different on diff. devices...so, just let it settle a few days...
    Otherwise Dust and I will have to brainstorm a little more:p
    dustwun77 and jg62 like this.
  12. jg62

    jg62 Well-Known Member


    Dropped the Mason sbc-fso in and will see how that responds over the next couple days, however I did get my in-call volume raised with your phone away from the ear trick...:D So at least we are trending in the right direction....:)
    Mikestony likes this.
  13. jg62

    jg62 Well-Known Member

    Just an update on what has transpired. Dropped the sbc-fso kernel in about (3) days ago, and removed (1) app. Since then I have seen some improvement but the wake lag is still there, although I think it has improved moderately. Guess that leaves me with (3) choices, deal with it, reload it, or wait for BMG...............decisions, decisions.

    Thanks for all the suggestions guys, appreciate it.
  14. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Ya know one thing I didn't check, and I don't know is, if this rom or kernel is undervolted by default. Some devices just cannot handle undervolting...such as mine....I should check what mine is set at :)
  15. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Found it
    [​IMG]
    Hope you can read that I uploaded it from Tapatalk
    jg62 likes this.
  16. jg62

    jg62 Well-Known Member

    Can read it fine Mike, not sure I understand it though......:confused:
  17. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    I'll explain it the best way I can, and I'm sure someone else can do better but here goes.
    Each frequency is assigned a upper and a lower voltage threshold.
    Undervolted kernels will lower those voltages, both upper and lower, to save battery.
    You can "up" those voltages by either the included Vipermod script, accessed in Terminal Emulator, like I did, or an easier way, is with the app called Incredicontrol. (other apps can do it too, but I use that one)

    If you want to use TE (Terminal Emulator), just open TE up, type "su", (without the parenthesis) and hit enter.
    Then type "vipermod", then enter.
    Then choose option 1, then enter.
    I have not changed voltages with Vipermod, I just read them via TE. :)

    Edit: found the original voltages for each frequency here: both upper and lower are the same:
    { 19200, 925, 950 }, // orig voltage 1050
    { 128000, 925, 975 }, // orig voltage 1050
    { 245000, 925, 975 }, // orig voltage 1050
    { 384000, 925, 975 }, // orig voltage 1050
    { 422400, 925, 975 }, // orig voltage 1050
    { 460800, 925, 975 }, // orig voltage 1050
    { 499200, 925, 1000 }, // orig voltage 1075
    { 537600, 925, 1025 }, // orig voltage 1100
    { 576000, 950, 1050 }, // orig voltage 1100
    { 614400, 950, 1075 }, // orig voltage 1125
    { 652800, 950, 1100 }, // orig voltage 1150
    { 691200, 975, 1125 }, // orig voltage 1175
    { 729600, 975, 1150 }, // orig voltage 1200
    { 768000, 975, 1175 }, // orig voltage 1200
    { 806400, 1150, 1200 }, // orig voltage 1225
    { 844800, 1175, 1225 }, // orig voltage 1250
    { 883200, 1200, 1250 }, // orig voltage 1275
    { 921600, 1200, 1275 }, // orig voltage 1300
    { 960000, 1225, 1275 }, // orig voltage 1300
    { 998400, 1225, 1275 }, // orig voltage 1300
    maxnix, ocnbrze and jg62 like this.
  18. jg62

    jg62 Well-Known Member

    Here is what I show:

    [​IMG]
  19. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Can't see that my friend..broken image?
  20. dustwun77

    dustwun77 Endeavor to Persevere :) Guide

    I see that you saw MB's advice to disable autobrightness, That help any?
    jg62 likes this.
  21. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

  22. jg62

    jg62 Well-Known Member


    I checked but I was already disabled
    ocnbrze and dustwun77 like this.
  23. jg62

    jg62 Well-Known Member

    @ Mike Stoney - I'll try sending it again, but basically my values are nearly identical to what yours are
    Mikestony likes this.
  24. jg62

    jg62 Well-Known Member

  25. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    That's o.k...hmmmm....I wonder if you have both boxes checked at the "screen animations on" and "screen animations off"
    In advanced settings/display....
    Right about now, I starting to grasp at straws:rolleyes:
    jg62 likes this.

Share This Page