Support decrypt Galaxy S3

Discussion in 'Android Devices' started by tscott70, Sep 8, 2012.

  1. tscott70

    tscott70 New Member
    5

    Sep 8, 2012
    2
    0
    5
    S3 has been encrypted in order to receive corporate emails from an Exchange server. I need to remove the encryption (un-encrypt) since I'm not able to update the OS because the phone is encrypted...

    When I look in Settings -> Security, under "Encryption", it just says the phone is encrypted and the option is greyed out. I see no way to remove the encryption.

    Am I missing something here? Is it not possible to unencrypt the device?

    thanks in advance.
     

    Advertisement

  2. Rachel A

    Rachel A Well-Known Member
    213

    Aug 11, 2010
    2,459
    869
    213
    Female
    DBA & Developer
    In front of my S3
    From what I know, if you're to stand any chance at all you will have to factory reset your device at the very least.

    Not to sound alarmist, but I did read of some folks who were unable to succeed with even that.
     
  3. tscott70

    tscott70 New Member
    5

    Sep 8, 2012
    2
    0
    5
    Thanks for the response. I'm willing to do a factory reset, but I also read that it may not work and may even make the situation worse, so I'm hesitant.

    I can't understand why the option to decrypt the device isn't there........
     
  4. Szadzik

    Szadzik Well-Known Member
    223

    Feb 15, 2010
    5,413
    715
    223
    Male
    FAS Admin
    If you use an Exchange account it imposed the encryption setting. delete theExchange account and you should be able to decrypt it.
     
  5. Rachel A

    Rachel A Well-Known Member
    213

    Aug 11, 2010
    2,459
    869
    213
    Female
    DBA & Developer
    In front of my S3
    My understanding is that you can encrypt only. If you don't want the encryption any more than you have to reset the phone back to stock (or other ROM). There is no decryption process as such.
     
  6. mr stroudy

    mr stroudy New Member
    5

    Sep 10, 2012
    4
    0
    5
    You MUST run the decrypt process in settings and then backup and factory reset.
    And then you can restore all settings.
    This works with the galaxy s3
     
  7. Szadzik

    Szadzik Well-Known Member
    223

    Feb 15, 2010
    5,413
    715
    223
    Male
    FAS Admin
    I do not know where you got this idea, but if that is true, what would the point of encryption be? I think you are completely wrong and agree with the post right above mine. You have to decrypt first.
     
  8. Rachel A

    Rachel A Well-Known Member
    213

    Aug 11, 2010
    2,459
    869
    213
    Female
    DBA & Developer
    In front of my S3
    You misunderstood me.

    What I am referring to us the ability to take an encrypted device and decrypt it just by changing a setting.

    Everything I've read on the subject so far indicates that the process is a one way street. Once turned on it can only be turned off by performing a factory reset and formatting the internal storage.

    The point of encryption (and yes, I do know a thing or two about encryption having extensively used symmetric and asymmetric keys to protect credit card data for several years) is to protect the data on the device whilst in operation.

    Once encrypted you have to type in a password or pin (no pattern lock) at (can't remember if this is either at boot time or unlock) on the phone to facilitate the decryption. Thus then enables the data to be decrypted for that session. I guess that this may use an asymmetric key possibly protected by a symmetric key, but I've not looked into this to say for certain.

    However, unlike apps such as TrueCrypt on the PC, there is no device decryption option available on Honeycomb, ICS or Jelly Bean.

    http://support.google.com/android/bin/answer.py?hl=en&answer=1663755

    If you'd like to dispute my answer, please provide references as to how it can be achieved.

    There is a massive difference between symmetric and asymmetric keys. Knowing this is important before you make statements as you did above.
     
    Szadzik likes this.
  9. mr stroudy

    mr stroudy New Member
    5

    Sep 10, 2012
    4
    0
    5
    Trust me my answer above works I had the problem and solved it this way.
     
  10. SUroot

    SUroot Well-Known Member
    1,123

    May 25, 2010
    23,925
    5,304
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Yes entering a password will decrypt for the session. I have no experience with encryption on the s3.

    However, as a desktop Support technician, I can confidently say that hdd encryption products such such as:

    PGP WDE
    Checkpoint FDE

    Will definitely do a full decrypt (removing all trace, permanently) so the tech is there. Sure it can take days but it can be done so at least there is a precedant

    Slightly off topic

    I've asked Samsung some questions which they have yet only partially answered in regards to sd encryption. They state that if the s3 dies, there are desktop apps that will decrypt the sd, though they wouldn't tell me which.

    What encryption is used, anyone know? I read somewhere it was AES
     
  11. Rachel A

    Rachel A Well-Known Member
    213

    Aug 11, 2010
    2,459
    869
    213
    Female
    DBA & Developer
    In front of my S3
    Where you rooted? Because that's the only way you can recover everything from a factory reset - you have to have had valid backups first to restore from later, and you can only backup the contents of the /data/data folder with a rooted app.

    None of this disputes that there is no decryption option per say.

    You turn encryption on and it stays on until you factory reset the device which will wipe out the local storage files in the process and give you a fresh new OS installation.

    Granted this is for the Galaxy Nexus, but point still stands: http://forum.xda-developers.com/showthread.php?t=1396720
     
  12. Rachel A

    Rachel A Well-Known Member
    213

    Aug 11, 2010
    2,459
    869
    213
    Female
    DBA & Developer
    In front of my S3
    Yes, it is AES-256
     
    SUroot likes this.
  13. mr stroudy

    mr stroudy New Member
    5

    Sep 10, 2012
    4
    0
    5
    Ok I'll make it simple, I have a galaxy s3 (not rooted) and I encrypted my phone and the password overtime annoyed the hell out of me, so in settings I went to security scrolled down to Decrypt phone (not encrypt) done that then went straight to reset.
    My phone is now working as it did before I encrypted it. I made sure everything was backed up first though.
    Good luck

    Oh and I backed up to computer not phone as that would just be silly lol
     
  14. portuguess

    portuguess New Member
    5

    Sep 17, 2012
    1
    0
    5
    You are missing the point. Based on the particular exchange outlook settings that the OP as well as myself has, there IS NO DECRYPT OPTION as it is grayed out. In your situation, the encryption you had was not as deep and therefore you could decrypt and then reset. We CANNOT DO THAT, as due to the type of encryption we have, decrypt is not an option. When I chose to encrypt for this exchange server, it told me that I would not be able to decrypt (yes, I read the disclaimer it showed) and now would have to do a factory reset to hopefully have this phone decrypted.

    So, your posts are of no help because you do not understand the situation
     
  15. MatthewCordaro

    MatthewCordaro New Member
    5

    Sep 25, 2012
    2
    0
    5
    I'm having the exact same problem on a Toshiba Thrive after an OTA update to ICS.
    I remember being able to decrypt before the update from Honeycomb. I can recall I even did it once just to test that it would work before loading a ton of apps. It seems that somepoint after the update, the option disappeared. Did you encrypt before an OTA update, or any update, to a new OS level?
    I'll let you know if I find anything as searching for a decryption solution is by far easier than a factory reset with 100 installs with settings. :p
     
  16. doubleshocker

    doubleshocker New Member
    5

    Oct 5, 2012
    3
    0
    5
    I had the same problem. I solved it and posted it on my blog.

    Essentially, you need to remove your exchange email account from your phone and your company's OWA site.

    Then you can decrypt your phone. Your phone is only doing what it's told - since you have an active exchange account with a policy requiring encryption, that option to decrypt is greyed out until you remove the account.

    My blog is here - I'm new so I can not post links, but if you want the play by play - here it is.... computer-hints-and-tricks.blogspot.com

    Not sure if that will help you out, but it worked for me.
     
  17. pfp_az

    pfp_az Active Member
    15

    Sep 28, 2012
    40
    0
    15
    I don't believe there is an difference in the encryption itself. The difference is that when you enable the Exchange Server sync you relinquish some control of your phone to the Exchange administrator. Since the Exchange administrator has stipulated that the mobile device must be encrypted the phone will not allow you to decrypt. I can't say for sure but I'd guess that removing the Exchange account (especially if that process removes all exchange data) would then allow you to decrypt since the phone no longer has to answer to the Exchange administrator.
     
  18. doubleshocker

    doubleshocker New Member
    5

    Oct 5, 2012
    3
    0
    5
    You are correct. Please see post above - once the account, under settings...sync and accounts, is removed, the policy associated to the account is also removed, thereby making the decrypt option available.
     
  19. SayaO

    SayaO New Member
    5

    Jun 10, 2013
    1
    0
    5
    I had no idea what encryption was until i tried doing so...
    I've just decrypted my phone, but the SD card keeps encrypting...
    There is no decrypt option for the SD card...

    So, I'm not sure what to do.
     
  20. Rxpert83

    Rxpert83 Dr. Feelgood
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    You are probably going to have to reformat the card
     
  21. Darshan_Dilse

    Darshan_Dilse New Member
    6

    Jan 8, 2014
    1
    1
    6
    Guys i found out how to decrypt the SD Card on galaxy SIII.

    Go to security->Encrypt external SD card-> Uncheck all option and ->Continue.

    Its done guys!
    Quote
    MultiQuote
    Edit
     
    TommyGrahn likes this.
  22. TommyGrahn

    TommyGrahn New Member
    6

    Jan 9, 2014
    1
    1
    6
    Thank you so much for your post on how to decrypt the device. I had to enter a secure password to get into the page where I could turn off decryption. It wasn't that intuitive to get but once I did that I saw the Turn Off button which turns off the encryption. It just finished decrypting my card! I'm so happy now! I went through this once when I got a replacement phone and it wasn't able to access the previously encrypted files. Boy did that make me mad! So now I removed that stupid Exchange client (I'll just use the web interface) and I can safely give my defective phone to BB to replace (screen is unresponsive at times).

    THANKS!
     
    tracsportva likes this.
  23. donrull

    donrull New Member
    5

    Sep 20, 2014
    2
    0
    5
    This worked for me exactly as described! Thank you!
     
  24. bamph

    bamph New Member
    5

    Sep 25, 2014
    1
    0
    5
    After uninstalling exchange on my S3 I tried to decrypt it. The instructions said choose a decryption password - make sure it's at least 6 characters and a number. When I first set the password - it was 8 characters and no numbers. I entered this password and it accepted it - but never would de-encrypt. When I finally changed it to the required 6 characters and a number - it worked.
     
  25. yellowcobra98

    yellowcobra98 New Member
    6

    Sep 18, 2014
    3
    1
    6
    Fix the Encrypted phone.

    Hard Reset Phone:
    1. Power Off Phone
    2. Hold down Volume key, Home key & Screen key until the phone will vibrates.
    3. Let go of the keys then the phone boots on and off.
    4. Turn Phone On.
    5. Password setting is now available.
    :).
     

Share This Page

Loading...