Default Browser not working, Web page not available


Last Updated:

  1. justinclarke

    justinclarke Member

    The default Browser application on my HTC Hero v1.5 just keeps coming up with the standard "Web page not available" page when I try to connect to any website. This happens when I use GSM, 3G, HSDPA or Wifi to connect.

    I generally use Opera Mini to access the web and this works perfectly, it was only when I used the Dolphin Browser (to access a site that doesn't display properly in Opera) that I realised it wasn't connecting and coming up with this message, so I tried the default Browser and realised this had the same issue. I then tried Skyfire and this also did the same!

    All other applications are fine and can connect to the internet perfectly well. As I said above the Opera Mini browser works perfectly but this may be to do with it proxying the data so therefore works slightly differently to all the other browsers.

    So it seems like something is amiss with my settings / files that the default Browser, Dolphin and Skyfire use.

    Any ideas?

    Advertisement
  2. ayrshiredude

    ayrshiredude Well-Known Member

    I kinda have a similar problem with the default browser in that it won't load any pages when connected using wifi. It works fine over gsm/3g just not wifi. Again Opera works fine but any other browser I have tried has the same issue.
  3. justinclarke

    justinclarke Member

    That's interesting, sounds like a similar issue. I'm thinking it might be down to certain apps I installed/updated lately. As up until about 1 week ago all the browsers were working fine!

    I've uninstalled most of the recent apps that I updated, but it still doesn't make a difference.

    The apps were Automatic Task Killer, EStrong File Explorer, lastFM, Lookout Mobile Security (2 updates lately), Copilot, EasyTether Lite, PdaNet free edition.

    Also ConvertMe, Xkcd Viewer, WaveSecure, Handcent SMS, Wifi Analyzer, DNS Lookup, UK TV Guide, Google Translate, Dolphin, Skyfire were updated but I've yet to uninstall them to see if that helps. Will try that now.

    It could be that the Dolphin or Skyfire update overwrote something that all the browsers use.

    You have any of these apps?
  4. justinclarke

    justinclarke Member

    I uninstalled all of the apps mentioned above, rebooting after each one, and still no luck with the internet on the default Browser app.

    I reinstalled Dolphin and Skyfire to no avail either.

    Looks like it's going to be a reinstall of the ROM for me! Unless anyone has any ideas?

    Thanks.
  5. justinclarke

    justinclarke Member

    I seemed to have fixed my issue!

    Somehow my access point settings were wrong. I had my Proxy as "", my Port as ) and my APN as general.t-mobile.uk

    I used the following settings and it's working. Not sure how this got changed!

    Name: T-Mobile Internet
    APN: general .t-mobile .co .uk
    Proxy: <not set>
    Port: <not set>
    username: t-mobile
    password: ** (sorry, don't know what it is?)
    Server: <not set>
    MMSC: http :// mmsc. t-mobile .co .uk: 8002/
    MMS Proxy: 149.254.201.135
    MMS Port: 8080
    MMS Protocol: WAP 2.0
    MCC: 234
    MNC: 30
    APN Type: * (sorry, don't know what it is?)
  6. endolith

    endolith Active Member

    I'm having this issue too, but I doubt it's related to APN since I do everything over Wi-Fi and don't have a data plan.

    Android Browser says "web page not available" for everything including google.com, 192.168.1.1, 127.0.0.1, localhost, etc.

    Dolphin browser is the same way.

    Opera works fine. Other apps connect to the internet fine.

    I was wondering if it has something to do with the hosts file because I installed AdFree? But I renamed the hosts file and it still doesn't work.

    Oh. Under wireless settings there was a proxy set up.

    Proxy settings


    • Hostname 216.155.165.050
    • Port 8080
    • Use proxy only on wifi - Checked

    Maybe it will work now that I disable this?
  7. endolith

    endolith Active Member

    Yep. It works now after disabling the proxy.
  8. reegee

    reegee New Member

    I fixed this on my htc hero for sprint. I opened the settings for the network, disconnected, reconnected. Then open the google map app. Now I can get on the internet.
  9. squashbuff

    squashbuff New Member

    I replied to a similar problem on another forum some time ago. Maybe it would apply to other people having similar issues.

    I was having a similar problem yesterday after I upgraded the OS on my phone.

    Let me describe what I am using:
    HTC Glacier with Cyanogen 7 ROM including Google Apps.

    I installed TransProxy 3.08beta and a few other applications, made some config changes, enabled / disabled proxy a few times and later on the browser application that was included with the ROM would not connect to 3G data. It was working fine on WiFi. However Opera worked fine on either. Also other apps like market worked fine.

    This is what fixed it for me:
    1. Disable proxy in TransProxy
    2. Create a shortcut for system proxy settings on home screen:
    long press on home screen > custom shortcut > pick your activity > activities > settings > Proxy Settings(.ProxySelector)
    3. Open proxy settings using the shortcut
    4. Clear settings using 'Clear' button
    5. Save

    After this the browser started connecting to 3G data.

    Hope this helps.

    Cheers
  10. squashbuff

    squashbuff New Member

    Sorry for double post
  11. arngwarrior

    arngwarrior New Member

    if you clear the history and cookies, you will be able to use your browser again.
  12. niteshangre

    niteshangre Member

    u may have figured out the solution by now. also try this-you can try clearing cookies cache etc. BUT more important & effective, just get fresh internet settings for your cellphone. it worked for me..yesss :)
  13. niteshangre

    niteshangre Member

    u may have figured out the solution by now. also try this-you can try clearing cookies cache etc. BUT more important & effective, just get fresh internet settings for your cellphone. it worked for me..yesss :) enjoy
  14. emaswarisan

    emaswarisan New Member

    Hi friend..Thanks very much to u,after scroll to disable the proxy,the google browser works already.:shakehands:
  15. LoRes2101

    LoRes2101 Member

    I'm also having problems with the internet not working but I think I have a bit of a different problem than the rest of you.

    My phone is an HTC Hero S from US Cellular. Version 2.3.4

    1. The internet works in Opera Mini all the time

    2. The internet will usually work to sync Gmail emails to my phone although sometimes it seems to lose connection but will fix it self and sync several hours later.

    3. The internet in other programs usually works, like the Reddit apps. I can load stories, although it seems slow at times (maybe it is reconnecting/resetting internet connections?) somtimes imgur.com links will have to be opened in the browser (opera mini) for them to display. Possibly, again, because the connection could be interrupted.

    4. Other browsers PARTIALLY work, even after a fresh install. For example, I can go to speedtest.net and run a speed test just fine but going to facebook.com will either not work, work once, or only load the sidebars and not any profile or feed data (although it will load the notifications.) This is true for Dolphin and Opera Mobile especially. The stock browser sort of works a little more reliably but still has some issues.

    - I have tried resetting my phone to factory defaults. This seemed to fix it for a little while, but it doesn't seem to be working perfectly the whole time and it seems to be getting worse.

    - 3g generally works better tan Wifi for syncing reliability. It also seems to load web pages in any browser perfectly.

    - I am at a college campus WiFi the entire time, so the wifi is very good, reliable and has excellent strength.

    - For many connectivity issues, resetting the wifi or switching between 3g and wifi will temporarily fix the problem for 5-30 minutes or so.

Share This Page