Defective DX2?Support

Last Updated:

  1. blog

    blog Active Member

    So I'm trying to activate my freshly arrived DX2, but when I hit the activate button and it rings the activation line, i hear a dialtone that repeats every second. Beep, beep, beep.

    This interferes with the voice prompt system, so I can't really do anything. No dialpad ever appears.

    Unless I can figure out a way to bypass the activation screen, it doesn't look like I'll be playing with this phone very much before sending it back.

  2. bradyapba

    bradyapba Well-Known Member

    you can just bring it to a store, they will do it for you.
  3. square

    square Well-Known Member

    same thing happened to me. it eventually connected me to a rep. they activated it for me and had me do some test more beeping. seems like an activation issue.
  4. trophynuts

    trophynuts Well-Known Member can also do it online in your VZW acct.

    If you take it to a store they may charge you a fee.

    you can also call customer care with another phone and do it over the phone for free.
  5. DroidFiend

    DroidFiend Active Member

    Yup, count me on this list. It also connected me to a rep but I decided to shut the phone off and try again.

    Upon restart, it prompted me to add my accounts. I just skipped that, dialed *228 and I was able to successfully follow the prompts and activate with no more beeping.
  6. John58543

    John58543 Well-Known Member

    Had same problem...just sign on to your VZW account online and activate that way then activation should go smoothly on phone.
  7. blog

    blog Active Member

    There we go. Couldn't do it from the network, but was able to call from another phone and get it done. Thanks guys, nothing more to see here.
  8. nkd

    nkd Well-Known Member

    there is an easier way. Click on emergency call to bring the dialpad, thats what I did and dialed *228 and it connected me to automated activation process and asked me to verify my order number and I hit yes and waited 30 seconds and everything was done.
    grenade01 likes this.
  9. rankman

    rankman Well-Known Member

    Same thing happen to me. I activated it on and it fixed the issue.
  10. grenade01

    grenade01 New Member

    nkd for best answer. This worked like a charm! I thought the phone was defective until I saw this thread.
  11. droidnick

    droidnick Member

    The same thing happened when I recieved my replacement x2. another one sent and the same thing. went into a Verizon store and it turns out that they never assigned the new phones serial # to my account so it wouldn't activate. the rep punched in the serial # of the second phone they sent me and it worked.

Share This Page