Defective USB port?


Last Updated:

  1. quantumrand

    quantumrand Well-Known Member

    I'm under the impression that my Nexus S' USB port is defective. I was trying to use the Dalvik Debugger to take some screenshots the other day, and found that when I plug it in, Windows gives me a message saying that my USB device has malfunctioned. The thing is that it doesn't do this all the time. Every once in a while it will connect properly and my phone will show the Debug and USB symbols in the notifications.

    I've tried updating the SDK drivers and using different computers, but it's all the same result. My phone recognizes that it's charging, but not that it's connected to a computer, except for that 1% of the time that it works.

    I haven't used the USB connection much (I use SwiFTP to upload files to it), but I feel like it had worked before, but I also seem to remember it had little issues staying connected.

    I've tried clearing the cache through the recovery mode, but it didn't seem to fix it. My next step will be wiping the phone, but before I do that, I was wondering if anyone else has run into the issue and found a fix for it.

    Advertisement
  2. B2L

    B2L Well-Known Member


    Which drivers are you using? My phone had some problems connecting before I had the right drivers installed, also have you tried manually installing the drivers? And what version of windows are you using. It seems like I have had problems with the driver on windows 7. But on my older laptop with XP it installed them just fine.
  3. quantumrand

    quantumrand Well-Known Member

    I've tried it on Windows 7 and Vista. I've tried both the rev3 and rev4 drivers from the SDK, but only on one of the Win 7 machines. That computer had seen another Nexus S, so it let me install the drivers. The other two machines wouldn't let me get that far, saying it was an unknown/malfunctioning device, so it wouldn't let me update the driver manually.

    The reason I'm thinking it's defective and not just an issue with the proper drivers is because it works sometimes. Like one out of every 50 times I plug it in, it recognizes that it's connected to a computer and gives the debug/USB icons in the notification bar. After a few minutes though, it disconnects on its own and won't recognize anything anymore.

    I've tried using another USB cable as well, so I've ruled that out, too.
  4. B2L

    B2L Well-Known Member

    If that's the case I would say that it's quite possibly defective. I have taken screenshots the same way as you are trying to and never had the problems that you are. Did you buy the protection plan with it? Because if so I would have someone look at it. If not your only hope is calling Samsung technical support. Unless anyone else has an idea of what has been causing it.

    Have you tried asking around on XDA? There may be someone who has had the issue and knows a work around.

Share This Page