delete limit exceeded notification wont go away?


Last Updated:

  1. sessman

    sessman Well-Known Member This Topic's Starter

    Joined:
    Nov 4, 2009
    Messages:
    199
    Likes Received:
    24
    so I got the hero today and so far im stoked, the only question i have is i have a notification that wont go away, it says "SYNC - too many contacts deletes. then when u click on it it says "there are 255 deleted items for contacts account ******@gmail.com. What would you like to do? and it gives me 3 options, delete the items, undo the deletes, do nothing for now.

    ive tried all three options and the notification just comes right back, any ideas?
     

    Advertisement
  2. rotarius

    rotarius New Member

    Joined:
    Nov 2, 2009
    Messages:
    4
    Likes Received:
    0
    I had this error too, b/c when I got the Hero the guy at the Sprint store copied over my old phone's contacts into the new Hero. Somehow doing this and then trying to sync with my Gmail contacts won't work. I'll bet that you have 255 contacts in your Gmail "All contacts" list.

    The only way I got it to work, and this is kind of a pain, was to follow these steps.
    1. In Settings -> Data Syncronization -> Google, uncheck Contacts.
    2. Open "People", go to the "Groups" Tab. Hit "Menu", then choose "Sync Groups". I chose to sync "My Contacts" rather than "All Contacts".
    3. In Gmail on the computer, I went into each contact in My Contacts and made sure that all the info from my old phonebook was in there, e.g everyone's phone numbers.
    4. In Gmail on the computer again I went to export and backed up "My Contacts" to a Google CSV file.
    5. I deleted all the contacts out of my phone, and all of the contacts out of Gmail on the computer.
    6. I rechecked the Contacts sync box from step one.
    7. On the computer I imported the CSV file from step 4 back into Gmail.
    8. Let the phone sync.

    After doing all that, Gmail and my phone sync without that error. There might be an easier way to do this, but that's what worked for me.
     
  3. smarkham604

    smarkham604 Member

    Joined:
    Nov 11, 2009
    Messages:
    14
    Likes Received:
    0
    I ran into the same problem. I went back to the Sprint store to get my old phone contacts restored since sync seemed to delete all the phone contacts and restore all gmail contacts. I did have the forethought to export my gmail contacts before I chose delete or undelete on the Hero.

    After more than an hour, trying to sync and getting the same error repeatedly, albeit with random numbers of erroneous contacts, I realized it was syncing some but not all of my gmail and phone contacts, and generally messing up my contacts all together. The only work around discussed (from an HTC second tier tech by phone) was to use Outlook to sync the new (from old phone) contacts. Export that file for importing to gmail. Good idea except I do not have Outlook on any machine, and I use a Mac to access the phone as a USB drive.

    I left the store with the all the gmail contacts deleted with only the new (old phone) contacts transferred by the sprint store, and all three application sync settings checked off (gmail, calendar, and contacts) under Settings> Data synchronization> Google> application sync settings

    Here's what I did to remedy the problem back at home without using Outlook as a workaround:

    1) Restored my gmail contacts (remember the export I did before going to the store?)
    2) Downloaded from the market an app called "ExportContacts" by Rishi Srivatsavi
    3) Used that app to export the phone contacts to the SD card.
    4) Copied that csv file from the SD card to my Mac
    5) Imported that csv file in gmail contacts
    6) Cleaned up the gmail contacts (numerous duplicate people with phone numbers from phone contacts and email from gmail contacts) including creating custom groups.
    7) Deleted all contacts on phone
    8) re-synced gmail contacts

    I did get the error again, and chose to ignore until I turned off "Auto-sync" under Settings> Data synchronization> Google> General sync settings

    It seems to me "auto sync" was trying to sync at the same time gmail was trying to sync contacts and it created the deleted contact errors.

    I later de-selected "Sync all contacts" for People/Groups Menu> Sync groups This eliminated all the random email address I have e-mailed once in my life from showing up on my contacts, since gmail keeps the email addresses of *everyone* I have ever sent an e-mail. Now my contact on the Hero are a manageable number of contacts.

    Hope this helps.
     
  4. JameyK

    JameyK Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    83
    Likes Received:
    0
    Same thing here. Is there is a way a NEWBEE can get this to work?
     
  5. Norcaligirl

    Norcaligirl New Member

    Joined:
    Apr 14, 2010
    Messages:
    2
    Likes Received:
    0
    I did what rotarius said to to (quoted above) and I *STILL* got the error but then I turned off "Auto-sync" under Settings> Data synchronization> Google> Auto-sync like smarkham604 said to do.

    All my contacts showed up in my phone. Now I know it seems like unticking "auto-sync" is the quick fix but I think the steps that rotarius mentioned are crucial to making sure that your contacts are cleaned up.

    Good luck!
     
  6. cyberkamote

    cyberkamote Well-Known Member

    Joined:
    Jul 17, 2010
    Messages:
    68
    Likes Received:
    2
    having the same problem, but right now im too lazy to read and do the steps, but I will soon and will update you guys.
     

Share This Page

Loading...