Desire HD Fastboot Remote not allowed


  1. artstyle

    artstyle Member

    have a DHD i picked up not working. unable to load past boot screen, just goes to white screen with logo and fades. Access fastboot,hboot,recovery
    commands but they don't work same for factory reset. Just goes back to the same white screen and fades. Already spent a lot of time with no success
    go into adb and fastboot devices shows serial number and
    C:\>fastboot getvar all reports as below, have tried fastboot boo recovery.img starts loading the reports access not allowed. Call a repair
    tech and they reckon $50 to sort the software. Sounds great if it sorts the issue, but if anyone here can help it would be much appreciated.


    INFOversion: 0.5
    INFOversion-bootloader: 0.85.
    INFOversion-baseband: 26.03.0
    INFOversion-cpld: None
    INFOversion-microp: 0438
    INFOversion-main: 1.32.405.6
    INFOserialno: SHxxxxxxxxxx
    INFOimei: xxxxxxxxxxxxxxx
    INFOproduct: ace
    INFOplatform: HBOOT-7230
    INFOmodelid: PD9810000
    INFOcidnum: 11111111
    INFObattery-status: good
    INFObattery-voltage: 4101mV
    INFOpartition-layout: Generic
    INFOsecurity: off
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    INFOcommitno-bootloader: a3d4
    INFOhbootpreupdate: 11
    INFOgencheckpt: 0
    INFOregion-id: 0
    all: Done!
    finished. total time: 0.063s

    Advertisement
    scotty85 likes this.
  2. ral

    ral Well-Known Member

    Could you double check these two lines.

    Could you also post what you see on the HBoot screen. Does it say Locked/S-ON?
    scotty85 likes this.
  3. artstyle

    artstyle Member

    Sure can
    ACE PVT SHIP S-OFF RL
    HBOOT -0.95.0024
    Radio 26.03.02.26_h
    cMMC-boot
    scotty85 and ral like this.
  4. ral

    ral Well-Known Member

    The phone is rooted.

    Could you go into Recovery than Backup/Restore and select Restore and see if there are any backup's stored in there?
    scotty85 likes this.
  5. artstyle

    artstyle Member

    recovery just goes to white screen with logo and then fades to back lit black screen
    scotty85 and ral like this.
  6. ral

    ral Well-Known Member

    @scotty85 is probably the best person to help...

    I do not see the harm in try to flash a RUU and trying to return it to stock. Phone is from New Zealand? Is the phone from a carrier?
    scotty85 likes this.
  7. artstyle

    artstyle Member

    unsure of if it was from New Zealand new or from a carrier I could ask previous owner if it helps?
    scotty85 likes this.
  8. ral

    ral Well-Known Member

    If the information is not on hand, it is not that important. Would be happy to get it to boot and sort out other things later. If you are on a Windows PC you could try downloading one of these, plug the phone in the PC, and run the file.

    If you plan to root (assuming we get it working):

    RUU_Ace_Gingerbread_S_HTC_WWE_2.50.405.2_Radio_12.54.60.25_26.09.04.11_M2_release_199042_signed.exe - download now for free. File sharing. Software file sharing. Free file hosting. File upload. FileFactory.com

    If you plan to run it stock:

    RUU_Ace_Sense30_S_HTC_WWE_3.12.405.1_R_Radio_12.65.60.29_26.14.04.28_M_release_233505_signed.exe - download now for free. File sharing. Software file sharing. Free file hosting. File upload. FileFactory.com

    This probably won't work, but I do not see any harm in trying.
    scotty85 and artstyle like this.
  9. artstyle

    artstyle Member

    Thanks for that worked, but phone must be locked for another carrier any ideas how to get it on Telecom XT here in NZ, ended up using this RUU_HTC_WWE_1.32.405.6_Radio_12.28b.60.140e_26.03.02.26_M_release_15589
    scotty85 likes this.
  10. ral

    ral Well-Known Member

    scotty85 likes this.
  11. D-U-R-X

    D-U-R-X turbo drinker Moderator

    Your CID (Carrier ID) is 111111 - that is Super CID, which means that the phone would be able to be flashed with a non-branded ruu... not sure why you'd want to lock the phone to another carrier, when you can have an unbranded DHD that can be used on any network.
    scotty85 likes this.
  12. artstyle

    artstyle Member

    yes I get your point, happy to have A unbranded DHD. Didn't understand the Super CID.
    Much appreciated. Just when I put my SIM for Telecom NZ 3G network it wouldn't
    connect, went to 2 degrees put the SIM and it worked fine.
    scotty85 likes this.
  13. D-U-R-X

    D-U-R-X turbo drinker Moderator

    Sorry... I've reread my reply - wasn't meaning to come off negatively! :)

    It can be harder to find carrier branded ruu's (at least I've always found it), which is what I was referring to :)
    scotty85 likes this.
  14. artstyle

    artstyle Member

    didn't take as negative, just happy to get some advice and real happy about getting the DHD working. Anyway if I can find and RUU suitable for Telecom XT 3G will my phone then accept their service? Telecom NZ website phone check states " Your device supports the following frequencies:

    • GSM 850/900/1800/1900MHz
    • WCDMA 850/900/1900/2100MHz



    Telecom Network Compatibility
    This device should work on the XT Mobile Network.
    To confirm your device will work on the XT Mobile Network, please visit a Telecom store or dealer to try your device with a Telecom SIM.
    scotty85 likes this.
  15. artstyle

    artstyle Member

    Just been doing some more checking and my DHD is A9191 and there is a A9192
    that is suitable for Telecoms 3G network, so looks like I need the A9192 if I want full service on XT network.
    scotty85 likes this.
  16. D-U-R-X

    D-U-R-X turbo drinker Moderator

    I'm not sure about compatibility, sorry! The ruu wouldn't need to be branded though, for your phone to work on the network... it looks as though your phone was rooted... part of the process would have been sim unlocking the phone, so any sim would work in it.
    scotty85 likes this.
  17. D-U-R-X

    D-U-R-X turbo drinker Moderator

    The A9192 is the Inspire, which is the US version of the Desire HD... there may not be any problem using it on the network... give it a try!
    scotty85 likes this.
  18. scotty85

    scotty85 Guides Guide

    just to make sure im understanding correctly... your device gets voice and text service,and edge data,correct?

    as D-U-R-X said,sim unlock is a by-product of the most convetional means of rooting the dhd/inspire and your phone should work on any gsm network now,given the limitations of phyiscal radios present(the att inspire only accepts specific frequencies,unfortunately,unike an internationa desire hd).

    if your device was still locked to a carrier,when you powered it up with a sim ohter than that carriers sim,you would normally be prompted for an unlock code,wich would then allow voice and sms to work,and possibly some form of data depending on the device,the ruu,and the APNs present.

    so if your device boots up and has phone signal you can make calls and texts with,then its not locked down to anywhere. running the unbranded ruu should let your phone find an APN that works with the network youre using(when i boot my inspire on an unbranded ruu us t mobile edge data works fine). if your on a carrier ruu,youll likely need to manually program the APN settings(what i have to do if i boot my inspire on the stock att ruu).

    so i guess the big question is... if you are getting working voice and texts, is your device an att inspire? if so,thats likely the reason its not getting 2g or 3g data on an international carrier :(

    edit:
    i also took the liberty of editing out your serial number and imie above... those are numbers you dont really want someone abusing ;)
    artstyle and D-U-R-X like this.
  19. artstyle

    artstyle Member

    thanks for removing serial number, never thought about it being a risk.
    From what I have read, my a9191 won't be accepted on Telecoms 3G network
    I would need the A9192. So I have changed a 2 Degree as a carrier and the phones working fine. Did retry the Telecom SIM and it didn't find XT network. First time I tried the Telecom XT 3G sim It came up with limited service, but would not make calls
    and under available networks it showed up Vodaphone and NZ Comms. Went to 2 degrees tried their Sim and phone found their network and Vodaphone, 2 degress
    got a new customer. If I could get the DHD on Telecom 3G I would go back to them as a carrier, but everything I have read states I need the A9192 version not the A9191 that I have.
  20. scotty85

    scotty85 Guides Guide

    glad you have found some sort of solution. sounds like the the issue was with the carriers sim then,not the phone... a friend had a sim card that was locked to straight talk,so would only use their devices.

    if you wish to trade your desire hd for an inspire,i could be talked into that... att inspires are plentiful here in the states,so i could always get another if needed. an actuall DHD would be better for me,as it would actually get 3g on my t mobile prepay :cool:
    D-U-R-X likes this.
  21. aiamuzz

    aiamuzz Member

    Hi is the thread dead ... if anybody is watching ... my Desire HD too behaves exactly the same as Artstyle's OP ... except that 'adb devices' in hboot does not return Device ID ... however in fastboot, 'fastboot devices' returns the connected Device ID.

    even my device is 'SHIP S-OFF'


    Tried to
    1. RUU, ...
    2. flash ZIP's for recovery, ROM from SD card ... through *DIAG.zip and *IMG.zip's

    all return to the white screen and fades as artstyle's description ...

    3. tried flashing recovery manually thru 'fastboot flash recovery recovery.img' ... but same returns the following error ...

    sending 'recovery' (3554 KB)...
    OKAY [ 0.602s]
    writing 'recovery' ...
    FAILED (remote: not allowed)
    finished. total time: 0.609s

    Already tried on machines with sdk
    Win7 64 bit
    Ubuntu 64 bit
    WinXP 32 bit

    All OS's return the above error ...

    Really hope my DHD springs back to life ...

    Thanks for any or all help
    :)
  22. scotty85

    scotty85 Guides Guide

    you are not getting a response from adb devices becasue the phone is not booting far enuff into the OS,or it is booting into an OS where usb debug is not enabled. 'adb' comands are run in the booted OS,or withing a custom recovery.

    if fastboot devices returns a serial number withthe phone in fastboot,have you done fastboot getvar all ? if not,run that command and post its output.

    you are unable to fastboot flash recovery recoveryname.img becasue you do not have an eng,or htcdev unlocked,bootloader,so that is normal.

    you should be able to install recovery as a PD98IMG file in hboot,or run as an RUU from fastboot:
    fastboot erase cache
    fastboot oem rebootRUU
    fastboot flash zip zipfilename.zip
    fastboot reboot-bootloader
    fastboot reboot

    heres a link for ext 4 PD98IMG: PD98IMG_ace_recovery_ext_4.zip

    tho i dont know if that will do you much good at this point.

    your best bet is to run an RUU. what have you tried to run,what were the results? be as specific as possible,as you may just have not successfully applies an RUU at this point :)
  23. aiamuzz

    aiamuzz Member

    Thanks for looking into scotty85

    I will not try until advised,

    [HIGH]
    :~$ fastboot getvar all
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 0.85.0024
    (bootloader) version-baseband: 26.10.04.03_M
    (bootloader) version-cpld: None
    (bootloader) version-microp: 0438
    (bootloader) version-main: 2.47.502.7
    (bootloader) serialno: HT134T202882
    (bootloader) imei: 354455047307812
    (bootloader) product: ace
    (bootloader) platform: HBOOT-7230
    (bootloader) modelid: PD98*****
    (bootloader) cidnum: 11111111
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 4087mV
    (bootloader) partition-layout: Generic
    (bootloader) security: off
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: a3d4fa0f
    (bootloader) hbootpreupdate: 11
    (bootloader) gencheckpt: 0
    (bootloader) region-id: 0
    all: Done!
    finished. total time: 0.003s
    [/HIGH]

    Please instruct on how to proceed further ...

    The bootloader must be locked as i was still evaluating the stock ROM and i haven't attempted it yet.

    This device was shipped with GB, hence i have read that AAHK is not an option to unlock bootloader.
    Can i try to unlock through HTCDev, many have advised against it though, but for a divice shipped with GB i haven't come across a Hack Kit to unlock my bootloader ... unless you know of one.

    What is ENG-off, does my device qualify for this as it was shipped with GB ?

    sidenote : On my previous devices LG, and Motorola we would clear cache/data(factory reset) whenever a bootloop occured ... Is factory reset an option via HTC fastboot ?
    ;
    ;
    ;
    ;
    ;
    UPDATE
    ;
    ;
    ;
    ;
    ;
    :( bootloader unlocking through htcdev not possible

    [HIGH]
    :~$ fastboot oem get_identifier_token
    ...
    (bootloader) [ERR] Command error !!!
    OKAY [ 0.007s]
    finished. total time: 0.007s
    [/HIGH]
    ;
    waiting for advice !!!

    thanks.
  24. scotty85

    scotty85 Guides Guide

    you do not need the aahk,htcdev unlock,or any other exploits. you are allready s off and superCID,so you can run any ruu that you wish.

    your best bet is to run an ruu.

    what you are currently running is this one:
    Shipped ROMs

    run the .exe with the phone in fastboot mode. if the utility fails for some reason, you can extract rom.zip from the utility in the following manner:
    rom.zip can be renamed PD98IMG and flashed via hboot from the sd card,or as an RUU with the phone in fastboot/RUU mode as described above
  25. aiamuzz

    aiamuzz Member

    thanks for the quick reply scotty85 ...

    I have already tried RUU.exe in fastboot ... after confirming all the options the phone reboots and goes into the HTC white screen ... and the RUU.exe shows a 'waiting for bootloader' message ... this is where i am stuck!!!

    I have even tried the PD98IMG.zip (after extracting ROM.zip) on one of the rom.zip i tried flashing ... all the included components in the bootloader flashed with 'OK' status and when asked to press power ... phone went back to the white HTC screen after reboot ... stuck again !!!

    Same with the CWM recovery files flashed as PD98IMG.zip format ... it says in a fraction of a second as update successful but when power is pressed it goes to the HTC white screen ... a battery pull - Vol Dn + Power - recovery ... results in the HTC white screen ... stuck again.

    How is the procedure for RUU via 'fastboot' methos ?

    this one ?


    HTML:
    1. you should be able to install recovery as a PD98IMG file in hboot,or run as an RUU from
    2.  
    3. fastboot:
    4. fastboot erase cache
    5. fastboot oem rebootRUU
    6. fastboot flash zip zipfilename.zip
    7. fastboot reboot-bootloader
    8. fastboot reboot
    all these need to be executed via the terminal on a PC correct ?

    In 'fastboot flash zip zipfilename.zip' ...
    the zipfilename.zip is the ROM.zip or PD98IMG.zip or the recovery.zip ?

    and this zip should be on the SD card or on the PC folder from where i am executing the fastboot commands ?

    thanks.

Share This Page