1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

desire hd wifi problemSupport


  1. italia13

    italia13 New Member

    My htc desire
    has full wifi connection, i got on facebook, google, the market and its works fine
    after 5 minute "connection error has occured" pops up and i have to turn my wifi of and on, it will work for 5 minutes then do the same

    any1 have any ideas on what to do, it would help heaps

    Advertisement
    :
  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Has your handset just received an OTA update? Is your Android version currently 2.3.3?

    There's an issue with this version whereby if the WiFi Signal strength drops below -88dBm, it will cut off and switch to a 3G connection. A fix has been to turn 3G off whilst connected to WiFi. It's also been suggested that giving yourself a Static IP will also resolve the problem.
  3. italia13

    italia13 New Member

    thanks el presidente but how do i create a static ip adress for my phone
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    First up, connect to your desired network.

    Settings -> Wireless & Networks -> WiFi Settings -> Menu (the button at the bottom of the handset) -> Advanced Settings -> Tick the box which says "Use Static IP".

    You'll then need to enter the options specific to that network.

    The screen should look like this -

    [​IMG]

    If you're connected to a network, the IP address you're currently using will already be displayed (as it is in the top of the picture), enter that into the IP address pull down.

    Your gateway will be the internal IP address of your networks router. You can get this by accessing a PC, going to the start menu, typing CMD and pressing enter. In the DOS window which opens, type ipconfig and press enter. You'll see a load of info displayed, you're looking for something called Default Gateway, take a note of that then enter it into Gateway section on the phone.

    Netmask will always be 255.255.255.0

    I think you can leave DNS blank as DNS should be handled by the default gateway.

    The above may or may not fix the issue, but give it a shot and report back either way.
    gabbyevs and Inmatxu like this.
  5. F.K

    F.K New Member

    It certainly is a problem related to the ota update to 2,33 and the switching off 3G works for me. I haven't tried static ip though cuz I use different wifi networks in different locations but hope htc gives us a fix soon. Having a high end phone with something so stupid as an error is very very annoying.
  6. Inmatxu

    Inmatxu Member

  7. Inmatxu

    Inmatxu Member

    it does work for me, have been connected for more than 15 minutes and it did not dropped. certainly an improvement!
  8. Sombre

    Sombre Well-Known Member

    I tried static IP after upgrading from 2.3.3 Sense Stock to CM7 as CM7 has crap WiFi for some reason. Didn't help at all, thinking of restoring my Sense 2.3.3
  9. gabbyevs

    gabbyevs Well-Known Member

    an added thanks to el presidente your static ip settings worked i know how wifi back on my phone

    cheers
  10. picckko

    picckko New Member

    Have had a look at previous posts. 3G works fine, phone recognises my home wifi network but gets into a loop of finding network, obtaining IP address, disconnecting, connecting etc. In advanced settings the IP address is 'unavailable' so I can't make progress from El Presidente's post http://androidforums.com/desire-hd-...45055-desire-hd-wifi-problem.html#post2755542 which seems to fix most people's.

    Any ideas? My wifi network works fine for laptops, iPhones etc.

    Thanks

    Picckko
  11. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Are you running 2.3.3? Turn off 3G, then try the static IP trick.

    Let me know if that works.
  12. Greigory

    Greigory New Member

    I'm getting this aswell, originally stuck in a loop of scanning, connecting to (network name), Obtaining IP adress from (network name), disconnected......however now its just stuck in a loop of scanning connecting (without giving the name of what its trying to connect to) and disconnected, tried using static IP but no change, using most recent update which was apparently aimed at improving WiFi......was working fine before, just woke up one morning and nothing :/
  13. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Do you have anything like Juice Defender or Green Power installed?
  14. Rhind

    Rhind New Member

    I'm running 2.2 and have got exactly the same problem - stuck in a loop of scanning, connecting to (network name), Obtaining IP adress from (network name), disconnected...

    Meanwhile my iPad and Blackberry connect effortlessly

    Any advice gratefully received

    David Rhind
  15. Goreygirl

    Goreygirl Well-Known Member

    I had that looping issue on Froyo... I found I had to "forget" the connections and then set them up all over again .. this seemed to sort it out for me.
  16. picckko

    picckko New Member

    Nope, none of these has helped. in advanced settings i have static IP ticked but above that on the screen IP address is shown as Unavailable. It's like this whether I have my 3G on or not. I know my wifi is working as I'm using it for this laptop! In the Ip address in IP settings there is an IP address shown, so v confusing. Any help would be great.

    Picckko
  17. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Is your router picking it up at all? Can you see it as connected/or connected in the past via the admin panel?
  18. Chensta10

    Chensta10 Member

    I've been wondering what was up with my phone for a couple of weeks now and yesterday, I finally got annoyed enough to realised it was an actual problem and searched on here. Glad I did.
    Thanks!:D
  19. jonoferguson

    jonoferguson New Member

    i have a slightly different problem. I can connect to my wifi, it says i'm connected and it says the signal strength is excellent, but the little wifi symbol at the top of the screen is dark (not lit up, or showing 0 bars). So the phone thinks it's working so when i use internet it just tries to load forever instead of saying--no data connection- or something like that.

    The really weird part is it worked fine for a month or so, then all of a sudden it connects to the router but is getting no internet. My laptop and ps3 work fine off the wifi by the way.

    Any help would be greatly appreciated!! Thanks
  20. Driftfog

    Driftfog Well-Known Member

    I have had the above issue on and off over the last few weeks, ever since getting the Virgin Super Hub (loosely termed name lol) I have to soft re set the phone to get a decent signal.
    Though my sons pc, xbox and other phones and tablets in the house hold the signal :confused:
Loading...

Share This Page