Desire not reconnecting to network properly


Last Updated:

  1. GarBot

    GarBot New Member This Topic's Starter

    Joined:
    Jul 19, 2010
    Messages:
    2
    Likes Received:
    0
    Hi all,

    this may have been covered elsewhere on the forum, but I couldn't find it.

    I have a Desire which is doing something a bit odd. I'm in Oz, using it on the Telstra network.

    When at home, it connects to the wireless and uses that fine for the Internet. When away from home it usually connects to the network carrier (HSDPA) fine for internet.

    However, sometimes I'll be out and try to use the Internet, only for the phone to report it has no connection. I'll be getting a full strength signal, can use the phone fine, but data services don't have a connection. The HSDPA icon doesn't appear, and instead the wireless icon appears, even when there is no wireless nearby.

    When this happens, it stays that way until I completely reboot the phone - if I don't reboot it can last days. It reconnects to the wireless network fine, but won't connect to HSDPA for data services. Reboot the phone, and it works fine. Switching to and from airplane mode or disconnecting from the network has no effect, it has to be a reboot, which takes ages.

    This doesn't happen all the time, but has happened three or four times in the past month. It's almost as if the phone gets locked up trying to switch from wireless to HSDPA for data, and then just sits in that mode.

    Is anyone else experiencing a similar problem? I love the phone, this is the only real glitch I'm having with it so far. Any advice..?
     

    Advertisement

Share This Page

Loading...