Desire ProblemSupport

Last Updated:

  1. grjamal

    grjamal Member

    I get a HTC Desire Cell from my friend. When I ON The Mobile it goes up to O2 screen and didn't go to the main Screen. It reboot and vibrate some time it go to main screen but again reboot. 2ndly I dont know which software/image is install in it. I press Vol Down key and power so it went to hboot etc mode.
    any body can help me in this regard.

  2. Tyseyh

    Tyseyh Well-Known Member

    I assume it's a cdma device since you refer to your phone as a cell, does it have a sim card?
  3. Hadron

    Hadron Well-Known Member Contributor

    Can you tell us what you have done to the phone? Is this the same phone you were trying to root a month ago?

    What does it say in the hboot screen?
  4. grjamal

    grjamal Member

    The phone is GSM Phone I didn't try any thing on it and I want to alive it.
  5. Hadron

    Hadron Well-Known Member Contributor

    So there were no software updates or anything before this happened? Had it been misbehaving in any way prior to this (rebooting or freezing for example)?

    Try pulling the battery out and leaving it out for a few minutes, then see what happens.

    Are there any data on it that you are keen to rescue? If it won't boot when cool and is unrooted then we may have no options except factory reset (which wipes everything) or, if that fails, reflashing with an RUU (which would also wipe it), either the latest O2 one we can find or the gingerbread upgrade.

    Of course if it's a hardware problem neither of those will help. That's why I was asking about the device's history and whether there have been other problems, to try to guess at the cause and hence what might be worth trying.
  6. grjamal

    grjamal Member

    this is the pictures of the screen


    when i press vol down and power button I also try RUU but when reboot it wont start.
  7. Hadron

    Hadron Well-Known Member Contributor

    Are you saying you have tried an RUU (download it to a pc, selected fastboot from the menu you showed above, connected phone to pc via usb & ran the ruu .exe)? If so, which one?

    That phone has an android 2.1 radio, so seriously old software!
  8. grjamal

    grjamal Member

    I Start Update through RUU It give error [152] IMAGE UPDATE ERROR


    I am trying to update it to 2.33
  9. Hadron

    Hadron Well-Known Member Contributor

    Which image did it fail on? The RUU will flash a number of images (boot, hboot, recovery, radio, system). Failure on some of these is worse than others.

    If you got the upgrade from did you check the md5 code (don't know whether other sources provide this)? This is to check you have a good download. There's a thread on this linked in the All Things Root Guide sticky post.

    In case I'm not around when you read this, I'll warn you that a problem flashing the radio img is the worst. If the RUU got as far as updating your hboot you may have no options but to try again with the same RUU (you won't be able to run an older one if you have hboot 1.02).
  10. grjamal

    grjamal Member

    I can't update and the problem still with the phone. I mean the last image showing
  11. Hadron

    Hadron Well-Known Member Contributor

    See my previous question: where did the error occur?
  12. grjamal

    grjamal Member

    I didn't get u brother
  13. Hadron

    Hadron Well-Known Member Contributor

    At what point in the RUU process? Which image flash was it that failed?

    TBH the main reason for asking is to determine whether it's worth looking for a solution. If you say that it failed during the radio.img flash then I'm afraid there's nothing anyone but HTC can do.
  14. grjamal

    grjamal Member

    No... I was updating 2.33 gingerbread and it goes beyond 80% but failed.
  15. Hadron

    Hadron Well-Known Member Contributor

    Did it give any indication of what part of the phone it was updating when it failed? Either on screen or on computer. Usually it tells you that.

    Have you tried anything else that you've not mentioned? That was the key to another problem recently, so I have to check.

    Does it do anything different if you boot while pressing volume down or back button? And does the charge light come on when plugged in?

    The simplest thing is to try the RUU again - I heard one case where a different usb port on the computer helped (or might have been coincidence). There's also a thread at XDA where someone recovered a phone from this condition, but it might depend on precisely what state the phone was in and what software was on it whether it works (doesn't work for everyone).

    I'm afraid that I have very little time online at the moment, so can only call in occasionally.
  16. shauny13

    shauny13 Well-Known Member

    does the error say something about a radio like this?

    Radio_v2 fail-pu
  17. grjamal

    grjamal Member

    No it doesnt show any error but the screen stuck in the error showing in image.
    Anyone can help me as the cell is still on the condition which i upload the image.
  18. Hadron

    Hadron Well-Known Member Contributor

    But no error message on the pc running the RUU?

    Once it's got as far as replacing hboot there aren't many options I can think of - doubt you'll be able to use a different ruu if it's done that much. Maybe redownload the ruu and check md5 of the package before use. Make sure the phone is cool before starting. Will post back if something occurs to me.

Share This Page