Desire S stuck on bootloaderSupport


Last Updated: 2013-01-20 14:58:19
  1. madmarf

    madmarf Member

    hey all. im new to the forum but i do look through stuff here all the time.

    im seeing if anyone can help me. i bought a HTC DESIRE S from a friend who i can no longer get hold of. basicly it was stuck on the HTC screen and it wouldnt recover in the bootloader. im now trying to flash it however in the .exe RUU i go through it all and it says "rebooting to bootloader"..........etc but just stays there. the dots do go up and it looks like its progressing with the dots moving but after 2 hours it still says the same?

    also my "FASTBOOT USB" on the device is red, does that mean theres an issue?

    thanks all

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    i madmarf,i moved your thread to the desire s forum,where more folks familiar with the particular device will see it.

    we can start with some basic info:

    is this device rooted?

    can you tell us the info on the hboot screen?

    lastly,you can provide the output from this:
    once we have verified the ruu youre using is correct for your phone,you can extract "rom.zip" from the utility,and flash it from your sd card in hboot.
    to answer your question,the fastboot usb just means you are in "fastboot mode" on the phone,and is completely normal with it plugged in :)
  3. madmarf

    madmarf Member

    Hi Scotty, thanks for helping. the old owner told me it wasnt rooted and was just on plain orange.

    HBOOT says,

    SAGA PVT SHIP S-ON RL
    HBOOT-0.98.0000
    RADIO-38.03.02.11_M
    eMMC-BOOT
    Mar 10 2011, 14:58:38


    C:\>fastboot devices
    SH14PTJ06195 fastboot

    C:\>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 0.98.0000
    INFOversion-baseband: 38.03.02.11_M
    INFOversion-cpld: None
    INFOversion-microp: None
    INFOversion-main: 1.28.401.1
    INFOserialno: SH14PTJ06195
    INFOimei: 355067046531703
    INFOproduct: saga
    INFOplatform: HBOOT-7230
    INFOmodelid: PG8810000
    INFOcidnum: HTC__001
    INFObattery-status: good
    INFObattery-voltage: 4191mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    INFOcommitno-bootloader: 361a7ba6
    INFOhbootpreupdate: 12
    INFOgencheckpt: 0
    all: Done!
    finished. total time: 0.025s

    i think thats all you need?

    thanks, jez
    scotty85 likes this.
  4. madmarf

    madmarf Member


    sorry forgot to add that he took the SD card with him which is where we may have a problem. i have another here but obviously its empty.
    scotty85 likes this.
  5. scotty85

    scotty85 Guides Guide

    What is the name,or a link to,the ruu you are using?

    The sd card you have should work fine. Check its format,and make sure its FAT32. If not,you'll need reformat it.
  6. madmarf

    madmarf Member

    yes its fat32.

    RUU_Pyramid_HTC_Europe_1.35.401.1_Radio_10.43a.9007.00U_10.51.9007.27_M3_release_198179_signed
  7. scotty85

    scotty85 Guides Guide

    ahhh. this would explain it. :)

    the ruu youre using is for not for your phone- pyramid= htc sensation.

    try this ruu:
    Shipped ROMs

    make sure that you are starting the .exe file onthe PC with the pho in fastboot usb mode. if you cannot get the .exe to work,then extract rom.zip and place it on your sd card as described above,and rename it to "PG88IMG"

    put the sd card into the phone,boot to hboot,and it should find,unpack,and check the file,and then ask you to update. allow the update. make sure the phone is charged fully before starting. :)
  8. madmarf

    madmarf Member

    ah, ill bang myself on the head for that, my mistake.

    ok so still hung on pc way and on sd card its hanging on (1) BOOTLOADER, just says UPDATING and doing nothing (not updating). do you think i have something wrong with the bootloader?
    scotty85 likes this.
  9. scotty85

    scotty85 Guides Guide

    no... i do not think so. the .exe files can be finicky. one last thing you can try:

    with the phone in fastboot,in your cmd window,ether these commands:
    fastboot devices

    fastboot erase cache

    fastboot oemRUU

    the last comand will boot your phone into "ruu mode" wich is a black screen with a silver htc in the middle. start the ruu with the phone in this mode.

    if it fails,you should be able to get back to the regular bootloader by entering this in cmd:

    fastboot reboot-bootloader

    check these things to make sure youve got no connection issues:
  10. madmarf

    madmarf Member

    ok so im becoming increasingly annoyed now :mad:

    i tried all of that and
    1. it hangs on erasing cache
    2. it hangs on rebooting into bootloader

    i also change the usb cable and deleted-reinstalled the drivers. its coms and picks up the serial number in fastboot its just anything i try and do with bootloader it hangs. ive also tried the install SD again and it still hangs on the first stage?

    i appreciate your time with this again
  11. scotty85

    scotty85 Guides Guide

    how long did you give it on the sd card install? it will take quite some time. maybe try that again,and let it go a lil longer. if still no luck,might try to reformat the sd,or try a different one alltogether.
  12. madmarf

    madmarf Member

    i gave it 15min on first stage. ill give it an hour and report back, surely after an hour it should have gone past the first stage
  13. madmarf

    madmarf Member

    well.. i gave it a good few hours and the bootloader still says -updating

    not sure where to go from there. do you think maybe attempt to update / downgrade the bootloader will work?
  14. scotty85

    scotty85 Guides Guide

    you can try updating,you can use this ruu:
    Shipped ROMs

    have you tried different sd cards?
  15. madmarf

    madmarf Member


    hi scotty,

    yes tried 3 SD cards, all ok cards. i tried the update you sent aswell but again the bootloader process is just freezing.

    ive read on another forum that the eMMc chip may be nakard, do you think thats the prob here?
  16. scotty85

    scotty85 Guides Guide

    unfortunately,it very well could be. anytime any partition hangs when trying to update,its usually a bad sign.especially when its the bootloader or radio.

    did you extract the second ruu,and try it on the sd card as well?

    you can try this one,also,wich is a further upgrade,but i fear it will have the same results: Shipped ROMs

    edit:
    just to make sure were on the same page,when you extract rom.zip(as described in post 2),and place it on the sd,and boot to hboot,it checks the file,asks you to update,and when you say yes,it starts to update bootloader,and then goes no further?

    if this is not whats happening,then hold of on that 3rd update,and try and describe in as much detail as you can whats happening :)
  17. madmarf

    madmarf Member

    yes tried both on sd also. i think its probably the eMMc as no matter what i try its having the same results. ive just ordered a replacement chip from china so will wait for that to come, rework it and then go from there and see what happens. ill be sure to post you my result for anyones future ref:

    thanks again for your help!
  18. scotty85

    scotty85 Guides Guide

    you are quite welcome on the help :) sorry we didnt get it figured out... defintely sounds like some sort of hard ware failure. if you had a custom recovery installed,there are a couple adb commands to check the emmc,but without being able to replace the bootloader,im afraid we are stucked,until repairs have been made. let us know how it goes! :)

Share This Page