Desire stuck in bootloader loop after hboot downgrade - HELP!!Support


  1. andyrobb18

    andyrobb18 Member

    I have serious problems with my phone that I could really use some help with as at the moment I'm completely screwed - I've already spent hours reading forums but have yet to find advice that will help. Here's whats happened:

    I have an A8181 HTC Desire, and I took an OTA update yesterday that bricked my wifi. At this point I thought it would be easiest to root my phone, and after checking that my hboot version was 0.93, I read advice that said to downgrade this to 0.83, which I duly did.

    Now, my phone is stuck in a bootloader loop - I get the 3 androids on skatebooards with FASTBOOT in red, and I can choose from:

    BOOTLOADER
    REBOOT
    REBOOT BOOTLOADER
    POWER DOWN

    If I select bootloader I then get:

    FASTBOOT
    RECOVERY
    CLEAR STORAGE
    SIMLOCK

    I can access recovery and apply update.zip roms successfully (I've only tried official HTC 2.2 roms as the phone isnt rooted), but after doing so it just goes back to the bootloader loop.

    If I select FASTBOOT then I'm just back at the first screen.

    I've tried clearing cache and factory reset aswell, but I still can't get past this 2 screen loop.

    It's like the bootloader just can't load whatever rom is installed.

    Because the phone isn't booting up, I can't use adb or any other pc tools as the device is not detected on my pc - although it does show up in device manager on windows.

    I'm close to sending this back to try a warrantly claim, although I'm worried that by trying to fix this I may have invalidated this.

    I'd really appreciate any help or advice as to how I can get out of this and get my stock 2.2 back.

    Cheers

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    Breaking my post into 3 sections.

    Section 1 - me telling you off

    You must be careful you read up to date information. Check the date of the article. If there is no date, join a forum like this and verify what you are doing BEFORE doing it.

    Section 2 - information for me and you

    There is no need to downgrade hboot to root. This is OLD information. Very old.

    Your ota failed to install properly so there was always going to be a chance of corrective action.

    What method did you use to downgrade?

    What are the update.zip you're trying to apply?

    What was the build version of the ota you were applying? What carrier? Branded phone or not?

    Section 3 - suggested corrective action

    You're going to have to use an RUU to return to stock. I will give you instruction later when all section 2 questions are answered. Please do not attempt this on your own as I have asked these questions for a reason.

    Apologies if this post seems blunt or rude but I have my reasons and they are in your best interest ;)

    Of course I can't guarantee my following advice will work either
  3. andyrobb18

    andyrobb18 Member

    1. No problem...I can see that I've made a big stuff up here, so your help is much appreciated.

    2. The update.zip I'm using is: OTA_Bravo_Froyo_HTC_WWE_2.29.405.2-2.10.405.2_R_P_release8gn61bgo3rswcw24.zip
    The phone is unbranded and unrooted - it's a UK phone model A8181.
    Here's the instructions I've followed.
    Droid Den - Phone Guide: How To Root The HTC Desire HBOOT 0.83 - Droid Den

    If you need any more info let me know.

    Thanks again

    Cheers
    Andy
  4. SUroot

    SUroot Well-Known Member Developer

    Hi Andy,

    That information is great and its the best that I could hope for.

    You need to run a full RUU from your PC (Assume you have windows?) The RUU is a rom upgrade utility. Its an .exe that HTC tech's use to reinstall the phone. It will reinstall Hboot, recovery, fastboot, radio and the ROM itself.

    You can use these to upgrade too. Usually you do this in Android, but you cant do that.

    You need to download this first - which is the 2.29.405.5 RUU

    This is from my personal drop box and I have used it myself so I can confirm it works

    http://db.tt/9PzVqTE

    You need to boot the desire into Fastboot mode. From Off, hold BACK and press POWER. When the fastboot screen is reached, connect the USB cable and it should then say on the screen "FASTBOOT USB" to confirm it is connected.

    Run the .exe and go through the steps. As it is designed to run whilst android is running, some of the preperation steps mentioned in the RUU as it runs will not be relevant so don't worry about them.

    be careful the phone doesn't lose power or the USB connection is lost during this process.

    Most of what is flashed using this is fine if it goes wrong, but if the radio goes wrong, it could be bad. Not sure if you already have an issue with the radio or not, but if you get this, it will be a return.

    Hope this helps.

    If you get any errors, please post here in as much detail as you can.


    Good luck
  5. andyrobb18

    andyrobb18 Member

    Thanks for this - fingers crossed it'll do the trick.

    Can I check to be sure I don't stuff this up - what device drivers do I need installed on my Win7 pc for this to work correctly?
  6. SUroot

    SUroot Well-Known Member Developer

    As long as HTC sync is installed, all the drivers you need should be there.
  7. andyrobb18

    andyrobb18 Member

    No joy I'm afraid :(

    Here's what happens when I try this...

    I've installed HTC sync and rebooted the pc to be sure the drivers register.

    I've then started the phone and gone to fastboot, and when I connect to the pc this changes to fastboot usb - so far so good.

    However, when I run the RUU I get a 170 USB connection error, RUU cannot detect your android phone.

    When I look in device manager, I can see the phone there - its listed as ADB Interface->HTC Bootloader. When I disconnect the phone the device disappears from the list.

    Is there anything else I can do, or am I stuffed and looking at a return? Seem like it's so close to a fix, just need the device to be recognised.

    Thanks
    Andy
  8. SUroot

    SUroot Well-Known Member Developer

    Hmm not sure what should show in device manager under fastboot, but what you mentioned above would show in hboot.

    Try connecting in fastboot again, and delete that device from device manager (assume you added these drivers when rooting with unrevoked?)


    If still no joy, try reinstalling those drivers as per these instructions again:

    public:windows_hboot_driver_install [RootWiki]

    Failing that, have you got a card reader? If so, you can drop an RUU's pb99img file onto the root of the sd card as Hboot looks for this file when it loads. This then performs the same action without the need for USB connectivity.

    EDIT here it is: http://db.tt/MyTqmR2 Download it and rename is so it is just "pb99img.zip" so delete everything between pb99img and .zip from the filename.



    Then, if that fails too, yeah return it.
  9. andyrobb18

    andyrobb18 Member

    Ok, not fixed yet, but finally some progress :)

    Deleting the drivers and reinstalling these as per instruction got the device showing up as ADB Interface->My HTC, and the RUU detected the device.

    I thought I was home & dry as the update process started, but unfortunately I get a 131 Customer ID error, please use another RUU.

    I'm guessing the RUU isn't valid for this phone, but hopefully now I can see the device there should be some way of pushing through an update.

    Any advice on how I can get this RUU to work, or what would be a suitable alternative?

    Just to clarify, I'm based in Sydney, but ordered this phone from Hong Kong, but I'm assured its a european sourced htc desire, and its definitely unbranded.

    Thanks
    Andy
  10. SUroot

    SUroot Well-Known Member Developer

    Right OK.

    Sounds like your phone was originally branded to a network. Do you know which? for some reason I got it in my head that it was unbranded?

    We can either:

    1) Locate an original RUU for your device (some carrier RUU's are not available though)

    2) Create a goldcard which will bypass the customer ID. But you will have a debranded device which is fine, but not for warranty purposes neccessarily...

    Goldcard (you will need a card reader and this will need to be a clean SD card):

    Here is the GoldCard Tool

    To use:


    1. Format your SD card to FAT32 by going Settings > SD Card & Phone Storage > Unmount SD Card then Format SD Card
    2. Launch the goldcard tool as admin by Right click on App > Run as Admin
    3. Put your SD card in the card reader.
    4. Click get CID (Try clicking MMC0 if MMC1 fails)
    5. Click the link to open the goldcard generator, copy the CID from the tool into it. You will get an email.
    6. Click 'Refresh' in the app and select your micro SD card.
    7. Click 'Load goldcard.img' and select the file you received by email.
    8. Click 'Patch MMC'
    9. You now have a goldcard!
  11. andyrobb18

    andyrobb18 Member

    I thought my phone was unbranded - I got it brand new and the there's no branding on the hanset or the packaging it came in...although of course I can't be 100% sure of the phones origins, although I can try and check with the supplier.

    I've got a goldcard, so can I just confirm next steps - I assume I just put the pb99img.zip files onto the sd card, and then boot up the device...anything else I need to do?
  12. andyrobb18

    andyrobb18 Member

    for some reason the link to the goldcard tool is showing a 404 error...I'd like to create a clean one to be sure...can you check the link?

    Thanks
  13. SUroot

    SUroot Well-Known Member Developer

  14. andyrobb18

    andyrobb18 Member

    the phone doesnt seem to be looking for anything when i start hboot :confused:

    but, I'll give the goldcard a try and see what happens
  15. SUroot

    SUroot Well-Known Member Developer

    maybe it only happens when you press volume down in hboot to select recovery then? It says something in the main body about looking for pb99img.zip, not found blah blah.
  16. andyrobb18

    andyrobb18 Member

    I'm having trouble with the goldcard tool - it won't read the cid from a couple of different card I've tried, either using a usb card reader, or my laptops buil in card reader. Both mmc0 & 1 fail with the message:

    Executing adb shell cat /sys/class/mmc_host/mmc1/mmc1:*/cid
    Reading adb output
    ------------------------
    * daemon not running. starting it now *
    * daemon started successfully *
    ------------------------
    Could not locate CID in output
    Executing adb shell cat /sys/class/mmc_host/mmc0/mmc0:*/cid
    Reading adb output
    ------------------------
    * daemon not running. starting it now *
    * daemon started successfully *
    ------------------------
    Could not locate CID in output


    I'm guessing adb can't read the card in its location, even though the card displays in the HTC MMC drop-down.

    Easiest option is probably for me to drop the card into my wifes desire (luckily she has the same phone) when I get home from work tonight, and get the cid using the app from the android market. I'll then finish up creating a new gold card and try again.

    Fyi the device definitely doesn't look for that zip - I've seen it do it in the past when I've pressed vol- to go to recovery so I do know what you mean though. Hopefully once I've got a valid goldcard in there it will do this.

    One question - if I have a goldcard in the device, will the RUU work or will it still fail on customer id?

    I'll post an update once I can get my hands on my wifes phone :rolleyes:

    Thanks
    Andy
  17. SUroot

    SUroot Well-Known Member Developer

    The gold card spoofs the customer id so RUU should work
  18. andyrobb18

    andyrobb18 Member

    ok, sounds like the way forward then...today would happen to be my wedding anniversary, so will have to tread carefully with the missus when i get home to find some time tonight to try this!! :p
  19. SUroot

    SUroot Well-Known Member Developer

    Bit of advice. Wait till tomorrow ;)
  20. andyrobb18

    andyrobb18 Member

    Took a night off from the phone and went for champagne & flowers instead...good decision ;)

    Anyway, went down the goldcard route, and after trying 3 different sd cards I finally got the phone to search for and pick up the PM99IMG file - this update applied smoothly first time and the phone is now back in action :D

    Huge thanks for the help with this...I thought it was toasted for a while then!

    Cheers
    Andy
    SUroot likes this.
  21. SUroot

    SUroot Well-Known Member Developer

    Excellent. Glad you had a good night, it was definitely the way to go :)

Share This Page