Desperate! Can not flash ROM - E:Can't mount /scard/


Last Updated:

  1. CJ0206

    CJ0206 Active Member

    As you can see from the title I am without a working phone...

    I am new to rooting and have no idea what has gone wrong, I used ClockworkMod Recovery v5.0.2.0 and tried to flash ICS ROM (I can't remember it's full name...) and it went wrong...

    I backed up my ROM (I think) and it just stopped. I can boot into the recovery but every time I try and "install zip from sdcard" I get the error "E:Can't mount /sdcard/"

    My phone is an unbranded HTC Desire on the 3 network (if that makes a difference), PVT4, S-Off, HBOOT 6.93.1002, Radio 5.17.05.23

    I rooted using Revolutionary and the instructions HERE

    I have no idea what I am doing so if ANYONE can provide the most basic description of what to do please help as I am desperate and need a phone!

    Advertisement
  2. CJ0206

    CJ0206 Active Member

    I've tried 3 SD cards so I know I don't just have a bad card...

    If anyone knows how to just reset my phone (to an unrooted state even) I would be more than grateful. As stated before all I can do is boot up into HBOOT and ClockworkMod Recovery at the moment.
  3. shauny13

    shauny13 Well-Known Member

    You cannot use clockwork mod recovery with pvt4 if your erase size is 40000. Have you checked this first? See faq's.
    Hadron and CJ0206 like this.
  4. CJ0206

    CJ0206 Active Member

    As the phone will not load past HBOOT or ClockworkMod unfortunately I can not check.
  5. Hadron

    Hadron Well-Known Member Contributor

    Being unable to mount the card sounds like a USB brick (though that normally doesn't stop you booting into android). There is a guide to fixing these in the All Things Root Guide sticky post in this thread. Being S-Off you may be able to do it just with the 2 fastboot commands at the start of that guide. See the "adb and fastboot faq", linked from the same sticky post, for how to set up fastboot.

    If you can get the card working again, see whether it boots. If not you'll need to flash a new ROM. I'd recommend a rooted stock ROM to start, just to keep things simple: one of Teppic74's ROMs from ROM List -XDA would be my suggestion. You can use something fancier later, but for many of those you'd need to do a bit more setting up first.

    If that still doesn't work you can try flashing stock firmware, as described at the end of this post.

    Assuming that does fix it, TBH I've recommend using a different recovery - the later CWMs are less stable on the Desire than the ones Koush built (last one of those being 2.5.0.7). Most of the long-timers here are using 4Ext Touch now - there's a link in my signature. But get the phone running Android again first.

    I don't know what you did wrong, but in any event do not use ROM Manager - that has usb bricked a lot of Desires.

    In answer to your specific question:

    Unrooting is easy: you download an RUU from shipped-ROMs to your PC, boot into fastboot mode (select from HBOOT menu), connect to PC and run the RUU .exe. Make sure you have a decent charge in the battery first, otherwise that's it. I'd suggest using an unbranded WWE Froyo RUU or the official 2.3 upgrade. These things will replace your phone's software completely, except that the HBOOT that revolutionary installed is a special one which will not be replaced by the RUU (there is a way if you ever need to though).

    So having the revolutionary hboot means you will still be S-Off afterwards, so you can easily re-root after running an RUU: fastboot flash a custom recovery, then flash the root patch or a rooted ROM.
    CJ0206 likes this.
  6. CJ0206

    CJ0206 Active Member

    Thanks Hadron, I'll give it a go and let you know how it works out!
  7. Hadron

    Hadron Well-Known Member Contributor

    Ah, Shauny makes a good point (though I don't know whether these CWM 5 versions handle this?). That could indeed cause problems.

    OK, so what you could do is download 4Ext Touch: look for the phrase "direct download (Desire GSM) in the first post of that thread. Download it, unzip it, then "fastboot flash recovery recovery.img" (see adb and fastboot faq again). If you want to play safe, check the md5 code of the recovery.img matches the one supplied (there's a post on this in the forum sticky). That will replace your CWM with 4Ext Touch, which works with erase size 20,000 or 40,000.
    CJ0206 likes this.
  8. CJ0206

    CJ0206 Active Member

    Okay, phones on charge at the moment as it's less than 30% battery. I've got everything ready to try. Thanks a lot for your help so far!
  9. CJ0206

    CJ0206 Active Member

    I have to say you are all amazing!

    I used the two fastboot codes you suggested through my command line then installed the 4Ext Touch (much better interface than CWM), I then used that to install CyanogenMod!!

    Pretty simple considering how stressed I got, my phone's back I just need to put all my data back.

    Up and running again!!
    Hadron and shauny13 like this.
  10. Hadron

    Hadron Well-Known Member Contributor

    That's excellent news :)

    The truth is that almost all software problems on these things are fixable (the exceptions are corrupt radio firmware or hboot, so take care when flashing those). Do have a look at the collection of guides and other information in the All Things Root Guide sticky post.
  11. CJ0206

    CJ0206 Active Member

    To be honest I think I won't play much after that panic :) But I may have a go at some of the suggestions from the All About Android team
  12. SUroot

    SUroot Well-Known Member Developer

    Its CWM just being rubbish on the desire. 2.5.0.7 is the version to use if you must use CWM, otherwise 4EXT.
    CJ0206 likes this.
  13. desarenezitic

    desarenezitic Well-Known Member

    Sorry to hijack the thread but all the talk of 4Ext recovery being better would it be wise to change from CWM which works fine for me so far?
  14. Hadron

    Hadron Well-Known Member Contributor

    If it's working fine there's no need to change.

    But if you are S-Off then it's easy to give it a spin. It can also restore CWM nandroids, and it's very quick to change back if you prefer (download CWM from the toolbox thread - linked in the forum sticky post - and fastboot flash it).

    If you are S-On then it's not really an option, but no worries as CWM is fine.
  15. desarenezitic

    desarenezitic Well-Known Member

    Ah OK cheers, I'm not S-OFF anyway so I'll stick with CWM.
  16. PaulGT

    PaulGT New Member

    I have a similar problem with my LG Optimus Black P970. I was constantly changing the ROM. Now if I try to "install zip from sdcard" I get the error "E:Can't mount /sdcard/". Please help me! Now I want to install CM 10 on my LG. Can you help me with my problem and maybe tell me the best way to get CM10 on my phone?

    Sorry for my english (I am from Romania).
  17. Hadron

    Hadron Well-Known Member Contributor

    Does your sd card work normally, ie is the problem with recovery only or also when running android?

Share This Page