[DEV] WIP CM9 (Camera) [updated 2/23/2013]

Last Updated:

  1. elol

    elol Well-Known Member

    uhhhh g60madman,gud to see you rom has already..i will check for this rom..heee

  2. g60madman

    g60madman Well-Known Member Developer

    Elol it should have vast improvements from the other ROM you ported to the x6 rock it :)
  3. elol

    elol Well-Known Member

    hye g60madman are you already trying port hal camera cm7 to hal camera cm9?
  4. elol

    elol Well-Known Member

    will port it to ideos x6..thanks master g60madman mtdev
  5. g60madman

    g60madman Well-Known Member Developer

    Still working on it, I have not spent much time on it as I have rewrote the device files for cm9

    You bet :) its my pleasure :)
  6. christiansoto

    christiansoto Well-Known Member

    where are the gaapps
  7. g60madman

    g60madman Well-Known Member Developer

    You can snag them from the mtdev-cm9 ROM on the main post
    christiansoto likes this.
  8. Rcarnes91

    Rcarnes91 Well-Known Member

    Awesome can't wait to try this out
  9. tmicrd68

    tmicrd68 Well-Known Member

    Flashed ROM & went to titanium to reinstall app backups & found that root access was gone.Tried to re-root via terminal emulator without success.
    Still, nice & snappy ROM otherwise g60! I'll poke around with it for a while & see if I missed something.
  10. elol

    elol Well-Known Member

  11. g60madman

    g60madman Well-Known Member Developer

    As stated in the first post you will need to install superuser from the market.
  12. rdoac

    rdoac Well-Known Member

    Installed it and ran it last night, every seemed to work as well as the other cm9 or better (wifi?), but superuser (from market) was a right pain.

    When restoring My Backup Pro files it kept asking for Superuser permission and I would have to click allow continiously (tried the remember both ways to no avail). I tried to change the superuser config to allow all the time, then it decided that it had had it's permission denied. I suppose I should have tried denying superuser permission - maybe that would have worked?

    My Backup Pro seemed unable to restore apps properly and wanted to reinstall them as though I was trying to install an apk from an sd card, this then overwrote all the app settings, which MBP installs before the apk?

    Titanium backup just went into a permission loop for superuser so I gave up on it. Go Backup seemed to work but has a 200mb limit. I ended up using My Backup for the apps (with thousands of clicks) and then restored apps with settings I needed using Go Backup.. It was a pain.

    I tried a few things I found on the internet to fix superuser but it didn't. In the end I went back to cm7 and I probably need the camera for things like check deposits and qr reading.

    I have made a backup of it with clockworkmod so can go back quickly.

    I do like the feel of the rom better than cm7.

    All in all, looks good, but I think superuser should probably be tied in with the rom to fix the issue I had. Maybe it was an incompatible version? (latest from play store).
  13. g60madman

    g60madman Well-Known Member Developer

    Yeah superuser is really a pain here is the info I have in the first post to stop all the yapping from the app

    Install is the same as any other ROM. You will need to download SuperUser from the market as it's not included with the ROM. Once installed go to Settings < Security < Automatic Responses < Choose Allow

    I will see if it makes a difference if I include it in the ROM on the next build.
  14. elol

    elol Well-Known Member

    here the update to fix super user not will continues when applying and you will get torch working when flash this patch..:eek::eek:

    Attached Files:

    skearton, Izzard and calitrippin like this.
  15. FinalFinish

    FinalFinish New Member

    Long time lurker here, thought I would actually contribute the little that I can.

    10/22 Rom.
    3G: (1-10 scale 10 being perfect) 7. Had issues with signal completely being lost about every hour or two. Switching into airplane mode and back fixed every time. Could be a bad flash but I don't remember getting this with cm7 or the other cm9.
    GPS Locks: (1-10 scale 10 being perfect) 9 Took about a minute but I actually got a lock inside my house for once. Haven't tested on the road yet.
    Wifi: (1-10 scale 10 being perfect) 10. This is the best I've seen wifi on the triumph.
    MMS: (1-10 scale 10 being perfect) -
    SMS: (1-10 scale 10 being perfect) Works as intended and splits long messages unlike the other cm9 build.
    Speed: (1-10 scale 10 being perfect) 8 Browsing has lagged at times but I've been trying chrome. Rom itself is nice. App drawer jumps from time to time but I have no complaints.
    Battery Life: (1-10 scale 10 being perfect) 8
    Tethering WiFi/USB: (1-10 scale 10 being perfect) -
    Video Performance: (1-10 scale 10 being perfect) 9
    Your personal thoughts of the ROM: Like butter. Wow. Can't wait for it to get slimmed down so I can play with google voice again.
    g60madman likes this.
  16. g60madman

    g60madman Well-Known Member Developer

    Check out the new build in the MTDEV-CM9 thread MMS is now working, and also looks like the 3g is working a lot better. I will slim it some more on the next build.
  17. mr0chris

    mr0chris Guest

    This is weird but I'm getting wifi connection problems like we've had in the past. On fresh install it works fine for a but then it'll get stuck on "Turning on Wifi"
  18. calitrippin

    calitrippin Well-Known Member

    I had that problem too, but in my case it was cause by titanium backup, I think, since I went from CM7->CM9 think the wifi locations were restored and that screwed it up, reflashed and worked fine for me
  19. mr0chris

    mr0chris Guest

    That makes sense, I've been using Go Backup. I'll try reflashing and fresh installing everything
  20. AtticTRON

    AtticTRON Well-Known Member

    I tried this ROM for a few days and the two biggest issues I had were the 3g dropping every hour and the proximity sensor not working during a call. Everything else works great!
  21. zironia

    zironia Member

    Thanks for your hard work. Its very appreciated
    g60madman likes this.
  22. g60madman

    g60madman Well-Known Member Developer

    The new version on MTDEV-CM9 should be working perfectly. I have been using the ROM for over a day with no drops at all, and Wi-Fi now actually reconnects :)

    You bet!!! :D
  23. b_randon14

    b_randon14 Well-Known Member Developer

    Dude g60 this is epic I hope you realize this!! Ill try to look into the kernel errors when I can! I should have some free time here soon so ill check it out. Looks mostly like memory errors. Ill dig through the memory allocation code and see if I find anything interesting. It may be something simple in the config that works for the fb0 devices but not for ours.

    Ill look at the camera but I doubt I can be of much help there!!
  24. g60madman

    g60madman Well-Known Member Developer

    Trust me I know how epic this is!!! The major difference in mantera's port and tj's kernel is tg is using the 3G VMSPLIT where we are using 2G VMSPLIT in our conf file. That setting would make a lot of sense on how tj was able to fix the camera due to allowing more memory. I built a 3G VMSPLIT ROM last night which I can post up for you to test on if you want to go that route. It doesn't boot as the kernel is still 2G VMSPLIT, I didn't have the time to build the kernel as it was 1:00am and needed some sleep.

    I am also working with a lot of the fb0 devs from XDA. They recommend I start working on the KERNEL as no one has been able to make the kernel boot with CM unless they flash Android-ID with it. I am wondering if this whole time we have been spinning our wheels working on the .14 when the .7 was the way to go. I am going to spend some time on that tonight to see if I can make some headway. If I can get it to work, it shouldn't be to hard to patch the video drivers and we should be able to get it to work, and possibly camera as well?!?!

    Also brandon I was going to ask are you set on a DEV phone? Let me know, we just got done purchasing one for dsmryder, Chairshot and myself along with an 8B SD for Rukin thanks to the awesome user base we have!! GO COMMUNITY!! Let me know.
    jjohn7293 and sikk66 like this.
  25. b_randon14

    b_randon14 Well-Known Member Developer

    Hmm yeah maybe some changes took place in the updates to .14 that maybe throws a stick in the spoke when dealing with these devices. Also it could be not a mainline Linux change but a code aurora/msm change in between .7 and .14 that is causing the issue. So yeah I would say .7 may be the best bet for now if we can get it booting on that then we can patch like we did with the froyo kernels. And hopefully if we do get that booting, then the kernel side camera patches will fall into place as well as everything else and we could be seeing a sweet cm9 and cm10 mtdev rom!

    And I only have the one triumph, but I intend on saving to buy a gs3 and switch to straightalk but that may be quite a while down the road as I stay pretty broke around here. And you all by no means have to get me a dev phone, I haven't contributed much to mtdev and my development time is kinda slim as of right now. I mean dsm and chairshot and rukin all put in time fighting with code for mtdev and I haven't put hardly any work in!

Share This Page