Device compatibility issueSupport


  1. xtzyrkas

    xtzyrkas New Member

    Hi

    I am an owner of a Samsung Galaxy S GT-I9000, Firmware version 2.2.1 and I recently face the following problems.

    a. In the Play Store only a handful of applications are shown
    b. When I search for an application and find it whilst trying to install the following message appears "Your device isn't compatible with this version"

    Is it possible that you tell me what is the problem I face and is there any solution to it.

    Advertisement
    :
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    Welcome to the forums!
    It may be compatibility with your version of Android (Gingerbread, I assume). Some apps are 4.0+ only. Are their any in particular?
Loading...

Share This Page