Support Device doesn't turning on

Discussion in 'Samsung Galaxy Players' started by Kat_AS, Mar 7, 2013.

  1. Kat_AS

    Kat_AS New Member
    5

    Mar 7, 2013
    4
    0
    5
    Device: Samsung Galaxy Player. Android version: standard for this device (2.3 or something like this). Not rooted.
    when I was playing on it yesterday it suddenly shut down and I wasn't able to turn it on ever since. It starts to turning on, the word "SAMSUNG" appears on the screen and that's it. Nothing else happens until I take the battery off.
    The battery seems to be Ok (I've got 2 of them).
    Is there anything I can do to fix it by myself?
    Is it possible to save/copy any data from the device? PC currently can't see it. I didn't try factory reset and don't know whether I should.
     

    Advertisement
  2. exscentric

    exscentric Well-Known Member
    16

    Dec 5, 2011
    46
    8
    16
    A factory reset would loose data and any programs you have installed but might be what it needs.

    I'd be sure to plug it in with an adapter and be sure the battery is charging first however.
     
  3. Kat_AS

    Kat_AS New Member
    5

    Mar 7, 2013
    4
    0
    5
    It didn't help :bawling:
     
  4. exscentric

    exscentric Well-Known Member
    16

    Dec 5, 2011
    46
    8
    16
    What buttons did you use to reset it? I read somewhere it was power, volume + and home all at once but couldn't find anything in the book.
     
  5. Kat_AS

    Kat_AS New Member
    5

    Mar 7, 2013
    4
    0
    5
    Press Up button and without releasing it press and hold Power button. When the word "Samsung" appears on the screen release Power button but continue to hold Up. After a few seconds appears a screen where you can do a factory reset or clean cash.
     
  6. exscentric

    exscentric Well-Known Member
    16

    Dec 5, 2011
    46
    8
    16
    There was a trick on some of the old tablets, take the battery out and hold the power button for 30 seconds - might be worth a try????
     
  7. Kat_AS

    Kat_AS New Member
    5

    Mar 7, 2013
    4
    0
    5
    Nothing happend. It looks like something is broken and I can't do anything but to take it to the service center :(
    Anyways, thank you for your help.
     

Share This Page

Loading...